Configure Flash Builder 4.5 to use Flash Player 11 and AIR 3

I’ve seen several people ask how to set up Flash Builder 4.5 to develop applications that use Flash Player 11 and AIR 3 features. Here are the steps:

  1. Download playerglobal.swc from
  2. Copy it to [Flash Builder 4.5]/sdks/4.5.1/frameworks/libs/player/11.0.
  3. In Flash Builder > Project > Properties > Flex Compiler, set the minimum Flash Player version to 11.
  4. In the Flex Compiler properties, specify an additional compiler argument:

Graeme Bull of has created an (always) excellent video tutorial that walks you through the steps:

Setting Up Flash Builder 4.5 for Flash 11 and AIR 3 Apps