Adobe Reader Blog
Stay up-to-date on Adobe Reader…

Archive for November, 2008

November 4, 2008

Adobe Reader 8.1.3

For those of you who are using Adobe Reader 8.1.2, please update to Reader 8.1.3, which resolves several security vulnerabilities. To learn more about the update, please see Security Bulletin APSB08-19.

Bookmark and Share
11:07 AM Permalink