August 25, 2010

Patch for Adobe Captivate 5 to resolve Upgrade related issues

Install this patch to fix the issues that occur while upgrading earlier versions of Adobe Captivate projects to Adobe Captivate 5.

Installation Steps:

Windows:

  1. Take a backup of the file VeelaUpgrader.dll.
  2. Download the Zip File.
  3. Unzip the contents, rename AdobePatchInstaller.abc to AdobePatchInstaller.exe
  4. Double click set-up file. The patch gets installed, replacing the old VeelaUpgrader.dll file with the new one.

Mac:

  1. Take a backup of the VeelaUpgrader framework file.
  2. Download the attached file.
  3. Rename the Adobecaptivate-5.0-core-Update.zip to Adobecaptivate-5.0-core-Update.dmg
  4. Mount the dmg file and then install the patch installer.
  5. The patch gets installed, replacing the old VeelaUpgrader framework file with the new one.

Issues fixed:

When an earlier version of Adobe Captivate project is upgraded to Adobe Captivate 5, the following issues were observed:

  1. The output options specified in the Publish dialog box are not retained.
  2. Adobe Captivate 5 crashes when an Adobe Captivate 4 project containing a matching question slide with column 2 options at a higher z-order than column 1 options,  is opened in Adobe Captivate 5.
  3. If the earlier version of Adobe Captivate project had the ‘Contain’ operator in advanced actions, the script contents are not displayed in the project after the upgrade.
  4. If the earlier version of Adobe Captivate project  had Arial Regular font for matching question column 1, the font is changed to  Arial Narrow font  after the upgrade.
  5. The slides that were deleted in the earlier version of Adobe Captivate project are also shown in the TOC.
  6. A projectwith Audio of custom bit rate less than 32 kbps does not play the audio properly.
  7. Inverted quotes for answers in correct entries appear in Text Entry Boxes.
Posted by Vish10:27 AM
  • http://www.infosemantics.com.au Rod Ward

    On my Win7 64bit laptop, when I extracted the zip file there was no setup file to launch the update. Only a file called AdobePatchInstaller.abc and a directory called Payloads.

    I finally managed to get it to work by renaming the file as AdobePatchInstaller.exe and executing that.

    Hope this proves useful to other people that have the same experience.

    Rod

  • Vish

    Thanks for the info Rod, I’ve updated the steps to reflect the same.

    Thanks,
    Vish

  • http://www.tecwriter.de Martin

    Hi Vish,

    thanks for the patch but I can’t find the dmg file for my Mac …

    Thanks – Martin

  • Vish

    Thanks for bringing this up Martin. I’ve attached the dmg file and modified the steps to reflect the same.

    Thanks,
    Vish

  • http://www.tecwriter.de Martin

    Thanks Vish. I’ve published an article in my blog for all German users about this patch. Please visit: http://www.tecwriter.de/wordpress/captivate-5-zwei-patches-erschienen/

    Martin

  • John Stavros

    I followed the instructions. When I run the re-named EXE file, I get “Error loading Updater workflow.” My only option is to Quit.

  • Joshua

    Hello Vish. I downloaded and unzipped the updater, and ran AdobePatchInstaller.exe, but the installation failed. I couldn’t find any sign of a Setup file in the Captivate 5 Program Files folder or in the original CaptivatePatchInstaller Downloads folder.

    If you provide your email address, I can send you an image of the “Installation Failed” message in the Adobe Application Manager window.

  • Tim McDonnell

    Evening, I hope this is in the right place. I mention the following here because the context seems to be patching for issues opening earlier Captivate projects.

    I started with Cap 2 and then Cap 3 to complete my quizzes (projects with only questions and results) in 2008 and these have been taken by hundreds of people.

    Was sure hoping this patch would solve my nightmarish experience with a Cap 3 project opened and updated in Cap 5. The key issue is Cap 5 crashes consistently when I click on Preferences – Quiz – Pass Or Fail. (fresh new Cap 5 project works fine) I need to update the passing score and the ourcomes for Pass & Fail!

    Relatedly, I moved my 25 questions into a pool but a fresh Cap 5 quiz project cannot see this pool (Import Questions Pool), only a pool I made in 2008 for leftover questions? Why can’t it see the pool I created today? (Import Q + Browse (for what?) is a rather arcane selection method, sending a user on a scavenger hunt for pools to import)

    In summary, I don’t know if it’s the Cap 3 question slides are whack in Cap 5, corrupted preferences (did the move Adobe Captivate folder trick to write fresh preferences = NG) or I don’t know what.

    Are there any other patches I can try? If not, I don’t know what else to do. Thanks

  • John Thompson

    I can’t run the patch either, I get the “Error loading Updater workflow” message as well.

  • Sami

    Hi ! I´m loosing my mind and a lot of time, trying to fix these bugs:

    a- png images aren´t well supported. When I publish them, It appears a white border around the image. It didn´t happened on Captivate 4.
    My solution: I had to avoid any png image.

    b- Demo slides are completely broken. When I record a demonstration on a browser, Captivate doesn´t respect the positions of the input texts, or the dropdown menus, and when you publish the module, everything looks out of place.
    My solution: I resolved it by re applying the backgrounds of each demo slide and animating all the text inputs with the tool “Text animation” (In a large module like the one I had – 184 slides, it took me about 4 hours to fix this).

    c- Typing effect had to be done manually since it appeared in the wrong position in every case.
    My solution: I applied the “Typing” text animation manually in each case and had to simulate the audio also.

    d- When you try the “merge to background” option with any image, the objects don´t respect the position you set.
    Solution: I just pasted the images in different layers – This increases the module final weight.

    Please, I use Captivate since its version 3, and I really liked Captivate 4. But Unfortunately I cannot say the same with Captivate 5, since it turns my every day job to hell. PLEASE PLEAS PLEASE, I really need a path or whatever you can do to fix these bugs!
    I really appreciate your attention. Thanks in advanced!

    • Vish

      Hello Samanta, As we discussed in the meeting, we are working towards resolving the issue. Will keep you posted on this.
      Thanks,
      Vish

  • John

    When will there be a fix for the never-ending “Loading…” screen? I can’t believe something as simple as launching a published Captivate file doesn’t work…

    Please post a solution/patch for this ASAP? Currently, this not only makes me look bad for using Captivate to develop eLearning, it makes Adobe look awful.

  • http://www.RoboWizard.com Rick Stone

    I’m admittedly a bit confused with this.

    If I’m reading and understanding this correctly, one first has to be aware of this blog and actively monitoring it. So assuming you are, you see the blog post announcing the patch. So you have to manually download files, perform renaming and extracting and all that to get it installed.

    While I appreciate that this may allow you to be more nimble with providing updates, I have to say I’m a bit shocked that folks are expected to do this. Why isn’t there an official software update made available that folks just update Captivate and have it done?

  • Anne Flores

    This patch still doesn’t resolve my problem. I still try to open a .cp file and it gets 30% through, hangs up and then gives me an error. I have reloaded version 5 and reloaded the patch and still, it doesn’t work.

    • http://blogs.adobe.com/captivate/ Allen Partridge

      Anne, It sounds like you have something going on with your install or system. Can you send the file(s) that are having load failures and more info about the file(s)? You mention a cp file – are you on Captivate 5 or 4? Which OS are you using etc. I recommend submitting a bug report here: https://www.adobe.com/cfusion/mmform/index.cfm?name=wishform&product=5 (note to others, this link is always available right there on the right hand side of the Captivate Blog) – you’ll get a fairly quick reply and they should be able to help identify the source of the problem. The bug report will help ensure you can be reached and that the issue gets properly investigated.

  • Eric

    I have downloaded the file and it will not allow me to change the .abc file to .exe

    I hope you have a fix for this too.

  • Nicolle Brice

    The updator doesn’t work on my windows 7 64 bit laptop. “installation failed” Tried troubleshooting with Adobe Support Advisor, but no issues found. I need to try this update as my captivate 4 projects upon upgrade to version 5 have faulty slide audio.

  • Josh

    After installing this patch, I can no longer associate (WinXP SP3) .cptx files with Captivate 5. I have tried to manually set the associate but cannot set them to use the Capitvate 5 executable. The only way I have found to remedy this is to reinstall Captivate and not install this patch. Any ideas or suggestions?

    • http://blogs.adobe.com/captivate/ Allen Partridge

      Josh, I can repro this. have you submitted it as a bug to wish-captivate@macromedia.com ? — Allen

      • Josh

        Email now, thanks!

        • Josh

          Should be *emailing…. my Tuesday has already become a Monday.

  • Judi

    The patch did NOT fix my problem, and actually created a new problem for me. Now I cannot open my CP5 projects from within Windows Explorer because they now show the file association as Adobe Acrobat. When I try to change the file type association manually to the CP5 executable, it does not let me apply it. (The OK button remains grayed out.) Now I have to open Captivate and then open the file from within the active application. This creates an extra step I didn’t have to do before. How do I resolve this new and unexpected issue created by your unhelpful patch?

    I’m sort of resolving my audio issue by copying and pasting the slides from the original file into a new project file and then adding the audio. The audio now plays at the correct speed but the quality is still unsatisfactory compared with the quality I was able to achieve with CP3. I truly believe the audio problem occurred because I started the two problem files in CP3 and then updated them when I installed CP5. At the time I installed CP5, I had only completed a few slides in these lessons and had not yet recorded any audio, so I didn’t realize I was going to have a problem when I upgraded. I would have finished the lessons in CP3 if I had known, and now it’s too late because I have added several hundred more slides in the CP5 versions and can’t go backwards from CP5 to CP3. This is WEEKS of work we’re talking about to create these lessons and now my audience is going to have to suffer through inferior audio quality compared to the lessons I created in CP3.

    Even in the new files, when I create the audio in Audacity and import the MP3 into the Captivate file, it sounds “tinny” and somewhat “scratchy” no matter what settings I used to create the file in Audacity. The sound with the CP5 audio tool is better, but the editing features in CP5 are HORRIBLE!!!!! There’s not enough magnification to edit out tongue clicks and other distracting noises, and the other editing tools are also VERY limited. The editing capabilities in CP3 were better. Why did you take a step backward??????? Good audio quality is such an important part of elearning, so good editing tools are a MUST!!!!!! I tried creating WAV files in CP5 and then exporting to edit with Audacity, but when I imported them back into CP5, the quality was severely degraded.

    Overall, I’m extremely disappointed with the audio in CP5 and VERY, VERY sorry I chose to upgrade in the middle of this project. I still have another four lessons to create to finish this course so I’m going to have to apologize to my students for the inferior audio quality compared to what they were used to with the lessons I created in CP3.

    PLEASE PASS MY COMPLAINT TO THE CAPTIVATE DEVELOPERS – THEY NEED TO KNOW ABOUT THIS!!!!

  • marcd

    I am also experiencing the issue of not being able to open cptl files from windows explorer.

    CPTL file now seem to be associated with Adobe Acrobat and the file association cannot be modified in windows explorer. I select captivate5 from the list of programs but it never associates the program to the file type.

    Any help?

    • http://blogs.adobe.com/captivate/ Allen Partridge

      Marc, this file disassociation occured after installation of a minor hotfix. It’s resolved in the new patch. You can wait for the autodownloader to offer you the Captivate Patch, or download it from the links here.

    • Josh

      I second Allen’s response. I was experiencing this same problem and I uninstalled CP5 altogether then installed the new update patch and it works fine. I’m not sure if uninstalling is necessary though, I did it as part of my troubleshooting process.

  • David Gambal

    We recently upgraded to Captivate 5 where I work.

    I have a small project which uses a Flash Video (259,431 KB) on one slide.
    To put it into the Captivate 4 project, I clicked on Insert and then Flash Video
    This project works fine in Captivate 4.

    When I open the same project in Captivate 5 and then preview the project, the message “The flash video can not be loaded. The output may not be proper. (Slide…with the slide # for slides which contain flash videos). How do I correct this? Can I?

    In the meantime I copied all of the flash files to a new directory and rebuilt the project. Although this mostly works, there must be some way around this.

    Also in Captivate 5 if you click on Insert then Slide Video my project works ok, but no controls are available. When I click on Insert FLV or F4V File and go to preview the project everything works except this one slide’s video…..please help!!!

    Thank you,
    Dave

    • http://blogs.adobe.com/captivate/ Allen Partridge

      Dave it sounds almost like an AS2 issue. Is it a swf or a video file?

      • David Gambal

        Posted my comment below yours……forgot to hit reply……..

  • David Gambal

    Thanks for the reply……..it’s an FLV Video for Flash Player……….Is there a way to check if this video is AS2 or AS3? If it is AS2 is there a way to convert it?

    All the other videos in this presentation were created the same way and work ok although, they are much smaller, not sure if that matters.

    Please advise………

  • http://www.rebelou.com Annemarie Rebel

    Hi there.. I have been searching for days for a solution to my right click function not working with in CP5 published content. I have enable accessibility unchecked and I publish using the exe option. I have the latest flash player and I am really wondering why this is not working anymore… as it was fine in CP4.

    Any help / suggestions / ideas are greatly appreciated!!!
    Thanks a lot!
    Greetings from Holland
    Annemarie

  • David Gambal

    Anyone have any ideas how to make this work with Captivate 5?

  • Nagea

    I tried the patch but it says it failed, the installer has a problem???

  • R Hat

    Have not found a way to get the right click working in EXE files, but have in SWF.
    Publish as SWF, HTML and uncheck Accessibility options.
    Add the published SWF as flash trusted paths : this can be done by navigating to this url : http://www.macromedia.com/support/documentation/en/flashplayer/help/settings_manager04.html
    and adding the SWF path in the “Settings Manager” (this step is very important).
    You cannot get right click working if you view output, but it does work if you go to htm file and launch in a browser window. Good luck

  • Loading
  • Categories

  • Archives

  • Authors

  • Recent Comments

    • Radovan: Great news, but what about all already published content. Will be there any patch?
    • Chinmay Baid: We haven’t seen any issues so far on OSX. Can you please experiment and let us know if you face...
    • Lynne: I’m looking for hairdresser avatars for Captivate 8… do they exist?
    • C.R. Mudgeon: Are these playback issues found in OSX 10.7 as well? I am in the process determining viability of team...
    • mahw: sdf
  • Captivate & eLearning Videos

    Subscribe to Adobe eLearning on YouTube.

    Check out the latest eLearning Videos on AdobeTV

Recently Approved