November 26, 2010

Animations – Audio sync issue

A few of the users have observed that the animations which have some audio or flv video embedded in them, when used in Adobe Captivate, face sync issues. The embedded audio starts playing ahead of the actual timing of the animation which was leading to audio going out of sync. Worry no more, here is the solution. Our friend Srinandan, from Adobe Captivate team, has developed a widget to solve this issue.

You can download the widget from here. Try it out. The widget will make sure that audio is always perfectly in sync. Here are the steps to use the widget:

1.    Open your project in Captivate.

2.    Go to the slide where the animation is to be placed.

3.    Select Insert->Widget

4.    Browse to the location of widget

5.    Chose “AnimationWidget.swf”

6.    In the widget parameters, specify the swf file name that needs to be inserted

7.    Close the widget dialog

8.    Set the duration of widget equivalent to duration of animation specified in Step 6

9.    Repeat Steps 3-8 wherever an animation has to be inserted

10.  Publish the project

11.  Place all the animations in the same folder as published project.

Posted by vikramp11:20 AM
  • Pingback: Tweets that mention Animations – Audio sync issue « The Adobe Captivate Blog -- Topsy.com

  • Jared Bernotski

    Does this AnimationLoader.swf widget work in Captivate 4 published with AS3? I have tried publishing to Flash Player 9 and 10, and swf animations will not load. I have placed the swf in the published folder and followed all other steps listed above under “Here are the steps to use the widget.”

    Any swf that imports classes or has an associated .as file doesn’t work properly in Captivate. This isn’t just a problem with audio being out of sync. The issue is that swfs that work fine outside of Captivate, such as embedded in an HTML page, do not function when embedded in Captivate.

    I was hoping that this AnimationLoader widget would resolve the issue, but I can’t get it to work.

    Please help!

  • http://blogs.adobe.com/captivate/ Allen Partridge

    Jared, the animationLoader widget is for Captivate 5. If you are still using Cp4, ensure that the swfs are all of the same AS base type. IOW, if the Cp project is using AS2, then only AS3 Animations will work. Likewise you’ll need to use AS3 with AS3. Hope this helps some.

  • Jared Bernotski

    I have already checked that. All the swfs that I’m impoting are AS3, and the Cp project is using AS3. There is no mixing of AS2 and AS3, but regardless, swfs loaded into Captivate do not work if they import any classes, external libraries, or use .as files.

    Do you have an animationLoader widget for Captivate 4, or do you know where I could acquire one?

  • Rick

    I have an audience that is using Flash Player 7. Does this work with AS2?

  • Rina

    The widget helps with my audio issues but it enlarges the SWF file so you only see the top left hand side of the SWF.

    I am using Captivate 5 on a Mac.

    Any ideas to resolve the issue?

  • sravan

    How can i add voiceover to each sentence /sync each sentence

  • sravan

    please tell me the steps to sync eavh sentence?

  • Tim

    The widget seems to work good to correct the audio, however, by following the steps you posted I come up with one problem. I can’t get the animation to pause using Captivate’s playback controls. Any suggestions?

  • Doug Desilets

    I am using the widget as instructed and it will work fine if the swf files (with audio) are in the same folder but when I publish this to our Connect Server it doesn’t find the files. I published all the files to the same folder and the published course. Any suggestions or does this not work with Adobe Connect?

  • firefly

    This is going to be a pain as everytime you need to publish your file in order to see whether it’s playing correctly.

  • firefly

    Another problem is the audio still playing when i jump to different slides!

  • firefly

    This solved the audio sync issue but audio can’t stop playing even though you jump to a different slide so anyone knows how to fix this??

  • Junkbox726

    Wow, Adobe has done it again with Captivate. Considering I cannot efficiently develop a course without running into so many issues, I will probably lose my job. Thanks Adobe team in India.

  • Junkbox726

    By the way, this widget does not work. Please test your products!!!

  • Loading
  • Categories

  • Archives

  • Authors

  • Recent Comments

    • Lo' Roz: mmm good news but i try it and videos continue to not working on chrome 36 !!!
    • DaveC: I have created an e-learning package using captivate 7 which is free-roaming, non-linear and not used for...
    • Tracy J Windsor: I am having this same issue — The button / Clickable area does not work in Mobile view...
    • PaulB: Ive just switched from storyline to captivate 8 and I am having trouble with the responsive projects. It seems...
    • David: I can not preview the responsive layout on my project in Captivate 8. Anyone know why?
  • Captivate & eLearning Videos

    Subscribe to Adobe eLearning on YouTube.

    Check out the latest eLearning Videos on AdobeTV

Recently Approved