Adobe Connect Support Blog

Adobe Connect Add-in Compatibility with the Google Chrome Browser

Updated January 27, 2015:

Note: This article only applies to Adobe Connect on-premise server deployments. Adobe Connect hosted clients are unaffected.

The Google Chrome browser is currently shipping with two versions of the Flash plugin.  The default PPAPI and also the NPAPI Flash plug-in. The following versions of Adobe Connect installations are incompatible out of the box with the default PPAPI plug-in:

  • 9.1.2
  • 9.1.1
  • 9.0.1 – 9.0.4
  • 9.0.0.1
  • 8.2.2.4
  • 8.2.2

PPAPI plug-in incompatibility results in the Adobe Connect Add-in not being detected and launched in Chrome when invoked in a Connect Meeting. Even if the Add-in is installed, the meeting opens in the browser and not in the Connect Add-in. Upon attempting to share ones screen (a Connect feature supported in the Add-in but not in the browser), the following message appears:

chrome-addin.fw

Google Chrome, with the release of Version 40, will no longer use their whitelist to allow NPAPI  plugins to run without requiring approval: http://googleappsupdates.blogspot.com/2015/01/upcoming-changes-to-npapi-support-in.html Chrome users will not be able to use the Adobe Connect Add-in for the above listed versions of Connect. To address this problem, Adobe is patching the following Connect versions for use with Chrome:

  • 9.1.2
  • 9.1.1
  • 9.0.4
  • 8.2.2

These patches will fix the incompatibility problems with the PPAPI plug in. Adobe Connect servers that are not running one of these versions (or a later version) will need to be upgraded to the nearest later version to the one currently installed and then apply the appropriate Connect PPAPI patch.

There should not be any change in the behavior for Flash Player NPAPI in January because Flash Player is not listed among the applications  that are going to be removed in January:  http://blog.chromium.org/2013/09/saying-goodbye-to-our-old-friend-npapi.html

Workarounds until the patches are available:

  • You can attend Adobe Connect Meetings without the Adobe Connect Add-in, however the Add-in is required for enhanced functionality like screen sharing and making offline recordings.
  • Turn off auto-upate in Chrome so that you do not upgrade to a version of Chrome that is problematic.
  • Alternatively you can use any browser other than Chrome with Adobe Connect.
  • Manually enable NPAPI by clicking on the “Plug-in blocked” message in the URL bar and choosing “Always allow plug-ins on [website]” http://www.chromium.org/developers/npapi-deprecation

 

chrome-enable.fw

Note: In April 2015, this will no longer be an option as NPAPI support will be disabled by default in Chrome and Google will un-publish extensions requiring NPAPI plugins from the Chrome Web Store. Google will however provide an override for advanced users in the form of an ‘enable-npapi’ flag and enterprise policy to temporarily re-enable NPAPI.

Application, General, Meeting, Recording, Seminars