Adobe Connect Support Blog

July 7, 2017 /Database /Install /

Adobe Connect Error creating new meetings post 9.6.1 upgrade **Please Select an item**

Environment :

Adobe Connect 9.6 On Premise

Cause :

This may be noticed after an upgrade to Adobe Connect 9.6.1 on-premise solution. Some examples of the various symptoms that have been observed with this problem,

  • Error creating new meeting rooms from the application : “Please select an item”
  • Error moving users across system groups, “invalid operation error; access denied”
  • Error creating new users in the system, “Field permissions-mask of type 5 is missing”

To identify, append &mode=xml to the Adobe Connect url string in your browser where the error is received and run it. Example, https://xxx.adobeconnect.com/————-&mode=xml. Scroll down the bottom of the screen to see the XML message, you should find an error :  “Invalid error; Field permissions-mask of type 5 is missing”

Resolution :

This may occur if the SQL Server is not set to the right Compatibility level as per the supported recommendations. Verify the SQL server compatibility level and change it to SQL 2008 or higher via SQL Management Studio Express, or via executing this SQL query :

sp_dbcmptlevel ‘breeze’, 100

Here,  ‘breeze’ signifies the Adobe Connect Database name, if you have a different name for your Adobe Connect DB, replace it with the right name here. Once this is done, we will need to execute the DB scripts once again separately starting from the version the upgrade is attempted from, until 9.6.1.

Contact Support to get the DB scripts and steps to apply them if you are running into this.

Note : It is recommended to ensure you have a copy of a full backup of Adobe Connect Database and Adobe Connect contents/installation before applying any DB modifications or version upgrades.

 

Database, Install

Join the discussion

  • By Sergio Martin - 3:51 AM on July 8, 2017  

    Sushma,

    Does Connect 9.6.1 support SQL Server compatibility level “SQL Server 2012(110)”?

    Thanks,
    Sergio

    • By Sushma - 1:45 PM on July 10, 2017  

      Hi Sergio, Thanks for asking this question ! I assume anything higher than or equal to (100) should be supported until the level recommended in our Tech Specs . I am however consulting our Engg for a more official word to confirm as I write. Hope to have a feedback shortly !
      Regards, Sushma