Adobe AIR 1.5.3 Now Available

The Adobe AIR 1.5.3 runtime and SDK are now available for download. This release includes an updated version of Flash Player, security updates and several bug fixes. The developer release notes include critical information that all developers building AIR applications should be sure to read including important information related to certificate renewals (see earlier blog post) as well as bug fixes.

Highlights of some of the important changes in this release:

  • If you have deployed an existing Adobe AIR application using AIR 1.5.2 or earlier and you want to update your application to use the 1.5.3 namespace, you will need to specify the old publisher ID of your application in your descriptor. Instructions on how to find your publisher ID and specify it in your descriptor are described in the release notes.
  • The process for changing certificates in an update to a deployed application has changed. Beginning with AIR 1.5.3, certificate renewals will no longer be handled automatically and you will need to use the migrate feature of ADT. Please learn more about this topic by reading the release notes.

Critical issues fixed in this release:

  • When an intermediate certificate expires, it is no longer possible to sign an application with a renewed certificate (fixed by removing the publisher ID).
  • The AIR application installer crashes on Linux systems using AMD Phenom processors.

Important links:

Localized versions of the release notes for both developers and end users are also available.

If you have questions related to AIR 1.5.3, please leave us a comment.

Show Comments

Hide Comments

Comments are closed.