Using Flash Player 10.1 and AIR 2 in Flash Builder

I didn’t realized until Renaun blogged it that the Flex 4.1 SDK includes Flash Player 10.1 and AIR 2. One of the biggest pains for me during the beta period was copying over files and folders to merge the 4.0 SDK with AIR and Flash Player so I could do development in Flash Builder. I didn’t know they were doing a 4.1 that included both of the new runtimes.

That means you can grab the Flex 4.1 SDK, and using Flash Builder 4 you can add it to your list of SDKs and start taking advantage of the new APIs including multi-touch, geolocation, and socket server. As Renaun mentioned, make sure you target Flash Player 10.1 or above in your project when you’re selecting the new SDK or you won’t be able to use the new APIs.

Flash on!

Show Comments

Hide Comments

Comments are closed.