Acrobat/Reader 10: Save button not working for PDFs referenced from long URLs

Issue

If you are using Adobe Acrobat/Reader in Firefox/Chrome to view PDF files from long URLs you may notice that  the Save button is not working as expected.  It may be disabled (greyed out), or it may be enabled, but clicking on the button does not bring up the Save dialog to save the PDF to the local file system.

In some organisations the PDF files may be loaded from complex applications which require long URLs to serve parameters with the PDF.  For example:

http://helpx.adobe.com/content/dam/kb/en/837/cpsid_83709/attachments
/Acrobat_Enterprise_Administration.pdf?timestamp=t1115222011102&a=1234567890
123456789012345678901234567890123456789012345678901234567890123456789
&dkmtid=doc&ext=.PDF#FDF=http://server/XML.xfd

The URL above will show the PDF, but the Save button will not work as expected:

Reason

This is an issue with some versions of Adobe Acrobat/Reader 10 in Firefox/Chrome, and will be resolved in a later update for Acrobat/Reader.  The issue occurs when the URL contains more than 259 characters, as Firefox attempts to use this URL as the file-name in the Save dialog.  Such a long URL can exceed a file system limit and therefore the Save dialog does not appear.

Workarounds

  • Use shortened URLs to avoid the issue.
  • Use Acrobat/Reader in Internet Explorer.
  • Use Acrobat/Reader 9 with Firefox/Chrome.

Solution

This issue does not happen with the latest version of Acrobat/Reader 11, and will be fixed in a future release of Acrobat/Reader 10.

reference: (183411841/3319248)

VN:F [1.9.22_1171]
Was this helpful? Please rate the content.
Rating: 5.4/10 (14 votes cast)
Acrobat/Reader 10: Save button not working for PDFs referenced from long URLs, 5.4 out of 10 based on 14 ratings

One Response to Acrobat/Reader 10: Save button not working for PDFs referenced from long URLs

  1. Luis says:

    Hi,

    It also fails with Internet Explorer 9 and Windows 7. It works fine using Acrobat/Reader 9 in Internet Explorer.

    When would it be a new available update with this issue resolved?

    Thanks.