Posts tagged "FormDataTypeInstanceImpl"

LiveCycle: NoClassDefFoundError: com/adobe/workflow/datatype/form/FormDataTypeInstanceImpl

Issue

After performing an upgrade from LC7 to ES 8.2.1 and then trying to run a process in the LC7 compatibility layer, the process instance may stall at a User component with the following exception in the server log:

java.lang.NoClassDefFoundError: com/adobe/workflow/datatype/form/FormDataTypeInstanceImpl
at com.adobe.workflow.qpac.user.UserService.execute(UserService.java:221)
at com.adobe.workflow.engine.PEUtil.executeAction(PEUtil.java:551)
at com.adobe.workflow.engine.ProcessEngineBMTBean.executeAction(ProcessEngineBMTBean.java:1933)
at com.adobe.workflow.engine.ProcessEngineBMTBean.asyncExecuteActionCommand(ProcessEngineBMTBean.java:1878)
at com.adobe.workflow.engine.adobe_ProcessEngineBMTEJB_e5zjcz_ELOImpl.asyncExecuteActionCommand(adobe_ProcessEngineBMTEJB_e5zjcz_ELOImpl.java:2153)
at com.adobe.workflow.engine.ProcessCommandControllerBean.doOnMessage(ProcessCommandControllerBean.java:138)
at com.adobe.workflow.engine.ProcessCommandControllerBean.onMessage(ProcessCommandControllerBean.java:99)
at weblogic.ejb.container.internal.MDListener.execute(MDListener.java:429)
at weblogic.ejb.container.internal.MDListener.transactionalOnMessage(MDListener.java:335)
at weblogic.ejb.container.internal.MDListener.onMessage(MDListener.java:291)
at weblogic.jms.client.JMSSession.onMessage(JMSSession.java:4060)
at weblogic.jms.client.JMSSession.execute(JMSSession.java:3953)
at weblogic.jms.client.JMSSession$UseForRunnable.run(JMSSession.java:4467)
at weblogic.work.ServerWorkManagerImpl$WorkAdapterImpl.run(ServerWorkManagerImpl.java:518)
at weblogic.work.ExecuteThread.execute(ExecuteThread.java:209)
at weblogic.work.ExecuteThread.run(ExecuteThread.java:181)

Reason

The version of the User QPAC deployed in LC ES is not the updated version compatible with LC ES. It cannot interpret the lc7form variable type which is used in the LC7 compatibility layer when importing LC7 processes into ES.

Solution

Deploy the updated User QPAC available from:
LIVEYCYLE_HOME\configurationManager\plugins\upgrade-plugin\collateral

VN:F [1.9.22_1171]
Was this helpful? Please rate the content.
Rating: 0.0/10 (0 votes cast)