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Chapter 23: Importing Skins into Flex 
Builder

This topic describes how to create skins for Adobe Flex applications by using Adobe Flash CS3, Adobe Illustrator 
CS3, Adobe Photoshop CS3, and Adobe Fireworks CS3.
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About skinning
Skinning is the process of changing the appearance of a component by modifying or replacing its visual elements. 
These elements can be made up of bitmap images, SWF files, or class files that contain drawing methods that define 
vector images.

Skins can define the entire appearance, or only a part of the appearance, of a component in various states. For 
example, a Button control has eight possible states, and eight associated skin properties, as the following example 
shows:

The default skins for the up, over, and down states appear as follows:

A. up B. over C. down

State Skin property Default skin class

down downSkin mx.skins.halo.ButtonSkin

over overSkin mx.skins.halo.ButtonSkin

up upSkin mx.skins.halo.ButtonSkin

disabled disabledSkin mx.skins.halo.ButtonSkin

selectedDisabled selectedDisabledSkin mx.skins.halo.ButtonSkin

selectedDown selectedDownSkin mx.skins.halo.ButtonSkin

selectedOver selectedOverSkin mx.skins.halo.ButtonSkin

selectedUp selectedUpSkin mx.skins.halo.ButtonSkin
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Other controls have similar states with associated skins. For example, the RadioButton and RadioButton controls, 
which are subclasses of Button, also have an up, down, and over skins. The ComboBox control has skins the define 
the appearance of the control when it is in the disabled, down, and over states. 

All Flex components have a default skin class that ships with Flex, where a skin class can represent more than one 
state of the component. As you can see in the previous table, the eight states of the Button control use the same default 
skin class, mx.skins.halo.ButtonSkin, to draw the skin. Logic within the class determines the appearance of the 
Button control based on its current state. 

For more information on Flex skins, see "Creating Skins" in Flex Developer’s Guide.

Types of skins
You typically define a skin as a bitmap graphic or as a vector graphic. Bitmap graphics, called graphical skins in Flex, 
are made up of individual pixels that together form an image. The downside of a bitmap graphic is that it is typically 
defined for a specific resolution and, if you modify the image by scaling or transforming it, you might notice a degra-
dation in image quality. 

A vector graphic, called a programmatic skin in Flex, consists of a set of line definitions that specify the starting and 
end point of a line, its thickness, color, and other information required by Flash Player to draw the line. When a 
vector graphic is scaled, rotated, or modified in some other way, it is relatively simple for Flash Player to calculate the 
new layout of the vector graphic by transforming the line definitions. Therefore, you can perform many types of 
modifications to vector graphics without noticing any degradation in quality. 

One advantage of programmatic skins is you can create vector graphics that allow you a great deal of programmatic 
control over the skin. For example, you can control the radius of a Button control’s corners by using programmatic 
skins, something you cannot do with graphical skins. You can develop programmatic skins directly in your Flex 
authoring environment or any text editor, without using a graphics tool such as Adobe Flash. Programmatic skins 
also tend to use less memory because they contain no external image files.

The following table describes the different types of skins:

For more information on Flex skins, see "Creating Skins" in Flex Developer’s Guide.

About skinning with Adobe tools
You can create Flex skins using several tools from Adobe, including: Flash CS3, Illustrator CS3, Photoshop CS3, and 
Fireworks CS3. By supporting these different tools, Flex lets you use the tool that you are most familiar with to create 
your skins.

Skin type Description

Graphical skins Images that define the appearance of the skin. These images can JPEG, GIF, or PNG files, or they can be symbols 
embedded in SWF files. Typically you use drawing software such as Adobe Photoshop or Fireworks to create graph-
ical skins. 

Programmatic skins ActionScript or MXML classes that define a skin. To change the appearance of controls that use programmatic skins, 
you edit an ActionScript or MXML file. You can use a single class to define multiple skins. Typically you use drawing 
software such as Adobe Flash or Illustrator to create graphical skins.

Stateful skins A type of programmatic skin that uses view states, where each view state corresponds to a state of the component. 
The definition of the view state controls the look of the skin. Since you can have multiple view states in a compo-
nent, you can use a single component to define multiple skins. 
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The main difference between these tools is that Flash Professional and Illustrator let you create vector graphics for 
you skins, while Photoshop and Fireworks let you create bitmap graphics for your skins. For more information on 
the different types of skins, see “Types of skins” on page 674. 

Adobe supplies an extension for each tool that you install before you create your Flex skins. The extension includes 
utilities to create and export skins, and templates that let you edit the existing Flex skins, rather than having to create 
skins from scratch. 

Naming skin assets 
By default, Flex Builder only recognizes skins that use the following naming convention:

Style_Selector_Part 

where:

• Style specifies the CSS style type, and is typically the name of the component being skinned.

• Selector optionaly specifies the CSS style selector.

• Part specifies the style property of the component that corresponds to the skin, such as upSkin or downSkin 
for the Flex Button control.

For example, the skin named Button_upSkin defines the skin for the up state of the Button control and the skin 
named Tree_borderSkin defines the skin for the border of the Tree control. The Flex skins that you can modify by 
using one of the Adobe tools all use this naming convention.

If you define a custom component, and create skins for it using the Adobe tools, use the same naming convention to 
enable Flex Builder to recognize it and assign it to your component. For example, if you have a custom component 
named MyComponent with skin properties named borderSkin and mainSkin, your skins could be named 
MyComponent_borderSkin and MyComponent_mainSkin.

If you do not use this naming convention, you can still assign your skins to a component, but you will have to 
explicitly assign the skin when you import the skin into your Flex Builder project. 

Importing skins into Flex Builder
After you create and export your custom skins, you import them into your Flex application by using Flex Builder. 
When you import the skins, Flex Builder automatically adds the skins and a CSS file to your project, where the CSS 
file contains the style definitions necessary to assign your custom skins to Flex components. You can modify the CSS 
file as required by your application. Flex Builder also automatically add an <mx:Style> tag to your application to 
reference the CSS file. 

Using 9-slice scaling with skins
Flex supports the 9-slice scaling of skins. The 9-slice scaling feature lets you define nine sections of a skin that scale 
independently. The nine regions are defined by two horizontal lines and two vertical lines running through the 
image, which form the inside edges of a 3 by 3 grid. For skins with borders or fancy corners, 9-slice scaling provides 
more flexibility than full-graphic scaling.
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The following example show an image, and the same image with the regions defined by the 9-slice scaling borders:

When you scale skin that uses 9-slice scaling, all text and gradients are scaled normally. However, for other types of 
objects the following rules apply.

• Content in the center region is scaled normally.

• Content in the corners is not scaled.

• Content in the top and bottom regions is scaled only horizontally. Content in the left and right regions is scaled 
only vertically.

• All fills (including bitmaps, video, and gradients) are stretched to fit their shapes.

If you rotate the image, all subsequent scaling is normal, as if you did not define any 9-slice scaling.

For more information on 9-slice scaling, see "Embedding Assets" in Flex Developer’s Guide.

Tips for creating skins
Before you get started, here are a few tips for working with the skin template files that are part of the extensions added 
to each tool:

• Make your skins the same size as the skins in the template. If you change the size, you might have to edit the 
9-slice scaling grids as well.

• The CSS file created by Flex Builder assumes that the exported symbols names for the skins have specific names, 
so you should avoid changing the names of the symbols when creating skins. 

• The default Halo skins are semi-transparent, so that they can pick up the background color of their container. 

• Because of the way Flex handles scrollbars, the symbols for the different states of the scrollbar thumb skins are 
offset to the right by one pixel from the registration point. The Slider control and its highlight use similar adjust-
ments for alignment. Make sure any custom skins that you create are offset in the same way. 

Creating skins in Adobe Flash CS3
You can use Flash CS3 to create vector graphics for Flex skins. Before you can create Flex skins in Flash CS3, you 
must install the Flex Component Kit for Flash CS3. The Flex Component Kit installs the SWC file that contains the 
classes necessary to create assets compatible with Flex.

System requirements
Your system must meet the following requirements to install the Flex Component Kit for Flash CS3:
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• Flex 3 

• Flash CS3 Professional

• Adobe Extension Manager 1.8. You can download the Extension Manager from 
http://www.adobe.com/exchange/em_download/.

• Flex Component Kit for Flash CS3. For information on installing the Flex Component Kit for Flash CS3, see 
"Importing Flash CS3 Assets into Flex" in Flex Developer’s Guide. 

Install the Flex skins for Flash CS3
1 If you have not done so already, install the Flex Component Kit for Flash CS3. 

a Change the directory to install_dir/frameworks/flash-integration, where install_dir is the Flex installation 
directory.

b Double-click the FlexComponentKit.mxp file to install the necessary files in Flash CS3.

2 Download the flexbuilder3_sdext_b2_fl_100107.mxp file that contains the Flex skins and extensions for Flash 
CS3 from http://download.macromedia.com/pub/labs/flex/3/flexbuilder3_sdext_b2_fl_100107.mxp. 

3 Double-click the flexbuilder3_sdext_b2_fl_100107.mxp file to install the necessary files in Flash CS3.

Edit an existing skin in Flash CS3
1 Launch Flash. 

2 Select File > New.

3 Select the Templates tab in the New Document dialog box.

4 Select Flex Skins in the list of template categories.

5 Select the skin that you want to edit in the list of templates, or select flex_skins to edit all skins at once.

6 Double-click the skin part to edit it in place. 

7 Modify the existing skin, or delete the existing skin and draw your own.

When editing a symbol, make sure that you are aware of the registration point (the + sign in the upper-left corner 
of the symbol). Flex always aligns the registration point with the upper-left corner of the component. Therefore, 
make sure your skin’s upper-left point is at the + sign, except for scrollbar thumbs, which need to be offset one 
pixel to the right.

8 If the shape of your custom skin is substantially different from the original skin, for example, your corners are 
more rounded, or you made the skin larger, you might have to edit the 9-slice scaling grid.

a Right-click on the skin on the Stage and choose Edit. This opens a view that shows just the symbol you 
selected.

• If you do not see dashed lines, then the symbol does not use a 9-slice scaling grid.

• If you see dashed lines, they represent the 9-slice scaling grid. Drag the lines to specify how the skin 
should be scaled in each direction. For example, if you have rounded corners, make sure that they are fully 
contained in the corner quadrants of the 9-slice scaling grid.

b When you're done adjusting the 9-slice scaling, click on the back button in the upper-left corner of the 
document window to return to the main Stage.

9 Save your skins as a .fla file.

10 Select File > Publish to publish your skin as a SWC file in the same directory as the .fla file.
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Create a new skin in Flash CS3
If you install the Flex Component Kit for Flash CS3, you can create new skins in Flash CS3. The basic workflow is as 
follows:

1 In Flash CS3, select File > New to open the New Document dialog box.

2 Select Flash File (ActionScript 3.0) as the file type.

3 Create the skin.

4 Select the skin in the Library panel.

5 Select Command > Convert Symbol to Flex Component.

6 Save the .fla file

7 Select File > Publish to publish your skin as a SWC file in the same directory as the .fla file.

For more information an examples on creating skins using the Flex Component Kit for Flash CS3, see "Importing 
Flash CS3 Assets into Flex" in Flex Developer’s Guide. 

Import skins into Flex Builder
1 Start Flex Builder.

2 Select a project that uses your custom skins.

3 Select File > Import > Skin Artwork to open the Import Skin Artwork dialog box.

4 Under Import skins from, select SWC or SWF file.

5 Browse to the SWC file that contains your skins. 

6 When you select the SWC file, Flash automatically creates a CSS file with the same name as the SWC file, and 
adds the extension .css. You can rename this file by entering a different file name in the Create skin style rules in 
field.

7 Select Next to open the Import Skin Artwork dialog box.

8 Choose the Flex components that you want to skin

Remember that skins use the following naming convention Style_Selector_Part. By default, Flex Builder 
assigns skins to components based on the skin names. You can optionally use Style Selector and Skin Part in the 
Import Skin Artwork dialog box to explicitly assign a skin to a component. For more information on skin names, 
see “Naming skin assets” on page 675.

9 Select Finish. Flex Builder adds the SWC and CSS files to your project, and adds an <mx:Style> tag to your 
application file. 

10 Save, then run your application to see your custom skins, or view them in Design View in Flex Builder.

Creating skins in Adobe Illustrator CS3
Adobe Illustrator lets you create vector artwork for Flex skins. Some features of Illustrator are not supported when 
you export skins to a SWF file. For example, blend modes and effects, including drop shadows, may not display 
correctly. If you want to use these or other advanced Illustrator features, first test them with a single skin.
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System requirements
Your system must meet the following requirements to install the Flex Component Kit for Flash CS3:

• Flex 3 

• Illustrator CS3 

Install the Flex skins for Illustrator CS3
1 Download the flexbuilder3_sdext_b2_ai_100107.zip file that contains the Flex skins and extensions for Illus-
trator CS3 from http://download.macromedia.com/pub/labs/flex/3/flexbuilder3_sdext_b2_ai_100107.zip. 

2 Double-click the zip file and extract its contents to a temporary directory.

3 Copy the directory FlexSkinning/Scripts/Flex Skin folder to Illustrator_install_dir/Presets/Scripts, where 
Illustrator_install_dir is the installation directory of Illustrator CS3.

4 Copy the directory Templates/FlexSkins to Illustrator_install_dir/Cool Extras/Templates.

Create a skin in Illustrator CS3
1 Start Illustrator.

2 Set grid and snap preferences.

Your skins look best in Flex if all items are “on-pixel”, meaning their x, y, width and height values are integers, 
with no fractional part, and you set snap to a one-pixel grid. All symbol instances in the skin template are already 
placed on-pixel. 

a Choose Edit > Preferences > Guides and Grid.

b Under Grid, change Gridline every: to 10 px, and Subdivisions to 10.

c make sure that the View > Snap to Grid option has been selected.

3 Select File -> Scripts -> Flex Skin -> Create Flex Skin.

4 In the New Flex Skin dialog box, choose Multiple Flex Components to edit all Flex skins, or choose a specific 
component to skin. If you choose Multiple Flex Components, Illustrator opens a file containing all of the Flex skins.

5 Modify the skins as necessary. 

a Double-click the skin part to edit it in place. (You can also find and open the symbol from the Symbols 
palette.)

b Modify the existing skin, or delete it and draw your own.

c Some symbols have a 9-slice scaling grid, represented by dotted lines crisscrossing the symbol. If the shape 
of your artwork is substantially different from the original artwork, for example your corners are more rounded 
or you made the skin part larger, then drag the dotted lines to specify which parts should be scaled in which 
directions.

Note: Flex expects each skin symbol to have its registration point set at its upper left corner. All of the symbols in the 
skin template are preset with the correct registration point; if you create new skins, make sure to set “Flash Regis-
tration” to the upper left corner in the New Symbol or Symbol Properties dialog.

6 Save the .ai file

7 Select File -> Scripts -> Flex Skin -> Export Flex Skin and specify the name of a SWF file name to hold your 
custom skins.
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Import skins into Flex Builder
1 Start Flex Builder.

2 Select the project that uses your custom skins.

3 Select File > Import > Skin Artwork to open the Import Skin Artwork dialog box.

4 Under Import skins from, select SWC or SWF file.

5 Browse to the SWF file that contains your skins. 

6 When you select the SWF file, Flash automatically creates a CSS file with the same name as the SWF file, and the 
extension .css. You can rename this file by entering a different file name in the Create skin style rules in field.

7 Select Next to open the Import Skin Artwork dialog box.

8 Choose the Flex components that you want to skin.

Remember that skins use the following naming convention Style_Selector_Part. By default, Flex Builder 
assigns skins to components based on the skin names. You can optionally use Style Selector and Skin Part in the 
Import Skin Artwork dialog box to explicitly assign a skin to a component. For more information on skin names, 
see “Naming skin assets” on page 675.

9 Select Finish. Flex Builder adds the SWF and CSS files to your project, and adds an <mx:Style> tag to your 
application file. You can edit the CSS file as necessary for your application.

Note: - You might get warnings from Flex Builder in the form: "The CSS type selector 'AccordionHeader' was not 
processed, because the type was not used in the application." These warnings occur when you do not use a skin refer-
enced in the CSS file. 

10 Save, then run your application to see your custom skins, or view them in Design View in Flex Builder.

Creating skins in Adobe Photoshop CS3
If you're using Adobe Photoshop to create Flex skins, you create bitmap graphics instead of vector graphics. When 
using bitmap graphics for skinning, there are a few issues you should be aware of:

• Gradients in bitmaps only scale well in one direction. If you need to create artwork with gradients, and they 
might need to stretch in both directions, you might consider using Flash or Illustrator instead.

• Make sure that your custom skins use a single layer. 

• Photoshop does not currently support for 9-slice scaling grids.

• Photoshop outputs individual .png files for each skin, rather than a single file containing all the skins.

• Some features of Illustrator are not supported when exporting to SWF. For example, blend modes and effects, 
including drop shadows, may not display correctly. If you want to use these or other advanced Illustrator features, 
first test them with a single skin.

System requirements
Your system must meet the following requirements to install the Flex Component Kit for Flash CS3:

• Flex 3 

• Photoshop CS3 
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Install the Flex skins for Photoshop CS3
1 Download the file flexbuilder3_sdext_b2_ps_100107.zip that contains the Flex skins and extensions for 
Photoshop CS3 from http://download.macromedia.com/pub/labs/flex/3/flexbuilder3_sdext_b2_ps_100107.zip. 

2 Double-click the zip file and extract its contents to a temporary directory.

3 Copy the directory Presets to Photoshop_install_dir/Presets.

Create a skin in Photoshop CS3
1 Start Photoshop.

2 Select File -> Scripts -> New Flex Skin.

3 In the New Flex Skin dialog box, choose Multiple Flex Components to edit all Flex skins, or choose a specific 
component to skin. If you choose Multiple Flex Components, Photoshop opens a file containing all of the Flex skins.

4 Modify the skins as necessary. 

a Select the layer for the skin you want to edit. You can do this one of two ways:

• Find the skin in the Layers palette. The skins are organized by component name.

• Select the Move tool and then go to the Tool Options bar at the top of the screen, check Auto Select Layer, 
and clear Auto Select Groups. Now click on the skin you want to edit on the canvas, and the relevant layer is 
automatically selected.

b Edit the selected layer.

c Make sure that the rest of the layer outside of your skin remains transparent; Flex assumes that any non-
transparent parts of the layer are part of your skin.

d Make sure that skin do not overlap.

5 Hide the layer named _HIDE BEFORE EXPORTING, and hide the _Information layer if it exists.

6 Save the .psd file.

7 Select File -> Scripts -> Export Flex Skin and specify an output folder. The export operation creates a directory 
named assets that contains one .png file for each skin. 

Import skins into Flex Builder
1 Start Flex Builder.

2 Select the project that uses your custom skins.

3 Select File > Import > Skin Artwork to open the Import Skin Artwork dialog box.

4 Under Import skins from, select Folder or bitmaps.

5 Browse to the assets folder that contains your skins as .png files. 

6 When you select the assets directory, Flash automatically creates a CSS file with the name assets.css. You can 
rename this file by entering a different file name in the Create skin style rules in field.

7 Select Next to open the Import Skin Artwork dialog box.

8 Choose the Flex components that you want to skin, and the corresponding symbol.

Remember that skins use the following naming convention Style_Selector_Part. By default, Flex Builder 
assigns skins to components based on the skin names. You can optionally use Style Selector and Skin Part in the 
Import Skin Artwork dialog box to explicitly assign a skin to a component. For more information on skin names, 
see “Naming skin assets” on page 675.



ADOBE FLEX 3 BETA 2
Flex 3 Developer’s Guide

682

9 Select Finish. Flex Builder adds the SWF and CSS files to your project, and adds an <mx:Style> tag to your 
application file. You can edit the CSS file as necessary for your application.

10 Save, then run your application to see your custom skins, or view them in Design View in Flex Builder.

Creating skins in Adobe Fireworks CS3
If you're using Fireworks to create Flex component skins, you'll be creating bitmap graphics instead of vector 
graphics. When using bitmap graphics for skinning, there are a few issues you should be aware of:

• Gradients in bitmaps only scale well in one direction. If you need to create artwork with gradients, and they 
might need to stretch in both directions, you might consider using Flash or Illustrator instead.

• Photoshop does not currently support for 9-slice scaling grids.

• Fireworks outputs bitmap graphics for each skin as a .png file, rather than a single file containing all the skins.

• You might not want to skin the application background as a bitmap, since it's likely to need to scale in both direc-
tions. 

System requirements
Your system must meet the following requirements:

• Flex 3 

• Fireworks CS3 

• Adobe Extension Manager 1.8. You can download the Extension Manager from 
http://www.adobe.com/exchange/em_download/.

Install the Flex skins for Fireworks CS3
1 Download the flexbuilder3_sdext_b2_fw_100107.mxp file that contains the Flex skins and extensions for 
Fireworks CS3 from http://download.macromedia.com/pub/labs/flex/3/flexbuilder3_sdext_b2_fw_100107.mxp. 

2 Double-click the mxp file to install the necessary files in Fireworks CS3.

Create a skin in Fireworks CS3
1 Start Fireworks.

2 Select Commands > Flex Skinning > New Flex Skin.

3 In the New Flex Skin dialog box, choose Multiple Flex Components to edit all Flex skins, or choose a specific 
component to skin. If you choose Multiple Flex Components, Fireworks opens a file containing all of the Flex skins.

4 Modify the skins as necessary. 

Notice that this template doesn't use frames to represent the different states of an individual component; all skins 
are shown in a single frame.

a Select the layer for the skin part you want to edit. 

Adobe suggests turning on Single Layer Editing from the Layers panel context menu and then looking 
through the Layers panel to find the appropriate part to edit. Alternatively, you can leave Single Layer Editing 
off and just click on an item on the canvas, but make sure that any items you create are in the correct layer.
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b Delete the existing artwork and create your own artwork in that layer. You can create multiple objects if you 
like; they'll get flattened into a single bitmap graphic on export.

5 Save the .png file.

6 Hide the Web Layer layer, _Information layer, and _BASE layer. There is no harm in exporting them, but they 
produce extraneous files.

7 Select Commands > Flex Skinning > Export Flex Skin and specify an output folder. The export operation writes 
one .png file for each skin to the specified directory. 

Import skins into Flex Builder
1 Start Flex Builder.

2 Select the project that uses your custom skins.

3 Select File > Import > Skin Artwork to open the Import Skin Artwork dialog box.

4 Under Import skins from, select Folder or bitmaps.

5 Browse to the directory that contains your skins as .png files. 

6 When you select the assets directory, Flex Builder automatically creates a CSS file with the same name as the 
directory that contains the .png files. You can rename this file by entering a different file name in the Create skin style 
rules in field.

7 Select Next to open the Import Skin Artwork dialog box.

8 Choose the Flex components that you want to skin.

Remember that skins use the following naming convention Style_Selector_Part. By default, Flex Builder 
assigns skins to components based on the skin names. You can optionally use Style Selector and Skin Part in the 
Import Skin Artwork dialog box to explicitly assign a skin to a component. For more information on skin names, 
see “Naming skin assets” on page 675.

9 Select Finish. Flex Builder adds the SWF and CSS files to your project, and adds an <mx:Style> tag to your 
application file. You can edit the CSS file as necessary for your application.

10 Save, then run your application to see your custom skins, or view them in Design View in Flex Builder.
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	9 Select Finish. Flex Builder adds the SWC and CSS files to your project, and adds an <mx:Style> tag to your application file.
	10 Save, then run your application to see your custom skins, or view them in Design View in Flex Builder.



	Creating skins in Adobe Illustrator CS3
	System requirements
	Install the Flex skins for Illustrator CS3
	1 Download the flexbuilder3_sdext_b2_ai_100107.zip file that contains the Flex skins and extensions for Illustrator CS3 from http://download.macromedia.com/pub/labs/flex/3/flexbuilder3_sdext_b2_ai_100107.zip.
	2 Double-click the zip file and extract its contents to a temporary directory.
	3 Copy the directory FlexSkinning/Scripts/Flex Skin folder to Illustrator_install_dir/Presets/Scripts, where Illustrator_install_dir is the installation directory of Illustrator CS3.
	4 Copy the directory Templates/FlexSkins to Illustrator_install_dir/Cool Extras/Templates.

	Create a skin in Illustrator CS3
	1 Start Illustrator.
	2 Set grid and snap preferences.
	a Choose Edit > Preferences > Guides and Grid.
	b Under Grid, change Gridline every: to 10 px, and Subdivisions to 10.
	c make sure that the View > Snap to Grid option has been selected.
	3 Select File -> Scripts -> Flex Skin -> Create Flex Skin.
	4 In the New Flex Skin dialog box, choose Multiple Flex Components to edit all Flex skins, or choose a specific component to skin. If you choose Multiple Flex Components, Illustrator opens a file containing all of the Flex skins.
	5 Modify the skins as necessary.
	a Double-click the skin part to edit it in place. (You can also find and open the symbol from the Symbols palette.)
	b Modify the existing skin, or delete it and draw your own.
	c Some symbols have a 9-slice scaling grid, represented by dotted lines crisscrossing the symbol. If the shape of your artwork i...
	6 Save the .ai file
	7 Select File -> Scripts -> Flex Skin -> Export Flex Skin and specify the name of a SWF file name to hold your custom skins.

	Import skins into Flex Builder
	1 Start Flex Builder.
	2 Select the project that uses your custom skins.
	3 Select File > Import > Skin Artwork to open the Import Skin Artwork dialog box.
	4 Under Import skins from, select SWC or SWF file.
	5 Browse to the SWF file that contains your skins.
	6 When you select the SWF file, Flash automatically creates a CSS file with the same name as the SWF file, and the extension .css. You can rename this file by entering a different file name in the Create skin style rules in field.
	7 Select Next to open the Import Skin Artwork dialog box.
	8 Choose the Flex components that you want to skin.
	9 Select Finish. Flex Builder adds the SWF and CSS files to your project, and adds an <mx:Style> tag to your application file. You can edit the CSS file as necessary for your application.
	10 Save, then run your application to see your custom skins, or view them in Design View in Flex Builder.



	Creating skins in Adobe Photoshop CS3
	System requirements
	Install the Flex skins for Photoshop CS3
	1 Download the file flexbuilder3_sdext_b2_ps_100107.zip that contains the Flex skins and extensions for Photoshop CS3 from http://download.macromedia.com/pub/labs/flex/3/flexbuilder3_sdext_b2_ps_100107.zip.
	2 Double-click the zip file and extract its contents to a temporary directory.
	3 Copy the directory Presets to Photoshop_install_dir/Presets.

	Create a skin in Photoshop CS3
	1 Start Photoshop.
	2 Select File -> Scripts -> New Flex Skin.
	3 In the New Flex Skin dialog box, choose Multiple Flex Components to edit all Flex skins, or choose a specific component to skin. If you choose Multiple Flex Components, Photoshop opens a file containing all of the Flex skins.
	4 Modify the skins as necessary.
	a Select the layer for the skin you want to edit. You can do this one of two ways:
	b Edit the selected layer.
	c Make sure that the rest of the layer outside of your skin remains transparent; Flex assumes that any non- transparent parts of the layer are part of your skin.
	d Make sure that skin do not overlap.
	5 Hide the layer named _HIDE BEFORE EXPORTING, and hide the _Information layer if it exists.
	6 Save the .psd file.
	7 Select File -> Scripts -> Export Flex Skin and specify an output folder. The export operation creates a directory named assets that contains one .png file for each skin.

	Import skins into Flex Builder
	1 Start Flex Builder.
	2 Select the project that uses your custom skins.
	3 Select File > Import > Skin Artwork to open the Import Skin Artwork dialog box.
	4 Under Import skins from, select Folder or bitmaps.
	5 Browse to the assets folder that contains your skins as .png files.
	6 When you select the assets directory, Flash automatically creates a CSS file with the name assets.css. You can rename this file by entering a different file name in the Create skin style rules in field.
	7 Select Next to open the Import Skin Artwork dialog box.
	8 Choose the Flex components that you want to skin, and the corresponding symbol.
	9 Select Finish. Flex Builder adds the SWF and CSS files to your project, and adds an <mx:Style> tag to your application file. You can edit the CSS file as necessary for your application.
	10 Save, then run your application to see your custom skins, or view them in Design View in Flex Builder.



	Creating skins in Adobe Fireworks CS3
	System requirements
	Install the Flex skins for Fireworks CS3
	1 Download the flexbuilder3_sdext_b2_fw_100107.mxp file that contains the Flex skins and extensions for Fireworks CS3 from http://download.macromedia.com/pub/labs/flex/3/flexbuilder3_sdext_b2_fw_100107.mxp.
	2 Double-click the mxp file to install the necessary files in Fireworks CS3.

	Create a skin in Fireworks CS3
	1 Start Fireworks.
	2 Select Commands > Flex Skinning > New Flex Skin.
	3 In the New Flex Skin dialog box, choose Multiple Flex Components to edit all Flex skins, or choose a specific component to skin. If you choose Multiple Flex Components, Fireworks opens a file containing all of the Flex skins.
	4 Modify the skins as necessary.
	a Select the layer for the skin part you want to edit.
	b Delete the existing artwork and create your own artwork in that layer. You can create multiple objects if you like; they'll get flattened into a single bitmap graphic on export.
	5 Save the .png file.
	6 Hide the Web Layer layer, _Information layer, and _BASE layer. There is no harm in exporting them, but they produce extraneous files.
	7 Select Commands > Flex Skinning > Export Flex Skin and specify an output folder. The export operation writes one .png file for each skin to the specified directory.

	Import skins into Flex Builder
	1 Start Flex Builder.
	2 Select the project that uses your custom skins.
	3 Select File > Import > Skin Artwork to open the Import Skin Artwork dialog box.
	4 Under Import skins from, select Folder or bitmaps.
	5 Browse to the directory that contains your skins as .png files.
	6 When you select the assets directory, Flex Builder automatically creates a CSS file with the same name as the directory that contains the .png files. You can rename this file by entering a different file name in the Create skin style rules in field.
	7 Select Next to open the Import Skin Artwork dialog box.
	8 Choose the Flex components that you want to skin.
	9 Select Finish. Flex Builder adds the SWF and CSS files to your project, and adds an <mx:Style> tag to your application file. You can edit the CSS file as necessary for your application.
	10 Save, then run your application to see your custom skins, or view them in Design View in Flex Builder.






