March 13, 2008

Lightroom 1.4, Camera Raw 4.4 now available

Adobe has released updates to Photoshop Lightroom (Mac|Win) and the Photoshop Camera Raw (Mac|Win) plug-in, both available immediately for download from Adobe.com or via the Adobe Update Manager (choose Help->Updates from within Lightroom or Photoshop). The releases provide added raw file support for nine additional digital cameras, including the Canon EOS 450D and Nikon D60–bringing the total number of supported cameras to nearly 200. Lightroom 1.4 also provides updated printer driver compatibility for Apple Leopard Mac OS X 10.5.

Canon

  • EOS 450D

Fujifilm

  • S100FS

Nikon

  • D60

Olympus

  • SP-570 UZ

Pentax

  • K20D
  • K200D

Sony

  • A200
  • A300
  • A350

According to the release notes, Lightroom 1.4 and Camera Raw 4.4 include corrections for the following issues:

* Previous camera profiles identified in the Calibrate panel of the Develop module may have displayed poor results at extreme ends of the temperature and tint ranges. A new camera profile identified as Camera Raw 4.4 is now available and will be applied by default to all images without existing Camera Raw or Lightroom settings. The creation of new default profiles will also include the updated Camera Raw 4.4 profile. Images edited in Camera Raw or Lightroom with earlier profiles will retain the earlier profile value and visual appearance.

* In previous grayscale conversions the Color Noise setting was disabled and this could result in an image with excessive noise when grayscale channel mixing is applied.  Both the tool and effect have been enabled in Lightroom 1.4 and Camera Raw 4.4 providing the ability to reduce noise in grayscale conversions.  In order to return to the prior visual appearance, Color Noise reduction can be set to zero.

Lightroom 1.4 includes corrections for the following issue:

* Compatibility with legacy printer drivers on OS X 10.5 (Leopard) has been updated.

Posted by John Nack at 11:19 PM on March 13, 2008

Comments

  • A. Dias — 10:17 PM on March 13, 2008

    John:
    It appears that Lr 1.4 fixed the OS X 10.5.2 (legacy) printer compatibility. CS 3 continues to have that problem though. Any plans to fix that soon?
    [I’ll ask about this one. If you have more specifics to share, please pass them along. –J.]

  • chris — 10:45 PM on March 13, 2008

    John
    1.5.1 should allow edit as smart object.
    Just one little feature could make so many things so much easier …
    Do we need to beg or can we just all send you guys beers?
    [Heh–patience, patience (but feel free to send beers anyway). ;-) –J.]

  • Elja Trum — 9:13 AM on March 14, 2008

    No big changes, but the added support for new camera’s is always welkom. :)

  • Ollivier Robert — 9:56 AM on March 14, 2008

    Thanks for getting this new version so fast with K20D support!

  • Rudi — 4:43 PM on March 14, 2008

    Photoshop CS3 Update Manager is not picking up Camera Raw 4.4 for me – on either of my two machines! I’m assuming that this will eventually be fixed… Lightroom update A-OK. :-)
    [Yeah, sorry about that: I’m told that the AUM posting was delayed by a couple of days, but that the files will be there shortly. In the meantime you can grab the exact same bits from Adobe.com. –J.]

  • Ben — 6:11 PM on March 14, 2008

    Does this solve the problem with printing to an Epson R1800 (and similar) under OS X Leopard where the color and brightness are way off? That would be *wonderful* news!

  • Amaziah Brown — 7:59 PM on March 14, 2008

    Camera Raw 4.4 (WindowsXP) does not show thumbnails for Pentax .pef files or previously converted .dng files (from .pef via ACR 4.3.1) in Bridge (latest). But ACR 4.4 will open files when hosted by Photoshop!
    Suggestions appreciated.
    [I’m not sure, but you might want to try purging the Bridge cache (Tools->Cache->Purge Cache). –J.]

  • Andy — 3:58 AM on March 16, 2008

    Hello John!
    Hope you and your family are well!
    Please accept my apologise for posting a rather long message about a problem I am experiencing with LR, but you have been very helpful in the past with solving a language setting problem with LR.
    I am running PS CS3 and LR on Win XP. My LCD is profiled with a Gretag i1 Display and I’m using a custom profile for my Canon printer. The colours that I see in LR and PS match those that are printed. However when I export the files from LR into sRGB JPG files for sharing or web viewing and open the photos in CM unaware software like Windows file viewer or a web browser the colours are less saturated, have less contrast and look slightly warmer (a very slight yellow and magenta tint). I know that this might be due to the inability of these programmes to use the embedded profile. Hence I chose to convert them into the sRGB colour space. Nevertheless the photographs I view in forums like this one, on website or Flickr look better. In comparison mine lack contrast, vibrancy and the colours don’t look as right anymore as they do in LR or when printed.
    Gian described a similar problem in this thread (http://luminous-landscape.com/forum/index.php?showtopic=21492) but there weren’t any helpful solutions put forward. Nik’s suggestion (http://luminous-landscape.com/forum/index.php?showtopic=21492&view=findpost&p=159455) is a workaround but it really counteracts the advantages of using Lightroom in the first instance. Why should I adjust my RAW files in Lightroom first, when I need to use PS anyway to produce pleasing JPG conversions.
    Am I making a mistake in my export/conversion process? Or do I have to adjust my workflow or the settings before exporting photos for viewing in CM unaware programmes?
    I thank you very much for your kind feedback and for helping me improve my post-processing skills!
    All the best,
    Andy
    [We’re all good here, Andy, thanks–just very tired. :-) I don’t know much about the issues you’re encountering, so I’ll pass this along to the LR guys for input. –J.]

  • Gregg Mack — 6:31 PM on March 16, 2008

    John,
    I updated Lightroom to 1.4, Camera Raw and DNG Converter to 4.4 and the update went flawlessly.
    But then things started to go awry as I tried to use the Web Module in Lightroom. Right after the progress indicator in the upper left corner of my Lightroom window showed completion, I got a very disconcerting message that non of the source files could be located, and it listed them all by name. Very strange, as the web gallery was actually created, and using Windows Explorer, and then Bridge CS3 revealed all of the source DNGs were right where they should have been.
    My second clue that something was not right was to move into the Develop Module, where an “unknown error type” was reported. I closed Lightroom and used Bridge to go into the folder with the DNGs. The previews/thumbnails looked OK, but opening the DNG files in Camera Raw 4.4, I got a big red “X” in the upper right corner of the image and a message saying something about the DNG file being “damaged”. Of course my heart skipped a beat or two. I shut it all down and went for a walk around the neighborhood, which allowed me some time to think about what to do next.
    After returning, I went to the Adobe Download site and attempted to re-download the installation programs, thinking that maybe my previous download had somehow gotten corrupted. When I got the Lightroom 1.4 download page, there was a strong, bold message advising people to revert back to Lightroom 1.3.1 and Camera Raw 4.3.1.
    I did that, and everything seems to be fine, and the DNG files that I had touched (damaged?) with the newer versions of the software appear to be intact and survived OK.
    Next time I think I’ll wait a week or so after I first see the update message pop up when I open Lightroom.
    Gregg Mack
    [Thanks for the info, Gregg, and sorry to hear that you’ve hit a snag. I’ve passed the info along to the LR team for review. –J.]

  • Djordje — 6:52 AM on March 18, 2008

    Hello everyone,
    This is regarding the issue with the latest update and Adobe’s suggestion that we go back to 1.3.1. How do I go back to 1.3.1? Do I just install it over 1.4 OR do I uninstall 1.4 first?
    If the latter, what will happen to my catalog if I uninstall 1.4 first?
    Please advise.
    Thank you!

  • Gregg Mack — 6:09 PM on March 18, 2008

    Djordje,
    I uninstalled 1.4 first, and them reinstalled 1.3.1.
    My catalog and presets were OK after I was back at 1.3.1.
    Gregg

  • Justin Keery — 1:57 PM on March 28, 2008

    To echo post above by Amaziah Brown… ACR 4.4 is not showing thumbnails for Pentax K20D PEF files despite clearing caches and all the things you’re supposed to do. Very annoying indeed, spoiling the fun of my new camera. I hope posting here (since I am still evaluating the new version) will feed through to the developers. Thanks!!

Copyright © 2014 Adobe Systems Incorporated. All rights reserved.
Terms of Use | Privacy Policy and Cookies (Updated)