September 23, 2009

AppleScript compatibility with Photoshop on Snow Leopard

Photoshop scripting expert Jeff Tranberry has passed along some useful info:

If you’re using AppleScript to automate Photoshop on Mac OS X 10.6 (Snow Leopard), you’ll want to update the Adobe Unit Types.osax scripting addition.

The Adobe Unit Types.osax file that ships with Photoshop CS4 and CS3 is a 32-bit component. Snow Leopard requires some scripting environments to be 64-bit.

Please see the following Knowledge Base article for additional details: Error about unit type conversion occurs when you run an AppleScript in Photoshop (Mac OS X 10.6)

7:12 AM | Permalink | Comments [11]
Copyright © 2014 Adobe Systems Incorporated. All rights reserved.
Terms of Use | Privacy Policy and Cookies (Updated)