December 26, 2011

Mac nerd friends: A little help here?

“Hello, my name is John, and I practice unprotected computing…” (“Hello, John.”)

Until I upgraded my Mac to Lion, I was a rigorous user of Time Machine: I’d plug in a Drobo at work, and I’d connect to a Time Capsule at home. It paid off when my hard drive died & my bacon was saved.

Ever since moving to Lion, though, I’ve been unable to back up. Connecting to either backup produces a “Preparing to back up” cycle that can last for hours or even days. It’s unusable to the point that I think I should just wipe the backups and start fresh.

Here’s where more problems ensue, however:

  • Deleting the backup from the Drobo was incredibly slow, to the point that I reformatted the drives and thus somehow rendered them inoperable (!). I need to carve out time to work with Drobo tech support, but I haven’t been able yet.
  • I can’t wipe my Time Capsule (which contains other data), and due to space constraints, I can’t start a new Time Machine backup without trashing the first. I fear the process taking more hours or days.
  • Okay, fine–for now I’ll just buy a new, fresh, cheap hard drive. Without doing research (!), I grabbed a big Seagate 2TB USB 3.0 drive. “No prob,” I figured, “this thing should be USB 2.0-compatible and more future-proof.” Now, however…
  • After reformatting the drive, Time Machine backups continuously fail. Things seems to go great for tens or even hundreds of GB of data–then simply stall out forever. This has happened several times, always at different points, even across reformatting.
  • Okay, fine–forget Time Machine, let’s do Carbon Copy Cloner. Unfortunately, even after reformatting (again) per CCC’s instructions, the backup failed ~66GB in. Given the TM failures, I’m not inclined to try again.

So, here’s what I’m wondering:

  • Is there something wrong with the data on my Mac–something that would cause old backups to stall & new ones to fail?  And if so, is there a diagnostic I can run to find & hopefully fix the problem?
  • Is there something screwy with Mac OS support for USB 3.0 devices?
  • Is there something screwy with this particular drive?

My Google-fu has failed to provide a solution, so thanks in advance for any guidance you can provide.

Posted by John Nack at 2:34 PM on December 26, 2011

Comments

  • Robert Sinclair — 2:51 PM on December 26, 2011

    I’ve had a number of problems with backups after upgrading to Lion as well. According to the various NAS manufacturers (including Drobo), Apple royally screwed up support for NAS devices, sending all of them scrambling to provide fixes. Some released patches right away, others are still struggling to get things working again.

    I’ve tried doing Time Machine backups (WITH the suggested fixes) on a Drobo and Synology NAS and they continue to fail, even after multiple emails with Tech Support. While I found Drobo customer service excellent, ultimately I had so many problems with the device (including fonts not appearing in the Drobo Dashboard after upgrading to Lion, rendering the device unusable), that I eventually sold the unit and cut my losses.

    [That's a shame. I've been very happy with mine over the years (speed not being a huge priority), and they seem like good folks. --J.]

    I’m in the middle of trying to get TM working on my Synology NAS now, and am also having trouble with the voodoo steps required to get TM working. Tech support has told me I need to run a special “sh” script they’ve provided that manually creates the sparsebundle file required for TM compatibility, but so far it’s still not working.

    I think users are going to continue to have TM problems until either Apple addresses the NAS issues at a system level, or the third-party manufacturers have had time to develop reliable solutions.

    So far the outlook is NOT good. It’s been awhile since Lion has been out, and so far the solutions I’ve seen are essentially “hacks” that are not working.

    [Hmm--thanks at least for letting me know I'm not alone. --J.]

  • Doug Otto — 3:01 PM on December 26, 2011

    The last time I had issues with a TM backup like that, the error was actually on my source disk.

    Boot the recovery partition (CMD+R) during boot and run the disk utility.

    [I'd love to try that, but my efforts to build a recovery partition (via CCC) have hit a wall. --J.]

    First run a repair of the partition and then check permissions.

  • Rob Fahrni — 3:13 PM on December 26, 2011

    John,

    I know this won’t help you fix your Time Machine problem, but it will help you get a solid backup.

    http://www.shirt-pocket.com/SuperDuper/SuperDuperDescription.html

    [Cool--I got a similar recommendation via Twitter; thanks. --J.]

  • Darren — 3:23 PM on December 26, 2011

    Guess you have checked the log files for time machine to see if there is a file / files causing it to fail – I had a similar problem caused by a hidden file with a long name which excluding the folder then let time machine complete

    [I haven't tried that, but it sounds like a decent suggestion. Any idea where those log files live? I'll go a-Googling. --J.]

  • sbg — 3:48 PM on December 26, 2011

    I’ve had the same problems, but with trying to back up to a single external USB drive. No solution, but I thought it might help eliminate the Drobo variable to some degree.

  • Thomas Brand — 3:55 PM on December 26, 2011

    John I would start by booting into recovery mode (CMD + R at startup) and checking your disk for errors and permissions issues. Often a Time Machine backup will fail due to errors on the source disk.

    If everything checks out okay try formatting your USB 2.0 drive again. Make sure that you are using the partition tab in Disk Utility, and that you are choosing the Apple Partition Map and HFS+ Journaled as your volume format.

    Next select the newly mounted disk as your time machine volume, but try excluding items outside of your Home folder from the the backup. (This can be accomplished in the Time Machine preference pane options.) If you can get a good backup of your home folder going try backing up the rest of your systems files and applications.

    P.S. Your Drobo should only be formatted using the Drobo Dashboard utility. You should download the latest version of the Drobo Dashboard after upgrading to Lion, and try formatting it again.

    Best of Luck and happy holidays, Tom Brand

  • Marty Cohen — 4:14 PM on December 26, 2011

    john…

    I like the SuperDuper suggestion because, as a regular user, I’ve run into a similar situation and it was relatively easy to look through the SuperDuper log to get a clue as to the specific file causing the problem. In SuperDuper run the copy until it fails, then go to the Window Menu and choose “Show Log”.

    It might be tedious to find, but I would also vote for a corrupted file that is causing the stall.

    Hope you find the solution without too much trouble. Let us know…
    Happy New Year (especially once the issue is solved).

  • Rod Wynne-Powell — 5:04 PM on December 26, 2011

    John,

    Sorry to hear your woes.
    It is difficult to assess exactly where you are now, after the various steps you have taken, and since I had similar instances of procedures that once worked flawlessly now fail when you need them most.
    I have read the several suggestions and seen no mention of Chronosync, but several colleagues swear by this rather than SuperDuper or Carbon Copy Cloner, however the last has been my choice, its one snag being the destination disc volume has to be erased.
    At first I was under the impression this meant the entire disc, but it means a partition, so provided this has ample capacity there need be no need for concern, just ensure there is a good amount free for the Recovery partition in addition to what is shown in Get Info.
    I am not sure how USB 3.0 fits with the Mac connection of USB 2.0, and bearing in mind that it is far slower than FW800, can you not get hold of a Firewire 800 drive?
    Also, it is important that you have checked your source for any corruptions, and if it reports that it has repaired anything run the recovery a second time, such that it confidently reports that ‘Macintosh HD’ appears OK!
    I have experience a brand new Mac with a recovery partition that reports an error “Recovery Partition does not checksum” which is kinda handy!
    You can check this out using Target Disk Mode. Connect the offending Mac in TDM to another Mac running Lion via Firewire 400 or 800 and start it using Command + R or choosing the Recovery Partition after starting holding down the Option/Alt key.
    You will see both the visible and otherwise hidden volumes, and can use Disk Utility from Utilities in the menu bar to run a check on the other Mac.
    Running Disk Utility externally often proves more effective than from the Startup disc, and is far faster than from a DVD (Note I only mention this in passing as Apple in its infinite wisdom no longer supplies such medium!)
    I was able in this way to bypass an initial internal hidden volume to give access to Lion’s recovery system.

    I am more than aware that some of what I have suggested will be known to you so please do not be offended.

    You do appear to be luckier than many with Drobo, I know several who have been far less lucky, but I have no personal experience in that area.

    I am not sure you know my issues with Lion, but it has caused me immeasurable grief, and if I could return to 10.6.8, I would be over the moon!

    By all means I will happily see if remotely I can help, I am on both Skype and iChat and obviously there is Connect, but I find that less useful, sorry Adobe!

    Happy New Year,

    Rod

  • J. Peterson — 6:51 PM on December 26, 2011

    Yet another vote for SuperDuper. Simple and effective; I’ve been using it at home for years, to back up to a local homebrew fileserver.

    At work we have CrashPlan…never tried to actually recover something from it yet. Have you?

  • tPet — 9:10 AM on December 27, 2011

    Like others .. I’m thinking the issue is also the source disk .. I haven’t had a problem with Time Machine at all since my Lion upgrade .. I am backing up via Firewire, which shouldn’t make a difference .. but might.

    At the very least … try running Repair Permission via the Disk Utility .. which is the Mac OS X version of rebuilding the desktop .. usually .. nothing .. but every once in a while, it actually does something useful.

    Also .. as a control .. try setting up a new user on your Mac and try a Time Machine backup from a clean account .. see if this issue might be a corrupt user preference or something.

    Dems my two cents anyway …

  • Eric Peacock — 9:49 AM on December 27, 2011

    Another vote for SuperDuper here — it does work on Lion and the log file can be useful when it fails though this rarely happens to be with nightly 6 terabyte syncs.

  • Mario — 9:59 AM on December 27, 2011

    I also feel your pain. After updating to Lion I had to erase an old TM backup and start all over again. What I don’t get about your post is how did you back up with time machine to a drobo and a time capsule? I can´t do that, it only lets me back up to a single location (on Snow leopard I haven´t tried that with Lion)

    [I had two entirely separate backups going, and I'd have to manually switch the disk via TM prefs. That was a moderate pain and kept me from backing up as reliably as I'd have liked (i.e. I couldn't set things up such that I'd simply plug in USB at work (Drobo) or connect to WiFi at home (Time Capsule). --J.]

  • AlexSkortos — 4:09 AM on December 28, 2011

    You can check this out using Target Disk Mode. Connect the offending Mac in TDM to another Mac running Lion via Firewire 400 or 800 and start it using Command + R or choosing the Recovery Partition after starting holding down the Option/Alt key.

  • ScooterComputer — 7:41 PM on December 28, 2011

    [Seeing as how I just made fun of Photoshop, karma insists I try to do some good…]

    I’ve seen issues with the Seagate FreeAgent GoFlex Desk USB 3.0 drives. Take a look over at the Seagate forums. The problem is between the Mac and the USB 3.0 dock/chipset. Users were reporting that if they purchased the 2.0 dock or the Firewire dock and used it with the exact same drive, problem went away. Seagate Support’s aware of it, but (somewhat like Adobe) they don’t give a hoot…they’ll lead you on a goose chase of KEXT requirements and useless hd utilities installations.

    I recommend getting a FW dock for that drive or buy a different vendor’s drive (from a vendor that doesn’t suck). ((Better yet, tear the drive out of that crappy enclosure and buy yourself a good bare enclosure from wiebetech.com or MacSales.com with an Oxford bridgeset.)) And then do either a CCC or SuperDuper clone right off the bat. Then try a fresh TimeMachine backup.

    [You're pretty intent on using USB, which makes me wonder: are you on a MacBook Air without FireWire?]

  • Shangara Singh — 5:16 AM on December 29, 2011

    Try TM Error Logger:
    http://www.addictivetips.com/mac-os/analyze-mac-time-machine-error-logs-with-tm-error-logger/

    To find the activity for Time Machine, type backupd in the Search box in Console. Never had an error, so not sure if problem file will be listed (I would think so).

    Following “may” be useful:
    http://www.bluedog.com.au/default/Time_Machine_Buddy.html

  • Kai Howells — 2:30 AM on December 30, 2011

    I’m guessing it’s file system corruption on the SOURCE volume.

    Boot in safe mode (it runs a fsck on the boot volume).
    Reboot
    Repair Permissions.
    Try again (yes, it’s a pain that it’ll take a couple of days before you find out if it’s worked).
    If this fails, boot off a separate volume and run Disk Warrior over your boot volume.

    If you want to find out what file is causing Time Machine to freak out, in the In Progress backup in the time machine volume, there are actually hidden log files that give you a lot more detail. Some terminal-fu is required to get at them.

    If CCC is failing as well as Time Machine, then other backup utilities are very likely to fail too. All things point to source volume corruption in the directory structure. Disk Warrior will most likely fix this, it’s been very (very!) good to me in the past and goes far beyond what Disk Utility/fsck will do for you.

  • Ron — 12:09 PM on December 30, 2011

    I feel your pain. I’ve been using Drobo since their first generation machine and can attest to the fact that they “seem to” place Mac development low on the priority list. I’ve gone through months of not having my plugged in and backing up Time Machine Drobo not recognized until I reboot the computer (with Snow Leopard), hours of transfer time wasted moving to Lion via USB because of some never understood incompatibility between Firewire ports and other goofy activities including the preparing to backup bug. I finally assessed the situation and decided that a fresh wipe was okay since nothing that old was really necessary. I only really need to go back a month or two. Any other deep dives take place in Gmail. Since reformatting and starting a Time Machine backup fresh everything has been fine with Lion. The Drobo is recognized and reported on for a couple months now.

Copyright © 2014 Adobe Systems Incorporated. All rights reserved.
Terms of Use | Privacy Policy and Cookies (Updated)