ADOBE CONFIGURATOR 1.0
USER GUIDE
1 Introduction

1.1 About this manual

This manual provides an introduction to Adobe® Configurator 1.0 on Mac OS® and Windows®.

Chapter 1 covers the basic conventions used in this manual and system requirements.

Chapter 2 offers a brief overview of Configurator and describes how to create a simple panel.

Chapter 3 introduces the menu, toolbar, and palettes of Configurator.

Chapter 4 explains how to package and deploy a panel.

Chapter 5 provides information for panel developers.

1.2 Conventions in this guide

Code and specific language samples appear in Courier font:

```
alert("hello world");
```

1.3 System requirements

**Mac OS**

- PowerPC® G5 or multicore Intel® processor
- Mac OS X v10.4.11–10.5.4
- 512MB of RAM (1GB recommended)
- 10MB of available hard-disk space for installation; additional free space required for installation (cannot install on a volume that uses a case-sensitive file system or on flash-based storage devices)
- 1,024x768 display (1,280x800 recommended) with 16-bit video card
- Adobe Photoshop CS4
- AIR 1.1

**Windows**

- 1.8GHz or faster processor
• Microsoft® Windows® XP with Service Pack 2 (Service Pack 3 recommended) or Windows Vista® Home Premium, Business, Ultimate, or Enterprise with Service Pack 1 (certified for 32-bit Windows XP and 32-bit and 64-bit Windows Vista)
• 512MB of RAM (1GB recommended)
• 10MB of available hard-disk space for installation; additional free space required for installation (cannot install on flash-based storage devices)
• 1,024x768 display (1,280x800 recommended) with 16-bit video card
• Adobe Photoshop CS4
• AIR 1.1

By default, Adobe Photoshop CS4 bundles AIR 1.1. If you don’t have Adobe AIR installed, go to http://get.adobe.com/air/.

1.4 Workbench overview

Figure 1 Workbench overview

1.5 Glossary
- **Custom-designed panel** – a panel that is designed by the user and executed in Photoshop.

- **Objects** - the predefined components that can be added to custom-designed panels.

- **.GPC** – the file extension for saved panels.
2 Configurator basics

This chapter provides an overview of Configurator and describes how to create your own custom-designed panels for use in Photoshop CS4.

2.1 Install Configurator

Configurator 1.0 is an AIR application. Install Adobe AIR 1.1 before running the Configurator installer.

AIR can be downloaded from the Adobe website at http://get.adobe.com/air/.

Configurator can be downloaded from the Adobe website at http://labs.adobe.com/technologies/configurator.

Make sure the downloaded installer is saved with file extension .AIR, and then double-click to execute the installer.

**NOTE:** AIR applications are platform independent. The same installer is used for Mac and Windows.

*Figure 2 Installation screen*

![Installation screen](image)

**Click the Install button**
2.2 Start Configurator

On Mac, go to the Applications folder and double-click Adobe Configurator.

On Windows, go to the Start menu, open the Adobe folder, and click Adobe Configurator.
2.3 Create a panel

Click the Create New Panel button on the Welcome page, or choose File > New Panel.
2.4 Set panel name and size

Click the Inspector palette on the right side to edit the name, height, and width of the panel.

Figure 6 Panel name

2.5 Drag objects into the panel

Drag objects from the Object palette onto the new panel, or double-click an object to add it to the panel.

Figure 7 Object palette

Click on the triangle icons to expand or collapse the palette sections.

Drag a tool button to the panel.
Drag a text widget to the panel

and then modify the text in the Inspector palette.
2.6 Save the panel

Choose File > Save Panel, and then choose a folder in the dialog box to save the panel file. The panel is saved in a file with the extension .GPC.

The default location is user’s Home folder, such as C:\Documents and Settings\username (Windows XP) or /Users/username (Mac OS).

2.7 Export the panel

The Export command generates the required runtime assets for Photoshop CS4. Choose File > Export Panel, and in the dialog box choose the following location:

/Applications/Adobe Photoshop CS4/Plug-ins/Panels/ (Mac OS)
C:\Program Files\Adobe\Adobe Photoshop CS4\Plug-ins\Panels (Windows XP)

If Photoshop isn’t installed in the default location, navigate to and the Adobe Photoshop CS4/Plug-ins/Panels folder. See section 4.2 for more information.

2.8 Run the panel in Photoshop CS4

Start Photoshop CS4 and then choose Window > Extensions > panel
name.

**NOTE:** You must name the panel in Configurator in order for it to appear in the Photoshop CS4 Window > Extensions submenu. Otherwise, it appears as *Untitled*.

Figure 11 First panel
3 Workbench

3.1 Menus and shortcuts

- File

<table>
<thead>
<tr>
<th>Command</th>
<th>Shortcut (Mac OS)</th>
<th>Shortcut (Windows)</th>
</tr>
</thead>
<tbody>
<tr>
<td>New Panel</td>
<td>Command + N</td>
<td>Ctrl + N</td>
</tr>
<tr>
<td>Open Panel</td>
<td>Command + O</td>
<td>Ctrl + O</td>
</tr>
<tr>
<td>Save Panel</td>
<td>Command + S</td>
<td>Ctrl + S</td>
</tr>
<tr>
<td>Save Panel As</td>
<td>Command + Shift + S</td>
<td>Ctrl + Shift + S</td>
</tr>
<tr>
<td>Close Panel</td>
<td>Command + W</td>
<td>Ctrl + W</td>
</tr>
<tr>
<td>Export Panel</td>
<td>Command + E</td>
<td>Ctrl + E</td>
</tr>
<tr>
<td>Exit</td>
<td>Command +Q</td>
<td>Ctrl + Q</td>
</tr>
</tbody>
</table>

- Edit

<table>
<thead>
<tr>
<th>Command</th>
<th>Shortcut (Mac OS)</th>
<th>Shortcut (Windows)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Undo</td>
<td>Command + Z / Command + Shift + Z</td>
<td>Ctrl + Z / Ctrl + Shift + Z</td>
</tr>
<tr>
<td>Redo</td>
<td>Command + Y / Command + Shift + Y</td>
<td>Ctrl + Y / Ctrl + Shift + Y</td>
</tr>
<tr>
<td>Select All</td>
<td>Command + A</td>
<td>Ctrl + A</td>
</tr>
<tr>
<td>Deselect All</td>
<td>Command +Shift + A</td>
<td>Ctrl + Shift + S</td>
</tr>
<tr>
<td>Remove Selected</td>
<td>Delete</td>
<td>Delete</td>
</tr>
<tr>
<td>Object(s)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Preferences</td>
<td>Command + K</td>
<td>Ctrl + K</td>
</tr>
</tbody>
</table>

3.2 Toolbars

- Align

<table>
<thead>
<tr>
<th>Toolbar</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>![Align top edges icon]</td>
<td>Align top edges</td>
</tr>
<tr>
<td>![Align vertical centers icon]</td>
<td>Align vertical centers</td>
</tr>
<tr>
<td>![Align bottom edges icon]</td>
<td>Align bottom edges</td>
</tr>
</tbody>
</table>
Distribute

Table 4 Distribute toolbar

<p>| | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Distribute top edges</td>
</tr>
<tr>
<td></td>
<td>Distribute vertical centers</td>
</tr>
<tr>
<td></td>
<td>Distribute bottom edges</td>
</tr>
<tr>
<td></td>
<td>Distribute left edges</td>
</tr>
<tr>
<td></td>
<td>Distribute horizontal centers</td>
</tr>
<tr>
<td></td>
<td>Distribute right edges</td>
</tr>
</tbody>
</table>

**NOTE:** Align and Distribute tools are enabled when two or more objects are selected, and they only apply to the selected objects.

**NOTE:** Auto Layout tool lays out all objects in the panel automatically, not just selected objects.

### 3.3 Object palette

**Tools**

The Tools area of the Object palette contains the tools found in the Photoshop toolbar.

*Figure 12 Tools area*
The Commands area of the Objects palette contains Photoshop menu commands.

> Figure 13 Commands area

The Search box at the top of the Object palette helps you find features quickly. Type text in the Search box and it displays all matching commands.

> Search box
Drag or double-click to add a command from the search results to the panel.

- **Buttons**

There are three types of buttons:

- **Action**

The Action button executes a recorded Photoshop action. The Action and Action Set properties are assigned in the Inspector palette.
The Script button executes Extended JavaScript code in Photoshop.

Click the Editor button in the Inspector to open a text editor to enter code such as `alert("hello my first script button!");`

The Script File button executes an Extended JavaScript file in Photoshop. The file URL can be an absolute or relative path of a file on the local hard disk.

See section 4.1 for more information about relative paths.
Widgets

There are four kinds of widgets:

- Simple Text widget

The Simple Text widget creates a rectangular box that can contain a text message.

Click the Editor button in the Inspector to open the Text Editor,
where you can enter the text message.

**Figure 15 Text Editor**

![Text Editor](image)

- **SWF/Image widget**

  The SWF/Image widget loads a GIF, JPEG, PNG, or SWF file into the panel. The URL field accepts any of the following forms:
  - URL: `http://somesite.com/picture.png`
  - Absolute path: `/User/user/test.jpg`
  - Relative path: `test.gif` or `./test.gif`

  See section 4.1 for more information on relative paths.
NOTE: If the loaded SWFs are built with Flex project in Flex Builder, they cannot be displayed in Configurator, but they can be displayed in the created panel in Photoshop.

➢ Movie Player widget

The Movie Player widget plays Flash video (.FLV) files in the panel. The URL field for the Movie Player widget accepts the same forms as the SWF/Image widget.

➢ Feature Search widget

The Feature Search widget searches Photoshop features. To use it in Photoshop, you type a string in the Feature Search field in the Configurator panel, and it displays all matching commands. When you click a command in the list of results, the command is executed.
3.4 Panel Editor

Multiple panels can be opened at the same time. Click a tab to switch panels.

An asterisk * means the panel has been modified but not saved. Position the cursor over the tab and it displays the full path of the saved panel file.
Several operations are supported in Panel Editor:

- **Select objects**
  - Click an object to select it and deselect any previously selected objects.
  - Drag a marquee in the panel to select a group of objects.
  - Press Command + A (Mac) or Ctrl + A (Windows) to select all objects.
  - Press Command + Shift + A (Mac) or Ctrl + Shift + A (Windows) to deselect all objects.
  - Click an empty area of the panel to deselect all objects.
Move objects

- Drag one or more selected objects to move them.
- Press the arrow keys to move one or more selected objects in increments of one pixel.
- Press Shift + arrow keys to move one or more selected objects in increments of 10 pixels.

**NOTE:** Configurator does not let you move objects past the panel’s edge.

Resize objects

When an object is selected, handles appear around the object. White handles ( ) indicate that the object can be resized. Blue handles ( ) indicate that the object cannot be resized.

Position the cursor over any white handle and it changes to one of the following:

- Drag this cursor horizontally to change the object’s width.
- Drag this cursor vertically to change the object’s height.
- Drag this cursor at an angle to change the object’s width and height.
NOTE: Configurator does not let you resize objects past the panel’s edge.

- **Align or distribute selected objects**
  
  Select two or more objects and then use the Align and Distribute buttons to adjust their layout.

- **Auto Layout all objects**
  
  The Auto Layout button lays out all objects in the panel automatically, trying to align objects of the same type into rows.

- **Resize a panel**
  
  Drag the lower-right corner of a panel to resize it.
NOTE: Configurator does not let you resize a panel to an area too small to fit its contained objects.

3.5 Inspector palette

Inspector palette is on the right side of Configurator. The upper area specifies Panel attributes; the lower area specifies Object attributes.

The Panel area lists the attributes of the current panel:

- Name – The panel name appears in the Window > Extensions submenu in Photoshop and is also used as the .GPC filename. The panel name cannot exceed 15 characters and cannot contain the following: `\`, `/`, `;`, `?`, `*`, `|`, `.`, `~`, `<`, or `>.
- Height – The maximum panel height is 800 pixels. The minimum is 10 pixels.
- Width – The maximum panel width is 1000 pixels. The minimum is 10 pixels.

The Object area lists attributes of the currently selected object(s). Different object types have different attribute sets. Some common attributes include the following:

- X – The X-axis coordinate of the upper-left corner in pixels.
Y – The Y-axis coordinate of the upper-left corner in pixels.
Width – The width of the object in pixels.
Height – The height of the object in pixels.
Tool Tip – The tool tip for the object, up to 200 characters.
Caption – A custom caption of up to 100 characters can be entered for the Action, Script, Script File, and Command buttons.

Special attributes:

- Command/Feature button – The button dragged from the Commands list or the results of a feature search.
  - Script – The Extended JavaScript code that will be executed when clicked in the panel in Photoshop.
- Action button
  - Action – The action name.
  - Action Set – The action set name.
- Script button
  - Script – The Extended JavaScript code that will be executed when clicked in the panel in Photoshop. Scripts cannot exceed 81,920 characters.
- Script File button
  - File URL – The absolute or relative path of an Extended JavaScript file on the local hard disk.
- Simple Text widget
  - Text – The content of the text widget, which cannot exceed 2000 characters.
- SWF/Image loader widget
  - URL – The URL of the SWF or image file. It can be an Internet URL or a local file path.
- Movie Player widget
  - URL – The URL of the FLV file. It can be an Internet URL or a local file path.

You can use the Inspector to modify the attributes of multiple objects. If multiple objects are selected, the Inspector displays the attributes shared among the objects. If an attribute varies among the selected objects, the Inspector displays (multiple values) in that attribute field.
If you enter a value in the Inspector, it is applied to all selected objects. This is a good way to align multiple objects or resize all buttons to the same dimensions.

**NOTE:** Setting the X and Y coordinates to the same value makes selected objects overlap. Press Ctrl + Z (Windows) or Command + Z to undo mistakes, or use the Auto Layout button to automatically lay out all objects.

### 3.6 Preferences

Choose Edit > Preferences or press Ctrl + K (Windows) or Command + K (Mac OS) to open the Preferences dialog box. It will include two areas.

- **General:**

  Specifies a default size for new panels.
Export:

Lets you generate related assets upon exporting a panel. For more information about the Export preferences options, see Chapter 4.
4 Package and deploy a panel

4.1 About relative paths

Three types of Configurator objects accept relative paths as an attribute. These objects are the Script File button, the SWF/Image widget, and the Movie Player widget.

A URL that starts with ./ or ../ is treated as a relative path. The base path used to resolve a relative path is different in Configurator and in Photoshop.

Configurator resolves the relative path based on the parent folder of the panel .GPC file.

**NOTE:** If the current panel isn’t saved, Configurator cannot resolve the relative path. Position the cursor over the tab in the Panel Editor to see the full path of current panel file.

For example, if a panel is saved with the path /Users/user/Documents/Untitled-1.gpc and there’s a file test.jpg in same folder, Configurator can resolve this file with the relative path ./test.jpg or test.jpg.

*Figure 25 Panel saving structure*

When the panel is exported to the Adobe Photoshop CS4/Plug-
ins/Panels folder, the referenced files in the same folder, such as test.jpg, are automatically copied to that folder.

After exporting, the folder structure looks like this:

![Figure 26 Panel export structure](image)

When the panel is opened in Photoshop, Photoshop resolves the relative path based on the parent folder of the .GPC file. In our example, that's the /Applications/Adobe Photoshop CS4/Plug-ins/Panels/Untitled-1 folder.

In another example, the relative path ../../../../Presets/Scripts/Image Processor.jsx is resolved in Photoshop to the absolute path /Applications/Adobe Photoshop CS4/Presets/Scripts/Image Processor.jsx.
4.2 Export a panel

When you choose File > Save Panel, Configurator saves the panel file with the file extension .GPC. This file cannot be opened in Photoshop. To create a panel that can be opened in Photoshop, you must export it as a Photoshop Flash Panel extension.

If Photoshop CS4 is installed on the same computer that’s running Configurator, the panel can be exported directly to the Adobe Photoshop CS4/Plug-ins/Panels folder. Then start Photoshop and choose Windows > Extensions to open the custom panel.

4.3 Package a panel for sharing

You must package a panel to share it with others. To package a
panel, you must first export an .MXI file from Configurator and then use Adobe Extension Manager CS4 to convert it to an .MXP file.

Select the option Generate MXI in Configurator preferences to generate an MXI file upon export that can be recognized by Extension Manager CS4.

When a panel is exported to a folder, the file structure looks like this:

*Figure 28 MXI file*

Double-click the file Untitled-1.mxi to open Extension Manager CS4 and have it save the panel as an Untitled-1.mxp file. The .MXP file can be deployed by Extension Manager CS4 on other computers.

4.4 Package a panel for CSXS Extension MXP

When you select the option Generate CSXS Extension Manifest in Configurator preferences, Configurator exports an .MXI file that can be packaged as a CSXS Extension MXP file.

CSXS Extension MXP is supported by Extension Manager 2.1 or later. Photoshop CS4 comes with Extension Manager 2.0. To upgrade to 2.1, install the patch located at http://www.adobe.com/exchange/em_download/index.html.

**NOTE:** Panels exported as CSXS extensions can contain only alpha characters and numbers in their names.

4.5 Package a panel as a ZIP file

Panels can be shared without Extension Manager by packaging the exported panel folder into a .ZIP file. Copy the .ZIP file to the other computer and extract it to the Photoshop CS4/Plug-ins/Panels folder.

4.6 Working offline in Photoshop

If you are working offline in Photoshop, Configurator SWF/Movie
widgets that have online URLs (such as http://somesite/some.swf) will not be loaded. When you decide to go online, you must re-open the panel to load the movie.

**NOTE:** To work offline in Photoshop, choose Window > Extensions > Connections. Then choose Offline Options from the Connections panel menu and select Keep Me Offline.

**Figure 30** Window > Extensions > Connections menu

**Figure 31** Connections panel menu
4.7 Export or deploy a panel on Windows Vista

On Windows Vista, Configurator and Adobe Extension Manager should be run in Administrator mode or with the system UAC – User Account Control disabled in order to export and package panels.
5 Information for developers

5.1 Flash panels in Photoshop
Configurator builds on the Flash panel extensibility functionality in Photoshop CS4. For more information, see the Photoshop panel developer’s guides for Windows and Mac.

5.2 Extended JavaScript
The Script button can embed Extended JavaScript code in your custom panel. This script code can call the Photoshop DOM API, which lets developers create buttons that do diverse tasks in Photoshop. For more information about Photoshop scripting, see the Adobe Photoshop CS4 Scripting Guide. A link to the guide is in Appendix B.
Appendix

A. Figures and tables

Figure 1 Workbench overview ................................................................. 6
Figure 2 Installation screen ...................................................................... 8
Figure 3 Installation options ..................................................................... 9
Figure 4 Welcome .................................................................................... 10
Figure 5 New panel .................................................................................. 10
Figure 6 Panel name ............................................................................... 11
Figure 7 Object palette ........................................................................... 11
Figure 8 Drag tool ................................................................................... 12
Figure 9 Drag a widget ............................................................................ 12
Figure 10 Modify text .............................................................................. 13
Figure 11 First panel ............................................................................... 14
Figure 12 Tools area ............................................................................... 16
Figure 13 Commands area ....................................................................... 17
Figure 14 Search box .............................................................................. 18
Figure 15 Text Editor .............................................................................. 21
Figure 16 Panel Editor ............................................................................ 24
Figure 17 Select objects .......................................................................... 25
Figure 18 Resize object .......................................................................... 26
Figure 19 Align and Distribute buttons .................................................... 26
Figure 20 Resize panel ........................................................................... 27
Figure 21 Inspector palette ..................................................................... 27
Figure 22 Inspector displaying multiple values ....................................... 29
Figure 23 General preferences ................................................................ 30
Figure 24 Export preferences ................................................................ 30
Figure 25 Panel saving structure .............................................................. 31
Figure 26 Panel export structure .............................................................. 32
Figure 27 Photoshop Window menu ........................................................ 33
Figure 28 MXI file ................................................................................... 34
Figure 29 Adobe Extension Manager CS4 .............................................. 35
Figure 30 Window > Extensions > Connections menu ............................ 36
Figure 31 Connections panel menu .......................................................... 36
Figure 32 Keep Me Offline option ............................................................ 37
B. Resources

Photoshop Scripting

Photoshop CS4 Scripting Guide

Photoshop Cs4 JavaScript Reference

Photoshop Developer Center

Photoshop Panel Developer Guide Win

Photoshop Panel Developer Guide Mac

Adobe Extension Manager 2.0