Panasonic Lumix DMC-GF6 support in Lightroom 4.4

Lightroom 4.4 has full raw support for the recently released Panasonic Lumix DMC-GF6. ┬áIf you are currently on Lightroom 4.4, there’s no further action required, it’ll just work with your new DMC-GF6.

Lightroom 4 customers can update their version to 4.4 using the Update Mechanism within Lightroom.

Comments are closed.