Lightroom 5.2 now available

Lightroom 5.2 is now available as a final release on Adobe.com and through the update mechanism in Lightroom 5.  The goal of this release is to provide additional camera raw support, lens profile support and address bugs that were introduced in previous releases of Lightroom.

The Lightroom 5 Software Development Kit (SDK) is also now available.  The Lightroom SDK allows developers to extend and customize Lightroom through the use of plug-ins.

Release Notes

New Features in Lightroom 5.2

  • A Smoothness adjustment slider has been added to the Detail Panel under Color Noise Reduction. This helps to reduce low-frequency color mottling artifacts
  • Refinements to the Spot Healing Tool:
    • New Feather control
    • Auto find source method now works better for images with textured areas like rocks, bark, and foliage
    • Auto find source method now prefers source areas within the crop rectangle
  • Auto Exposure has been improved to be more consistent across images and across different image sizes.
  • Smart Preview size has been updated to 2560 pixels on the long edge.
  • Refinements to the Local Adjustment Brush:
    • Right Click (PC) / Control-click (Mac) on a brush adjustment pin to bring up a context menu to duplicate or delete
    • Control+Alt+Drag (PC) / Command+Option+Drag (Mac) on a brush adjustment pin to clone (duplicate) that adjustment

Newly added support for Tethered Capture in Lightroom 5.2

  • Canon EOS 6D
  • Canon EOS Rebel T5i / EOS 700D / EOS Kiss X7i
  • Canon EOS Rebel SL1 / EOS 100D / EOS Kiss X7
  • Nikon D7100

New Camera Support in Lightroom 5.2

  • Canon EOS 70D
  • Canon PowerShot G16
  • Canon PowerShot S120*
  • Casio Exilim EX-ZR800
  • Fujifilm FinePix HS22EXR
  • Fujifilm FinePix HS35EXR
  • Fujifilm FinePix S205EXR
  • Fujifilm X-A1
  • Fujifilm X-M1
  • Leica C (Typ 112)
  • Olympus OM-D E-M1*
  • Panasonic Lumix DMC-GX7
  • Panasonic Lumix DMC-FZ70
  • Panasonic Lumix DMC-FZ72
  • Pentax Q7
  • Pentax K-50
  • Pentax K-500
  • Sony DSC-RX100 II
  • Sony A3000 (ILCE-3000)
  • Sony NEX-5T

* denotes preliminary support

New Lens Profile Support in Lightroom 5.2

Mount Name
Sony Sony E 35mm F1.8 OSS
Hasselblad Hasselblad LF16mm F2.8
Hasselblad Hasselblad LF18-55mm F3.5-5.6 OSS
Hasselblad Hasselblad LF18-200mm F3.5-6.3 OSS
GoPro GoPro Hero 3 Black Edition
GoPro GoPro Hero 3 Silver Edition
GoPro GoPro Hero 3 White Edition
Leica Leica TRI-ELMAR-M 16-18-21 mm f/4 ASPH.
Canon SIGMA 18-35mm F1.8 DC HSM A013
Canon, Nikon, Sigma SIGMA 120-300mm F2.8 DG OS HSM S013
Nikon SIGMA 30mm F1.4 DC HSM A013
Olympus, Sony SIGMA 60mm F2.8 DN A013
Pentax, Sony SIGMA 17-70mm F2.8-4 DC MACRO OS HSM C013
Pentax, Sony SIGMA 35mm F1.4 DG HSM A012
Nikon Nikon 1 NIKKOR 32mm f/1.2
Sony Sony DSC-RX1R

Bugs Corrected in Lightroom 5.2

  • Output Sharpening and Noise Reduction were not applied to exported images that were resized to less than 1/3 of the original image size.
  • Slideshow Exporting process fails for time-lapse sequences.
  • Unable to export a Book.  This only occurred after a customer deleted a background photo.
  • Catalog containing images processed with PV2003 were adding a post-crop vignette when catalog upgraded to Lightroom 5.
  • JPEG decoding produced a red colorcast.
  • Unable to scroll through photos when in Full screen mode.  This only occurs when more than 1 photo is selected.
  • “Store presets with this catalog” preference is not preserved when upgrading catalog from previous versions of Lightroom.
  • Crash when scrubbing Size slider with existing spot selected.
  • Landscape crop not maintained on portrait oriented photos
  • Pressing the Reset button while holding the Shift key results in an internal error.
  • Crash when attempting to move brush spots.
  • Gray area is shown when zooming in/out after cropping image.
  • A row of vertical artifacts appears along bottom edge of photo when applying Grain.
  • Defringe Color Sampler is inaccurate on photos that have Upright applied.
  • All of the images on a Compact Flash card did not appear in the Import Dialogue.
  • Metadata panel displayed incorrect information after modifying published photo. Please note that this only occurred when metadata was changed after the photo was published.
  • Soundtrack does not fade at the end of a slideshow.
  • The Esc key did not exit the slideshow after right clicking screen with mouse during slideshow playing.
  • Import dialog remained blank for folders that contain PNG files with XMP sidecars.

Download Links:

Lightroom 5.2: Windows | Mac

Lightroom 5 SDK – http://www.adobe.com/devnet/photoshoplightroom.html

 Thank You

135 Responses to Lightroom 5.2 now available

  1. Chris Vaccaro says:

    Will 5.2 support tethering for the Cannon 5D Mark III

  2. Mike smith says:

    That seems great .but I just down loaded 4.4 for Lightroom 4 and giving me probs as I could not find any one to contact I have had to remove it there do not seem to be any after service very disappointing .Mike Smith

  3. Jussi Pernaa says:

    Finally my cries got answered!
    Thank you for adding tethered support for D7100 <3 !

  4. Joe Singh says:

    Great news on the update, some really bugy bugs fixed !
    I haven’t installed yet but can you confirm if we will see an improvement in speed and an error when copying radial filter settings ?
    Copying and applying a radial filter saw an incorrect size and selection being made

  5. Tim says:

    Hi, when will 5.2 be available via Creative Cloud? No updates seem to be available at the moment…
    Thanks

    • Pete Green says:

      Have you tried quitting and restarting the Creative Cloud application yet?

      • exkeks says:

        Same here, quitting and restarting the Creative Cloud App gets me nowhere. Even after reboot: no update available.
        Macbook Pro Retina, OSX 10.8.4, Lightroom 5.0 installed.

        • Scott Baker says:

          I had the same problem – however if you check for updates from inside Lightroom 5.0 it directs you to a download page where you can manually download and install it.

          I’m not sure why Adobe is having so much of a problem with the CC updates – it never seems to work and should be such a simple thing.

  6. David Rolt says:

    Are you likely to add tethered shooting for the Pentax K5

  7. Matthias Bober says:

    Export with Dimension resizing is still buggy in LR5.2. Please see:
    http://forums.adobe.com/thread/1261837?tstart=0
    The broken Long Edge resizing seems to be fixed though.

  8. Good to see the feather control on spot healing

  9. David Golding says:

    Is Fuji not talking to Adobe? More X-Lens Profiles please.

  10. And selecting photos in publish collections from the grid is still not fixed. The most frustrating bug introduced by LR 5

  11. Creative Cloud Application is showing LR as up-to-date. (Although I am running 5.0). To upgrade to 5.2 do I just manually download the from the adobe website or do I have to wait for the update to become visible in the CC Application?

    Keen to get it installed ASAP as one of the bug fixes is relevant to something I am working on at the moment.

  12. CCMasterChief says:

    I tried installing 5.2 twice over LR 5 (Windows 7), but I keep getting the same error message.

    Error 1935. An error occurred during the installation of assembly component
    {FF2F571A-6C54-31E3-B23E-2A60283B08A8}
    HRESULT: 0×80070091.

    Do you have any suggestions?
    Thanks.

  13. Any word on whether or when tethering in Windows 8 will be fixed to recognize Canon cameras? This was a known issue when 5.0 was released, and I am disappointed to see this missing from the notes here. I guess I’ll have to install the update and see :-)

    mh++

  14. Can someone at Adobe confirm whether this fixes the bug where the navigator preview window gets stuck on a previous photo and does not show the photo you are currently viewing in the main develop window? It’s pretty frustrating and was introduced with LR5. Thanks.

  15. Ron says:

    Just installed LR 5.2 and whenever I click on the Slideshow module Lightroom 5.2 crashes.

    • Hartley Gardner says:

      Ron, I had this issue with Win8 & LR 5.0, and it turned out I needed updated video drivers. I was told that the DisplayPort drivers were the issue, but I upgraded ‘em all. Btw, Windows 8 is NOT to be trusted to know if you have the latest or not – go to the source (whatever your display cards are) and get the latest.

      • Ron says:

        Thanks, I’ll check for updated drivers, though I’m pretty sure I have the latest ones. But, we’ll see.

      • Ron says:

        All drivers were up-to-date. The crash happens on two differently configured Windows 7 computers. A Notebook and a Desktop. Different graphics cards, one has 16GB memory, one has 32GB. Nothing similar between then, yet slideshow module crashes on both. Seems like a problem with the software.

  16. 3D says:

    “Catalog containing images processed with PV2003 were adding a post-crop vignette when catalog upgraded to Lightroom 5.”

    My question is what happens to these images after updating from LR 5.0 to LR 5.2? So first I had upgraded from LR 3 -> 4 -> 5.0 and I edited a lot of pictures in the meantime. Now this bug has been fixed and want to update to 5.2.
    Will those post-crop vignette artefacts be reverted or ten thousands of my pictures will contain vignette irrevocably?

  17. What about performance!?!?!?! Will the (finally) be a progress??? It’s about time!!!

  18. Why was the preliminary support for the Phase One IQ260 removed, and when will you support the IQ280? I have a bunch of IQ280 files that need to go into my catalog and get edited, but I suspect I’ll probably have to use Phase One Capture One Pro.

    • Roland says:

      Same here, seems Adobe itends to lock out Phase One customers due to the C1P competition. Just good I hesitated to upgrade to CC and finally C1P gets its chance.

  19. Tim Lochmüller says:

    I have the same problem as Ian M Butterfield. Update doesn’t show up in the Adobe Creative Cloud Application. And my version number is still 5.0. What can I do?

  20. Alec says:

    Still not much support for Olympus Cameras / Lens
    Could it be that they are perfect !

  21. Anton says:

    Is there a difference between LR 5.2 and Lightroom CC?

    THX

  22. stefan0n says:

    Does LR 5.2 support remoting liveview on PC when used tethered camera capture?

  23. Lionel says:

    HA the renaming while publishing been fixed? It renames properly the first time but if i republish with a new preset name it won’t work

  24. Anyone else seeing a bug when exporting using short or long edge dimensions? Regardless of which I choose, the images come out all at the specified HEIGHT rather than specific edge length.

  25. Quan says:

    Need Zeiss E 16-70 profile!!!!

  26. Faraz Ahmad says:

    Perfect, gonna try it tonight. :)

  27. Christopher David says:

    CC is not showing that 5.2 is available for update. Please advise.

  28. Lance Moody says:

    Does not show up in Creative Cloud…(even if you quit and restart) another smooth update from Adobe.

  29. Oleksandr says:

    They still didn’t fix the published photos bug. The selection of published photo is not getting synced with the selection in film strip on the bottom. So when you double click the published photo LR brings up the photo selected in the film strip.

  30. Rodrigo Tozzi says:

    I’ve just upgraded from LR4 to LR5.2 and after open my LR4 catalog in LR5.2 I discovered that some photos with spot removal applied are not rendering right.
    I think it may be because of feather slide is set to zero on photos that clone spot removal was applied when converting LR4 catalog to LR5.2.

    • Stefan says:

      heal seems to be ok (feather=0), but importing a cloned spot the feather is set to 75,
      I tested it on a big spot which gives a different result to LR4, ~40 would match better,
      (in this test none of them gave a good result, it was only for testing)

      • Rodrigo Tozzi says:

        Which SO are you using? Win or Mac? In my case, all fotos with cloned spots when imported in LR5.2 are set with feather to 0. By the way, I’m using Windows version.

  31. dukestons says:

    lightroom 5,2 downloaded today
    now cannot use slideshow
    just a black screen
    even with thumnails and info at right hand side
    how can i get away from this problem

  32. George says:

    Hey, not everybody has T1 access….
    How about LR 5.2, English only, Windows only, like you used to have long time ago. (LR3)
    819 MB x 4 download failures and then a good one is about 4 GB to download.
    Thanks

  33. PVCDroid says:

    How soon before the Zeiss 16-70 f4 zoom profile is created?
    sel1670za

  34. shafeeq wmp says:

    anything is more than 4.1?

  35. Terry says:

    Just been using the WEB module in Lightroom 5.2 and it seems anything you do regarding creating new Templates causes the Lightroom to hang and the screen gets messed up. On restarting Lightroom 5.2, it does fix things until the next time.

  36. trshaner says:

    I just checked a number of images that had Spot Removal clone or heal spots applied in LR4. Inside LR5.2 Final the “converted LR4 catalog” shows ALL images with Spot Removal with ‘Feathering’ set to ’0.’ I seriously doubt this is an issue with my LR installation or system as others are experiencing the same issue. See this post for more information:
    http://forums.adobe.com/message/5694547#5694547
    This means every image with spot Removal applied in LR4 or earlier versions show visible CIRCLES without feathering in LR 5.2 Final. I hope there is a workaround other than opening every single image in the catalog and “manually” changing the LR5.2 Feathering setting off of ’0.’

    • Rose Weir says:

      I noticed your post in the Adobe Lightroom forum and followed up with that Allfilters 1.15 plug in by JEllis to find all images in 2013 with a clone circle. 1700 images later that is how I used Sunday afternoon repairing circles.
      Eventually, I chose to reset the clone brush and then synchronized the rest of the images for that month to remove the brush. I decided the image could survive without a hard edged, very visible circle when it was a correction on a bokeh or other insignificant item.
      Power or laundry lines I repaired with the current feature. V5.2 wasn’t happpy with overlapped circles so it was useless to just return the feather feature to those type of original repairs.

      Its rather strange that the overall population of Lightroom users have not noticed this issue. Just one post this morning (9/23) describing the same condition.

      • Stacey Vukelj says:

        I have this issue as well. I didn’t notice it until I went to review a book and noticed the error (after printing unfortunately) in a few images I had previously completed edits on. Very frustrating.

  37. What about support for the new IQ280 or the range of Schneider Kreuznach Lenses? Is Adobe purposely delaying these due to the C1P competition? If so, congrats, annoyed that the lenses are not supported and now even the IQ280 you finally made me try C1P….

  38. Marco says:

    I just got an answer from Jeffrey Tranberry
    ” Lightroom uses a different installer tech than the other CC apps. Hopefully it’s something we can resolve in the future to make it more seamless.”
    Apparently that’s the reason why it doesn’t show up as update in the CC app.

    http://blogs.adobe.com/jnack/2013/09/lightroom-camera-raw-get-new-features-camera-support.html#comment-90292

    Not sure if I will be installing 5.2 with all the issues I see here.

  39. Kathy says:

    After installing 5.2 from 5.0 my healing brush does not work. I cannot see where it is sampling and it is not sampling areas that are even similar to what I am trying to heal or clone. Please tell me how to fix this or go back to 5.0. Thank you!

    • Craig Lybbert says:

      Same problem here. The brushes don’t even appear anymore.

      • Anthony Rynne says:

        Same here. I had cropped a picture and then used the brush. I was picking from outside the crop and is picking an area not even close to the area to be cloned. I think I prefer v 5

        • Pete Green says:

          This can be expected (and we’re working on it), but you can use the \ key to change where the clone is selected from.

      • Anthony Rynne says:

        Another problem. I am exporting and getting an error
        Couldn’t render image: Invalid parameter name: ColorNoiseReductionSmoothness
        How do I get around this?

  40. Robert says:

    I can’t get the 64-bit LR 5.2 update to install over LR 5.0. I get a “Error 1303″ describing a lack of permissions, yet I have permissions wide open and the UAC is off. The attempt took away my LR shortcuts, though the files seem to be there in Program Files and LR starts when I click the main LR executable.

  41. Brian Thomson says:

    I just installed Lightroom 5.2 upgrade and it crashes (Windows 7) after inputting name and address information. Help needed. It over-wrote older LR5 version so now I don’t have access to my catalog.

  42. Jeff says:

    Where is the lens support for the Nikon AF-S 18-35mm f/3.5-4.5g?

  43. Mike says:

    This is Awesome!!

  44. Chris Dubea says:

    I’m a neophyte LR user (just started with v5.0) and have downloaded v5.2. I presumptuously assumed the installer would recognize that v5.0 was installed and update the existing installation.

    Instead it wants to create a new folder and do a separate install (I guess).

    Should I redirect it to the folder with the previously installed version? If not and I let it install in this new folder, will I have 2 versions installed?

    Any advise would be immensely helpful

    Thanks,

    Chris

    • Jay says:

      Just let it install it in the new folder, it should import your settings from the existing LR version. This is how LR update works. Most likely, your 5.0 will go away after that. I’m not sure this is the case with 5.x, as I’m chose to do a fresh install this time around, but it worked like that in the past.

  45. Andreas says:

    Hi :

    Hopefully someone can help me!
    Since LR 5.0 and now in LR 5.2 , I have the problem in developer mode ,
    the image after some settings is crashing after some time !
    It seems no matter what settings I use developer or in what order do I edit the images .
    After about 5 to 10 pictures in the development of the program crashes .

    I stopped some programs running in the background , but the same problem.

    Who has the same problem ? Or I’m the only one who has this problem?
    Sorry for my bad English . ‘m A German user :-)

    This makes it easier to find the possible error , I have now collected some information together :

    Information from LR :

    Lightroom : 5.2 [ 922 700 ]
    Operating System: Windows 7 Home Premium Edition
    Version: 6.1 [ 7601 ]
    Application architecture : x64
    System architecture : x64
    Number of logical processors: 2
    Processor Speed ​​: 2.1 GHz
    Built-in memory : 4090.8 MB
    Lightroom available for phys memory : 4090.8 MB
    Phys memory used by Lightroom : 645.4 MB ( 15.7%)
    Virtual memory used by Lightroom : 633.8 MB
    Cache memory size : 341.1 MB
    Maximum number of threads that Camera Raw: 2
    The system DPI setting : 96 DPI
    Desktop composition enabled: Yes
    Monitors / Displays : 1) 1366×768 , 2) 1920×1080

    Application folder: C : \ Program Files \ Adobe \ Adobe Photoshop Lightroom 5.2
    Library path: C : \ Users \ Andrew’s laptop \ Pictures \ Lightroom \ catalog \ Lightroom 5 Catalog.lrcat
    Preferences folder : C : \ Users \ Andreas Laptop \ AppData \ Roaming \ Adobe \ Lightroom

    Installed additional modules:
    1) Behance
    2) Canon Tether additional module
    3) Facebook
    4) Flickr
    5 ) Leica Tether additional module
    6) Nikon Tether additional module

    Config.lua Flags: None

    Adapter # 1 : Vendor: 10de
    Unit: 648
    Subsystem: 208c17c0
    Version: a1
    Video Memory: 495
    AudioDeviceIOBlockSize 1024
    Audio Device Name: NVIDIA HDMI Out (NVIDIA High Definition Audio)
    AudioDeviceNumberOfChannels : 2
    Audio Device Sample Rate : 44100
    Build : Uninitialized
    CardID : 1608
    Direct2DEnabled : false
    GPUDevice : D3D
    MaxTexture2DSize : 8192
    OGLEnabled : true
    Renderer : NVIDIA GeForce 9600M GS
    Shader Model : 10.0
    Vendor : NVIDIA
    VendorID : 4318
    Version: 10de : 0648:208 c17c0 : 00A1

    INFO on Window 7 Action Center :

    description
    Faulting application path : C : \ Program Files \ Adobe \ Adobe Photoshop Lightroom 5.2 \ lightroom.exe

    problem signature
    Problem Event Name : APPCRASH
    Application Name: lightroom.exe
    Application Version: 5.2.0.10
    Application Timestamp : 52288c50
    Fault Module Name : CameraRaw.dll
    Fault Module Version : 5.2.0.10
    Fault Module Timestamp: 52288bc7
    Exception Code: c0000005
    Exception Offset : 00000000000b34e3
    OS Version: 6.1.7601.2.1.0.768.3
    Locale ID : 1031
    Additional Information 1: 5231
    Additional Information 2: 52314b86dd492d0e1c8967d621f7fea6
    Additional Information 3: c2ea
    Additional Information 4: c2ea21294cccda45da2cc1baacc93c67

    Files that help describe the problem (if not available)
    WERInternalMetadata.xml
    appcompat.txt
    minidump.mdmp

    For more information about the problem
    Bucket ID : 130399310

    • Tom says:

      I am having the same issues, have you figured it out or had someone answer you? at least yours is saying 4000mb available mine only says 716mb of which I have 3400mb in memory

  46. Jure says:

    Hi, Lightroom 5.0 have a bug when editing in photoshop as a smart object, the spot removal or healing brush are not applied in smart object inside photoshop, also some of presets. With large photos it’s crashing… I will let you knew about this update if the bug still exist…

  47. Charles Morrison says:

    My LR5 64-bit update to 5.2 failed during install:
    Error was Error 1335 Could not read Data.cab1

  48. J.Barber says:

    Download file for LR 5.2 update (Mac) throws a checksum error when opened/verified. I have tried downloading from Adobe download site repeatedly and continue to get the same error with each download attempt over the weekend. Perhaps the file posted there has problem? The filename is: Lightroom_5_LS11_mac_5_3.dmg. The OS X error message is: ” The following disk image could not be opened. Invalid checksum”

  49. Bill says:

    Upgraded to LR 5.2 and am unable to edit files in PS6 via ctrl+E PS6 opens, but no file is opened from LR. This is a very recent development…several files had opened successfully, but no more. restart of LR and PS had no effect.

    Help!

  50. Philip says:

    Ditto Jeff’s comment.
    When will lens support for nikon’s 18-35mm G lens be available? It’s been a long wait…
    Thanks

  51. The 5.2 official release (not the RC) has a Collection creation bug where it will not allow context-related collections to be created. Previous to 5.2, you could hover over a target collection set and right click (ctrl-click) and create a collection next to an existing collection or within one, and now it forgets where you are and reverts the the next higher collection set.

  52. douglas says:

    i have to pay for this updade??

  53. Mike Sullivan says:

    It would be nice if Adobe would bring its download pages into the second decade of the 21st century. The download times are given based on 1999 connection technology. Here’s how long the site said downloading LR 5.2 would take:

    37 hrs, 34 mins @ 56K modem
    5 hrs, 5 mins @ DSL
    1 hrs, 16 mins @ T1

  54. Peter Cannon says:

    My Lightroom 5 came up with a problem so I have discarded my copy and want to download and install it again in hope of it working properly but the site won’t let me download it again. I am a Creative Cloud subscriber. Why can’t I just download again and restart?

  55. ben says:

    Is there a lensprofile for Fuji X-20 now ?
    I didn’t find a note about it.

    Thanks

  56. Lisa Modglin says:

    I purchased Lightroom 5 and installed the 5.2 fix. Now I am receiving a message that the release is expired and I have to buy a new one. What the heck is this about???

    • Pete Green says:

      Hi Lisa, In Lightroom do Help > check for updates and install the 5.2 update. Sounds like you may have the 5.2 RC installed.

  57. Kim says:

    I installed 5.2 update from 5.0 but 5.2 is not showing up. I did go through and located the update to make sure it uploaded correctly. I did not get any error messages during the upgrade download. Hope you can help me.
    Thans

  58. Andreas says:

    Hopefully someone can help me!
    The problem of crashes in developer mode will be less, if at the library, the meta and DNG preview is updated before or when everyone went back to developing an image to the library. I’m very disappointed from Lightroom!
    Please help me…..

    Problemsignatur
    Problemereignisame: APPCRASH
    Anwendungsname: lightroom.exe
    Anwendungsversion: 5.2.0.10
    Anwendungszeitstempel: 52288c50
    Fehlermodulname: CameraRaw.dll
    Fehlermodulversion: 5.2.0.10
    Fehlermodulzeitstempel: 52288bc7
    Ausnahmecode: c0000005
    Ausnahmeoffset: 00000000000b34e3
    Betriebsystemversion: 6.1.7601.2.1.0.768.3
    Gebietsschema-ID: 1031
    Zusatzinformation 1: cb3f
    Zusatzinformation 2: cb3f69a98e15c53850c8eb4f6c3f6c35
    Zusatzinformation 3: dbe8
    Zusatzinformation 4: dbe87ff64c0a5f43505c999424c27880

    Weitere Informationen über das Problem
    Bucket-ID: 130399310

  59. Ram says:

    Installed LR 5.2 and updated the catalog. Did a very quick edit for a test and then shut it down. On exit a C++ library error occurs.

    Anyone else had this problem?

  60. anne says:

    does the adobe creative cloud has the Lightroom 5.2? I need Lr to read raw files from the canon 70D

  61. Ted says:

    Seeing a bug in 5.2 final: After browsing collections within a Publishing Service and then browsing plain Collections and Folders, Grid View stops updating. If I change Collections or Folders, the photos shown in Grid View don’t change. In fact, the photos remain whatever were showing for the Publishing Service. However, Grid View _does_ update when changing Publishing Service collections.

    I’ve been able to reproduce this behavior several times.

  62. Cam says:

    Retina support for Slideshow Module…
    When is this much awaited functionality going to be addressed? As so many users have posted around the world on various forums, blogs and other likes, the Slideshow module is unusable on Retina display Mac’s.
    The Lightroom program was updated as a whole to support Retina resolution, all other modules except the Slideshow!
    Any news on this development would be greatly appreciated.
    Thanks :)

  63. sam says:

    is the 5.2 upgrade is free for those how purchesed the 5 version ?

  64. Paul says:

    Silly Questios – Does this software work with RAW photograph from a Nikon 700?

  65. Martin says:

    Wow!! I was doing some research to decide whether to switch to LR5, after using the trial, after reading all this I don’t think I’ll even bother trialling it! Care to convince me otherwise?

  66. Darina says:

    I have used Lightroom 5 for a week and my adjustment brush stopped working. I installed the 5.2 but it is still not working. I tried out every single slider, I toggled the flow/feather, the density, restarted Lightroom several times – the brush just does not respond.

  67. magisterludi says:

    Second monitor issue STILL unresolved (no pun intended). 1:1 Viewing on second monitor – image will not resolve until a slider – any slider – is clicked. This issue has been noted over and over again for well over a year, since at least 4.1, and I have yet to see any Adobe response. What gives?

  68. Lindsay says:

    Hi there,
    I just recently bought the Canon EOS-70D and apparently need to update my Lightroom software to the 5.2 to be able to import and edit RAW files! I am still using the 3.3 version and haven’t needed to upgrade until now. This may sound silly but how do I upgrade? Buy LR-5, install it and then upgrade to 5.2 online? Thanks for any help.

  69. Amos says:

    Do you get problem with the image when zoom in or out?

  70. Chris says:

    After a few weeks with the update 5.2 still have issues with sharpening on export on files resized to 1024×683 . Anyone else still having this problem ?

  71. tim says:

    Where is the fix for the bad math/missing pixels on export?

    Export *SOMETIMES* uses the size you want, others it exports at 1 pixel less than specified. Batch of 100 – 46 will be 480, 54 will be 479. Breaking my heart here…
    Ex: Export to 480 wide… some images 480, others export at 479. I know math is hard – but rounding decimals hasn’t been a problem before.
    Really screws things up when trying to used templates sized for 480 – that one pixel stretch turns sharp to mush.

    It’s been present since 5.0… we at 5.2 yo. Is soundtrack not fading at end of slideshow really *more* important than export sizing?
    Sup? :)

  72. Virginia says:

    LR 5.2 crashes whenever I try to access the slide show module so I can’t create a slide show.
    I’m running the non-cloud version on Windows 7 64 bit.
    Help!

  73. Nichole says:

    Is there a way to change 5.2 back to 5.0?

  74. Young J. Lee says:

    I am using Lightroom 4.4 which I receive when I bought the Leica M9.
    Can I update 4.4 to 5.2 without any extra charge?

  75. peter c says:

    Has anyone noticed a problem with disappearing flags since they installed the Lightroom 5.2 update, mine appear to be doing just that

  76. I am using LR5 and a Nikon D800e Camera. Thethered capture continues to crash and the only fix according to Adobe is to uninstall and re-install. This is no good when you are on location and in the middle of a shoot. Can anyone help me correct this. I am running Windows 8

  77. Richard says:

    In LR5.2 on OSX:
    In Library Mode
    If I view a remote gallery in Publishing Services (like SmugMug)
    and return to viewing my Folders in Grid mode
    then all thumbnails in the Grid and Filmstrip do not update
    and continue to display the Publish Service gallery I viewed.
    I rebuilt a new catalog and the issue persists.
    My only workaround so far is restarting LR after publishing anything.

    Could you please help ?

  78. Thomas Wollburg says:

    Lots of comments. Found only one mentioning performance without any answer – to me as a hobby photographer that cannot buy new hardware every year this issue is important – and to pro photographers to whom time is money I would guess its an issue as well.

    I basically bought Lightroom 5 because Adobe said its fasterbut it is NOT – you were lying: see this review.

    I own a first generation Core i7 27″ iMac and LR5 uses only half of the power available at any time… so my hardware could be twice as responsive if you only would use it better. Whats the point of 64bit architecture if you only use half of my cores? Not even mentioning (suspected to be honest) underuse of my GPU.

    So I am really looking forward to the release note that says “using the avaiable CPU and GPU more efficiently for both full-resolution preview rendering and image export”

  79. I see significant improvements to the old bugs…I don’t notice anything wrong with brushes..but one minor error can be the navigator…until I don’t pass over the actual photo, often it shows another picture, not allowing to preview any preset I’m going to use…speed updates are fine, but anyway a powerful machine is needed, even if I have a large catalog (60000) anyway, and two other minor catalogs…thanks!

  80. Zulakbar71 says:

    Hi, it seems I have a problem missing [ DETAILS ] & [ BASIC ] under DEVELOPE. Could be the bug is still around ?????.. Just bought LR5 almost 2 weeks ago & I’m using MacBook Pro Retina display with Intel i7 2.3Ghz processor.

    Please, how to settle the issue ?????????…it it’s not free folks…most of the works now interrupted

    Thanks

  81. Alan S. Morrison says:

    Hi. Have 4.4 after two upgrades from full v2. Got full v5.0 with Canon 5D MkIII. If I use this disc will it upgrade the same as the Upgrade version? I.e. Is it safe to do it this way or should I buy the Upgrade version?

  82. Patrick says:

    I use LR5 and have downloaded LR5.2 onto my AppleMac but I am unable to download images from my Panasonic Lumix GX7. How do I solve this?

  83. Alice says:

    Can I use Lightroom 5 when I edit pictures from my Nikon D5200? I read somewhere that it (LR 5) can’t deal with 24 MP is that right? And I will automatically get the updates to 5.2 when I’m connected to the Internet, right?

    • Richard Houghton says:

      Indeed you can edit pictures far larger than 24 MP. I have a D5200 and I love LR. I hav emade panoramic that are made of 6 pictures, making the pan HUGE, far beyond one single 24 MP photo. Get it you will love it.

    • Richard Houghton says:

      You will not get an automatic update for 5.2. you have to go to the Adobe Lightroom 5.2 download page. Google it.

  84. Charles van Dijk says:

    I have Lightroom installed on my D: Drive and therefore wish to update manually. How do I do this? Is it worth it? I run out of room on my C: Drive.

  85. Jari Timonen says:

    Since Lightroom 5.2 Auto exposure is over exposing majorly. Things are burning big time! Anyone else having this issue?

  86. Is there any support for Nikon P7800 raw files in lightroom 5. I Cant see any of my raw files in Lightroom 5.
    Regards
    Svante Kellner
    Sweden.

  87. Hello,

    I have been fond of the Lightroom software for years now, but recently, I have come across a problem with the program. When I try to open my catalog via my external hard drive, the program eventually never opens. I have been using this same format for editing and working within the program and can’t seem to find anyone else who has the problem online. I am a Creative Cloud member and all of which are updated. I have an engagement shoot today and REALLY need someone to provide a solution to this malfunction.

    Thank you in advance,

    Kathleen

  88. Richard Houghton says:

    I bought Lightroom 5 and upgraded to 5.2. I have PSE 11 installed prior. In preferences, I have external editing set to PSE and tiff.

    When I select 3 images, then go: Photo – Edit in – Merge to HDR in Photoshop, PSE launches but nothing ever happens after this.

    Similarly: when I Edit In Merge to Panorama in Photoshop, PSE launches and comes up in teh panorama window but no files are selected. No problem,,I just select them manually.

    So anyway do you have a suggestion to fix my issue?

  89. David says:

    I just update Lightroom 5 and now it wouldn’t open

Leave a Reply

Your email address will not be published. Required fields are marked *


− five = 4

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>