Lightroom 5.4 now available

Lightroom 5.4 is now available as a final release on Adobe.com and through the update mechanism in Lightroom 5.  The goal of this release is to provide support for Lightroom mobile, additional camera raw support, lens profile support and address bugs that were introduced in previous releases of Lightroom.

Release Note

New Camera Support in Lightroom 5.4

  • Canon EOS 1200D (REBEL T5, KISS X70)
  • Canon PowerShot G1 X Mark II (*)
  • Casio EX-100
  • DJI Phantom
  • Fujifilm X-T1
  • Hasselblad H5D-50c
  • Hasselblad HV
  • Nikon 1 V3 (*)
  • Nikon COOLPIX P340
  • Nikon D3300
  • Nikon D4S
  • Olympus OM-D E-M10 (*)
  • Panasonic LUMIX DMC-ZS40 (DMC-TZ60, DMC-TZ61)
  • Phase One IQ250
  • Samsung NX mini (*)
  • Samsung NX30
  • Sony Alpha a5000 (ILCE-5000)
  • Sony Alpha a6000 (ILCE-6000)

* denotes preliminary support

Added Camera Matching color profiles (PROVIA/STANDARD, Velvia/VIVID, ASTIA/SOFT, MONOCHROME, etc.) for the following Fujifilm cameras:

  • Fujifilm X-A1
  • Fujifilm X-E1
  • Fujifilm X-E2
  • Fujifilm X-M1
  • Fujifilm X-S1
  • Fujifilm X-T1
  • Fujifilm X-Pro1
  • Fujifilm X10
  • Fujifilm X20
  • Fujifilm XF1
  • Fujifilm XQ1
  • Fujifilm X100
  • Fujifilm X100S

New Lens Profile Support in Lightroom 5.4

Mount Name
Apple   Apple iPhone 5c
Canon   Canon EF 200-400mm f/4 L IS USM
Canon   Canon EF 200-400mm f/4 L IS USM EXT
Canon   Canon EF-S 18-55mm /3.5-5.6 IS STM
Canon   Canon EF-S 25-250mm f/4-5.6 IS II
Canon   Sigma 24-105mm f/4 DG OS HSM A013
Canon   Zeiss Otus 1.4/55 ZE
DJI   Phantom Vision FC200 (for raw files)
Fujifilm   Fujifilm X100S
GoPro   GoPro Hero3+ Black Edition
Nikon   Nikon 1 NIKKOR 6.7-13mm f/3.5-5.6 VR
Nikon   Nikon AF-S DX NIKKOR 18-55mm f/3.5-5.6G VR II
Nikon   Nikon AF-S NIKKOR 18-35mm f/3.5-4.5G ED
Nikon   Nikon AF-S NIKKOR 35mm f/1.8G ED
Nikon   Nikon COOLPIX P340
Nikon     SIGMA 24-105mm F4 DG OS HSM A013
Nikon   Zeiss Otus 1.4/55 ZF.2
Sigma   SIGMA 24-105mm F4 DG OS HSM A013
Sony E   Sony E PZ 18-200mm F3.5-6.3 OSS
Sony FE     Sony FE 24-70 f/4 ZA OSS
Sony FE   Sony FE 70-200mm f/4 G OSS
Sony Alpha   Sony 20mm F2.8
Sony Alpha   Sony 24mm F2 ZA SSM
Sony Alpha   Sony 35mm F1.4 G
Sony Alpha   Sony 35mm F1.4 G
Sony Alpha   Sony 50mm F1.4
Sony Alpha   Sony 50mm F1.4 ZA
Sony Alpha   Sony 50mm F2.8 Macro
Sony Alpha   Sony 85mm F1.4 ZA
Sony Alpha   Sony 85mm F2.8 SAM
Sony Alpha   Sony 135mm F1.8 ZA
Sony Alpha   Sony DT 11-18mm F4.5-5.6
Sony Alpha   Sony DT 16-50mm F2.8 SSM
Sony Alpha   Sony DT 16-80mm F3.5-4.5 ZA
Sony Alpha   Sony DT 18-55mm F3.5-5.6 SAM II
Sony Alpha   Sony DT 18-135mm F3.5-5.6 SAM
Sony Alpha   Sony DT 30mm F2.8 Macro SAM
Sony Alpha   Sony 50mm F1.8 SAM
Sony Alpha   Sony DT 55-200mm F4-5.6 SAM
Sony Alpha   Sony DT 55-300mm F4.5-5.6 SAM

Bugs Corrected in Lightroom 5.4

  • When switching to the Book module with images selected, a ‘Gathering Photos’ message would appear and stay persistent.
  • On Mac Lightroom activity, such as an export, did not prevent the computer from sleeping.
  • In the Develop Module, the ‘Settings > Crop as Shot’ menu item did not properly reset orientation.
  • In the Develop Module and when applying Grain, occasionally vertical artifacts would appear along the bottom edge of a photo.
  • In the Develop Module, there is a slight delay before the Histogram is available for adjustments.
  • Lens profile corrections for the iPhone 5 would not be selected when using the ‘Auto’ Lens profile correction feature in the Develop module.
  • In the Develop Module, Scrubby Adjustments on Adjustment Brush Pins did not work as expected.
  • Syncing of spot removals was not consistent from image to image.
  • Exporting a scaled image to PSD would sometimes cause the watermark to be displayed incorrectly.
  • When Don’t Enlarge is on in Export, image was not resized, even when making image smaller.
  • Sharpening/Noise Reduction were applied inconsistently depending on crop and export image size.
  • Luminance of exported file differed noticeably after crop.
  • When adding keywords on Import, Import begins at once when keywords entered with ‘enter’ key <Win only>
  • In the Import dialogue, Loupe view occasionally did not work.
  • When using the “Edit in Photoshop” feature in Lightroom, the Smart Object filter mask was sometimes not previewed correctly within Lightroom.
  • When creating a new Collection inside of a Collection set, the default option for Location was the parent of the selected collection set and not the selected collection set.
  • Upload via publish does not prevent computer from sleeping, and upload fails if computer sleeps.
  • When playing a slideshow comprising TIF or JPEG images, occasionally the slideshow would appear pixelated.
  • The color profile of a photo was incorrect when playing slideshow in full screen mode.
  • When using a video export preset, develop settings were not applied to all images.
  • Smart preview indicator under Develop histogram displayed the wrong number when multiple photos were selected.

Download Links:

Lightroom 5.4:

Windows – http://www.adobe.com/support/downloads/detail.jsp?ftpID=5741

Mac –  http://www.adobe.com/support/downloads/detail.jsp?ftpID=5740

 Thank You

126 Responses to Lightroom 5.4 now available

  1. Stig says:

    Crop mode do not work in this update. When will it be fixed?

  2. HI team!

    Just wondering if you’ve fixed the tethering support for the Nikon D610?

    Thanks,
    Woodrow

    • Hi Woodrow, the D610 isn’t supported in 5.4. We’re hoping to support it in the next update.

      • René says:

        As D610 is almost the same as D600 it is a little scandalous don’t you think?

        • “Scandalous”? No, it just missed the cut-off for this release as support was just recently added to the tether SDK by Nikon. We’re integrating those changes and testing them for future inclusion.

          • Sergio Pulgarin says:

            I didn’t want to buy Aperture, but I can’t wait another 4 month release cycle to get 610 tethering support in 5.5 (if then).

    • Amir Neshati says:

      Have you tried the CamRanger for remote shooting? Check out Camranger.com
      I have been using it for about a year and love it. You get to take an iPad, your phone and control the camera from 100 feet or so….Hope this helps.

  3. Jose Carlos says:

    Hello. I have the photographers CC bundle, and just finished updating all three programs.
    I imported some .RAF photos from my fuji X-T1 and lightrrom does not recognize the model and lens.

    Please HELP.

    Regards,
    Jose Carlos Babo

    • Patrick McSweeney says:

      I have the same issue but I believe the X100S is the same sensor so they should be identical. It would be nice to her from Adobe about this

  4. Philip Smith says:

    Downloaded updated. But it’s currently not letting me sign in with my account at the moment. I’m in UK time 11:05 GMT

  5. Mike says:

    When will DJI Phantom lens correction for DNG files work like the jpegs?
    Cheers

    Mike

  6. Tom says:

    Hi, Any plans for adding color profiles for GH3?

    • Tom says:

      Hi again, Is it possible to get a simple yes/no at least? Looks like a lot of questions are responded to quickly here.

      Thanks!

  7. Marek Morawski says:

    Why is the suport for Nikon Coolpix P7700 and P7800 still missing ? Most of the time I use Nikon D600 but in some rare cases I take photo with Coolpix P7700 and would like to have the proper correction for this camera. Is there any chance ?

  8. Orville Burgess says:

    When will lens profiles for Nikon 18-300 mm and Nikon 18-140 mm be available for Lightroom?

  9. Ahmad Al Khalidi says:

    Hi, I have lightroom 5.3 desktop version not cc and when I try to check for updates it’s saying no updates availablec so what’s wrong? shouldn’t it be giving me an alert to update to 5.4?

  10. Mathias Birsens says:

    Are there any plans for a Lightroom mobile app for android in the future? I would love to access my photos out of Lightroom from my mobile device!

  11. Peter says:

    Is it safe to update from 5.3 to 5.4 if I got work in progress? Also “check for update” doesn’t show any available updates? Thank you.

  12. Ok, I’m upset now. I bought a Nikon d610 and thought since the d600 was supported I wouldn’t have any problems with lightroom 5.3. So I check the posts and even though it says camera support for d610 that doesn’t mean tethering. So I say okay 5.4 would would show some bug fixes. That’s a NEGATIVE. So I’m bummed because common sense would say that if supports the camera it should support all the features for that camera. Please fix this ASAP. I bought a tether tools cable just so that I can use that awesome feature.

  13. KJ says:

    Hello, did you fix the slowness in Library module while running LR on Mac Maverick? That’s really annoying problem. Thanks for the effort of making LR better.

  14. erling says:

    Thetering with Canon 70D does not work for me. Is it supported in version 5.4?

    Erling

  15. Tenio Tenev says:

    Canon EF-S 25-250mm f/4-5.6 IS II – There is no such lens!

  16. Marcin Warmuz says:

    Hey guys, I have to say – great release. I’m very excited about all new Sony Alpha lens profiles. I see that Sony 35 1.4G shows up twice on the list above. Is it a type or is one supposed to be 35 1.4G and the other one 35 1.8?

  17. Milan says:

    Hi, I have some problem with Nik Software bundle. The Silver Efex doesn´t work, but no problem with Elements 11. What about that issue? Thx.
    Milan

  18. Girish says:

    Will freedom to create templates be available for Book module > jpeg option

  19. Frank Cornfield says:

    So Lightroom 5.4 is only available to CC subscribers? Long standing customers who purchased the product and have paid for updates are now being left behind? Introducing LR Mobile and forcing people to subscribe to software they already own is verging in fraud.

    Looks like its time to jump ship.

    • Hi Frank, don’t worry. The 5.4 update is available to all Lightroom 5 customers. The Lightroom desktop application remains available as perpetual license product and there currently are no plans to change that. Due to the nature of cloud services having ongoing costs, Lightroom mobile is not something that can be offered for a one time fee.

  20. Frank Cornfield says:

    Can’t get update from within LR 5.3 >Help>Check for updates…

    As a standalone LR 5.3 user will I have LR Mobile compatibility with 5.4?

  21. MD Gooch says:

    I have upgraded to LR5.4 and I keep getting an error message – “can’t find preview cache” the program states it will attempt to repair the next time it opens but has not. I am using Windows 7 64bit. I have tried repairing the upgrade, reinstalling from my original LR5 disk with the same error message continuing, LR4 works fine, however. The original (LR5.4) download took an exceptionally longer time on the machine that is having issues could the upgrade be corrupt? How do I roll back to version 5.3 to save my pictures? Any thoughts on how to repair?
    Thanks

  22. Rauke says:

    Dear team,

    Just like in 5.3, 5.4 still have problems while shooting tethered with medium format Leica S (Typ 006) camera’s.
    Can we expect a bug fix soon?

    • Hi Rauke, what OS/version are you on? What sort of issue are you seeing?

      • Rauke says:

        Hi Jeffrey,

        We are using Mac OS X Mavericks, iMac 27″, i7, 8GB and tested on several other Mac’s.
        In 5.3 the tethered images were showed blinking/flashing horizontal and vertical all over the screen. According to Leica (2 weeks ago), this should be fixed in 5.4.
        Although the blinking effect is not present anymore in 5.4 , it is not possible to adjust the image after the tethered shot is loaded.

  23. Lightroom 5.3 (standalone – No CC) alerted me that 5.4 upgrade was available, however when I clicked on update it took me to the 5.3 update. I had to manually search the Adobe site for the Lightroom 5.4 update. Found it and installed it on Windows 8.1 and all is well. Thanks

  24. Brian Snyder says:

    I don’t remember seeing any Pentax camera and lense profiles, can we get them?

  25. Colleen says:

    I downloaded 5.4 upgrade last night and now since the first time I downloaded it is not recognizing my camera to import? I even just went and purchased a brand new cord to ensure that wasn’t the problem and still not working.

  26. Amir Neshati says:

    Have you tried the CamRanger for remote shooting? Check out Camranger.com
    I have been using it for about a year and love it. You get to take an iPad, your phone and control the camera from 100 feet or so….Hope this helps.

  27. Simon says:

    What’s the best way to fall back to 5.3? on Win7 Just installed 5.4 and the whole LR has gone very laggy. Hanging in library mode with multiple images selected. Just slower all around. Am running haswell i7 4770k, fast everything else, dual SSD. Tried creating new smaller catalogue.. same issues.

  28. Justin Green says:

    For me, LR 5.3 says there are no updates.

  29. Charlotte Gilliatt says:

    I have Lightroom 5.3. I want to update to 5.4 but LR is saying that ‘No new updates available’? I usually get prompted to update automatically…never had this problem before. I subscribe to the CC Photography package. Any ideas?

  30. Paul Jervis says:

    Hi I have Lightroom and Photoshop cc with CC.

    With the LR mobile I wanted to have a go but I can’t find any option to sign in on my desktop version as instructed in the getting started with mobile.

    I have check for updates using help on LR desktop and checking the CC desktop app and both say I have no updates but checking the LR version I have installed and it is 5.3

    I have also noticed that when I click the CC icon on top right on my iMac in the app section it only says I have a photoshop cc . I originally installed LR using this app. I current use Mac osx 10.7.5 . If I click the install option for LR using the cc app will that have an effect on the version 5.3 already installed and working on my iMac.

    I am looking advice on getting my LR updated to 5.4 and wanting conformation that upgrading to 5.4 will give me the features (i.e. sign in option etc) to start trying LR Mobile on my iPad.

    Many thanks

    Paul

      • Paul Jervis says:

        Thanks Jeffery that has sorted me integrating Lightroom mobile etc and the rest of the 5.4 updates. Is there a reason neither creative cloud or checking for updates within LR help were not telling me an update was available?

        Also I mentioned while I have both Photoshop CC and Lightroom 5 as CC subscriptions only Photoshop appears on the CC drop down from icon in the apps section. Again just checking that this is not a problem or if i need to do anything so the CC desktop app recognises it is part of my CC. Hope that makes sense.

        Paul

  31. Brian Doyle says:

    Where in 5.4 can I find the Fuji presets, Velvia, Astia etc? I have found them in ACR8.4 but they are alluding me in LR5.4. Thanks for any help in advance.

    • Brian Doyle says:

      Got them thanks, where they should be of course, assumed they’d be in Develop Presets.

    • Sharad Mangalick says:

      Hi Brian,

      The new camera profiles are not presets, but actually color profiles that are available in the Camera Calibration panel. Its on the bottom right hand side of the Develop module. You’ll see them listed when editing images taken with Fuji x-trans sensor cameras.

      Thanks,
      Sharad

  32. Florian says:

    The fix for collections being created in the Set that I clicked on is worth the upgrade alone! :-)

    Is there information on how big the image files are in the mobile app? I am wondering if my 16GB iPad2 would be fast enough and how many images I could fit in about 4GB.

  33. Chris Lees says:

    Hi,

    I’ve just gone to check for upgrades in lightroom 5.3, it says its all up top date? I cant seem to upgrade to 5.4 to use mobile, I have subscription to the Photoshop CC bundle.

    Many thanks
    Chris

  34. DNGlover says:

    Guess the DNG Metadata bug that was finally acknolwedged is not part of this update? Makes using an external application to apply keywords useless if LR isn’t able to read them in (takes minutes instead of instant access like JPG). Come on Adobe… this has been an issue for a LONG time now.. finally reproduced and agreed to be a bug… and yet 5.4 rolls out with out a fix? DNG is YOUR creation… LR has a major bug… please hotfix immediately!!

  35. Christiw says:

    I just downloaded the update for 5.4 (was previously working in 5.3) and now Lightroom is nowhere to be found on my PC. It erased all of the original 5.2 program files. What happened? How do I get it back?

  36. Richard Holland says:

    Does this update fix the bug with slideshows where the slideshow doesn’t autouptate even though the collection being used is the target for autoimport?

    At the moment at my events I’m having to take several shots, then stop and re-start the slideshow for the newly autoimported images to show up.

  37. Bryn H says:

    Updated to LR5.4 for the bug fixes, not interested in mobile. Program became extremely laggy to respond to mouse clicks. Reverted to 5.3 this morning, problem vanished. There is clearly some kind of issue with 5.4 on Windows 7 64-bit.

  38. David Tucker says:

    I would like to get the fixes for LR5.3 but have no use for the 5.4 product. (Neither a subscriber to CC or in the Apple camp).
    Will you please make available just the fixes? – that way you may keep faith with a few more customers.

    • You can download an install the 5.4 update (it’s an update that applies to all users).

      • David Tucker says:

        Yes – but that is not the point.
        5.4 adds new features that I do not want to use and it seems that recent point upgrades may carry performance penalties. (It may not be proven, but it is always entirely possible that bigger, more feature laden editions will lose out on performance).
        Apart from that the download is approx. 900 MB. Adobe software has become extremely bloated. How much better to issue bug fixes at a fraction of that size.

  39. Sebastian says:

    I updated to 5.4 and it seems that Fuji is no longer available as a Make in the Lens Corrections tab; as a Fuji X100s shooter I find this distressing. Reverting back to 5.3 doesn’t seem to have brought it back. I was using it until the update; I’m sure I wasn’t imagining it. Help?

  40. Andi says:

    After Update to 5.4 my NIKTOOLS don’t work anymore: The Plugin starts up but then only shows a blank white screen. Minimizing/maxing changes the backgroundcolor to black, but still no picture.
    Anybody out there having the same issues? @Adobe: Any suggestions how to fix this problem?
    Thank you!

    • Hi Andi,

      Did you restart the system between updates? Are you on Mac or Win?

      Do you have the latest Nik plug-ins installed? https://support.google.com/nikcollection/answer/4400822?hl=en&ref_topic=3001406

      You can find out the version you have installed by launching Photoshop:

      On Mac: Select Photoshop>About Plug-in>(Select the Plug-in name)…
      On Windows: Select Help>About Plug-in>(Select the Plug-in name)…

      • Andi says:

        Hi Jeffrey,

        thank you for your fast reply – it worked
        Rebooting seems to have solved the problem, I did not change anything else. Processing pictures with NIK Tools works now.
        I am using windows and the latest Version of NIK Tools 1.111.

        Little Feedback to your POrtal: I assumed I would be informed by mail when someone answers, since I had left my mailaddress. Since I didn’t hear in a while, I thought no one @Adobe is interested in my problem. Searching if someone else has the same problem by now, I came back to this forum – et voila: Fast reply with working help

        Reply

  41. Lumbowski says:

    Still no tethering support for the Nikon D610? That’s ridiculous – the Nikon SDK was released in November. It’s such a key tool for professional photographers it amazes me that’s it’s not higher on the priority list. I would have said it’s a little more important than, say, adding lens support for a GoPro…

    Any idea when the next release will be? Please say “very soon”…

  42. Andy Murray says:

    I have been trying out Lightroom 5 – it has some cool controls but was really buggy. Just installed Lightroom 5.4 – doesn’t work at all.

  43. Todd Carpenter says:

    Hey fellas,

    I have just installed LR update 5.4. At first, it would not open at all, citing catalog issues. I reinstalled the update and now it boots the program but just as soon as its finished, it shuts down telling me that LR5.4 64bit has stopped working. Can you please help me with this issue?

    Thanks.

  44. Karen Joslin says:

    I upgraded to LR 5.4 recently, when LR told me it was available. (A week or so ago.) Everything was fine until yesterday. While I was working on an image using the paint tool, a large black box appeared and my entire screen flashed rapidly. I believe the black box was at the approximate size and location of my brush. My entire system was frozen, and the only thing I could do was to press the power button until my computer turned off. When I tried to restart it, it went through an endless cycle of attempting to restart, then giving me an error message like, “Your system shut down due to a problem. Press any key or wait a few seconds to restart.” Neither option would restart my computer. So I turned my computer off completely, unplugged the power adapter, and left it alone for awhile (at least half an hour, maybe longer). Before trying to restart again, I removed the battery and then replaced it. After that, my restart attempt worked. (Although when it restarted, it opened all the programs I had running, even though I told it not to.)

    Unfortunately, I experienced the same problem today, only this time with the healing tool. And this time I haven’t been able to get my computer to restart at all. I’ve removed my battery several times. I’ve reset the SMC. I’ve tried booting up in safe mode. It just keeps going through the same cycle – restart attempt, then message, restart attempt, message, etc. I’m using a MacBook Pro (mid or late 2008) with Mountain Lion OS. Any help would be greatly appreciated!

    • Hi Karen, if the entire system froze, I would suspect a low-level problem, such as a hardware failure (hard disk, video card). I would recommend a trip to the Apple store.

      • Karen Joslin says:

        Thanks, Jeff. I finally got it rebooted about an hour ago, but I just experienced the same problem while using my internet browser. So I will definitely be taking it in for some diagnostics.

  45. George says:

    Are there any plans to update the Lens Profiles for the Nokon AF Nikkor 70-300 mm 1:4-5.6G lens? I don’t think it is the same as the one listed that has a VR on it.

    Also, is there a way to get the Lightroom Window to cover more of the computer screen than it does? The three buttons that are normally on a screen (minimize, restore up/restore down and close buttons) don’t show on my Lightroom screen.

  46. michael podlusky says:

    Downloaded LR5.4 successfully. A lens correction for Sigma 24-104 f4 does not appear in the Sigma choices, altho its support is listed in the upgrade features. Am I missing it somewhere else in the program? Thanks-

  47. David Rolt says:

    Will Pentax K5 ever be added to tether support?

  48. Jason Earle says:

    Still no Sigma SD1 .x3f support. :(

  49. Nico Corlione says:

    After the latest update for Lightroom yesterday, I can’t import any photos anymore. I just get a massage that says: Unable to read these files. I also have a PC and on that one I didnt update lightroom. and that works fine. So it is a problem with the update. What do I do?

  50. JPL says:

    How may the new Pet-Eye facility be used in Lightroom 5.4?

  51. Mikko Vaasvainio says:

    After the update I keep on gettin “Unexpected error opening catalog” message and am unable to launch the application. It let’s me to try to choose a different catalog or creating a new catalog but those don’t work either.

    Could you kindly help me? I’ve used Lightroom only three months and with the money I paid I expect the application to work a bit longer than that.

    My OS is Windows 7 Home Premium 64 bit.

  52. Ray says:

    Will there be any future “tethered” support for the Samsung NX 1000 camera.

  53. Ray says:

    Will there ever be tethering for the Olympus E-3 and the Olympus E-5.
    Lot’s of people own these two DSLR cameras but there’s only two tethering options available.
    One is Olympus studio 2, which has never been updated, but the key for the software is now free from Olympus if you ask for it, (the cost was $100 bucks at one time), and the other is Imagecraft E capture which is a very basic image capture program. Would like to see someone else offer a Tethering program for these two professional cameras.

  54. Cheryl says:

    I’ve downloaded the LR 5.4 update. When I open my LR it shows v 5.3 How do I import the 5.4 update from my desktop into LR?
    Thanks,

  55. Leo says:

    I upgraded to Lightroom 5.4, under “White Balance” I see only the option of As shot, Auto or Custom, what happened to all the other setting like Incandescent, Florescent , tungsten etc as in the previous version?

    Thanks,
    Leo

    • rikkflohr says:

      You are looking at a file that is JPEG or Tiff. It already has the White Balance “Baked In” and is no longer editable in a non-destructive manner.

  56. thomas says:

    I just installed the update and dont have any lensprofile foir the Gopro anymore and also not the new one for the Hero3+ black… and al the downloaded profiles are also gone… GREAT :-(

  57. Maria says:

    Hi installed lightroom 5.4 yesterday now my spot removal brush will not work.
    The other problem l keep having is lightroom keeps disconnecting from my hard drives and l have trouble finding the link again, some times l have to remove folder and start again very frustrating because l lose all my edits!! l cant reconnect with folder because it wont let me. l do have four hard drives at the moment would that cause the problem?

  58. Mike says:

    I have always been a very big fan of Adobe products and have been for years…but lately find it very frustrating that you can look all over the internet and find 100 and 100′s of people that have complaints, throughout multiple forums and other mediums, about the Lightroom 5.4/Camera Raw 8.4 and the render engine completely freezing users computer systems, that are running the Windows 7, 8 and 8.1 (64 bit) OS systems. This problem happens in both CS6 and CC products. If you read most have had the problem for months and months and there is still no fix in site. Adobe does not seem to be taking the issue seriously or even looking into a solution (even though this effects 100′s and 100′s of “their paying clients”) …in fact most all complaints (I have seen) are all met with a Microsoft style tactic of a “lets pass the buck attitude” and blame it on the hardware manufactures drivers. Adobe says that it is a hardware problem but if you read the complains 90% of all the users, with the problem, have all the updated drivers, are using hardware listed in Adobe’s own compatibility list and have done multiple system checks. Also most don’t realize that the same issue happens when you try and render in After Effects so this is “clearly” a render engine coding issue. Come on Adobe stop blaming the hardware drivers as causing the issue when the problem, is “clearly” a Lightroom 5.4/Camera Raw and render engine coding issue on your end. I called support and they basically told me the same thing “it’s a hardware driver issue” …being a software engineer myself (and investigating the crashes/freezes), my response to tech support was no you are wrong it is a coding issue between Camera Raw, Lightroom 5.4 and the render engine because it effects other Adobe products that use the render engine as well…”all my non-Adobe” photo and video editing products run just fine on the system with no problems what so ever …so if it were a true hardware issue it would be effecting all those products as well and be producing random system crashes (which is not the case). Since only Adobe products are experiencing the hardware/system freeze then the issue has to be a problem in Adobe’s coding …once they learned that I do coding myself they suddenly refused to talk to me any further.

    The worst part is that once you install Lightroom5.4/Camera Raw 8.4 the render engine freezing issue remains …so even if you downgrade to Lightroom 5.3 and have Photoshop or After Effects installed, the problem is still there (if you render in any product or edit in any product that utilizes the render engine or Camera Raw 8.4 the system totally freezes).

    Until recently most have had no issues at all and you have awesome products (when they work). We paid a lot of money for your CS6 products and deserve working software. So far this has cost me personally thousands of $ in lost and/or delayed work. I am very disappointed that such a great product is now useless on so many systems. Could some one please look into this and provide us all with a real viable solution? …one that really works?

    • Pete Green says:

      Hi Mike,

      I looked for the threads you were referencing and couldn’t find any.
      Which freezing issue are you referring to with LR5.4/ACR8.4?
      What camera are you working with when getting the freezes?
      Feel free to email me directly at petgreen [at] adobe [dot] com and we can look into this for you.
      Regards

  59. Dale Greer says:

    Sharpening adjustments do not appear in JPG exports. Also, when I switch from the Develop module back to the Library module, sharpening adjustments I have just made to NEFs in the Develop module disappear. When I click back into the Develop module, they reappear. This make LR 5.4 COMPLETELY UNUSABLE as a professional image processing app. How do I revert to 5.3? That version was also buggy as hell (it refused to resize images on export), but at least it didn’t screw up image QUALITY. Get it together Adobe, or I will be switching to Aperture.

    • lyndsie says:

      I have this exact same problem and also with noise reduction. Mine also do not export the changes.

    • Dan Holy says:

      Here the same with LR 5.4 – do some sharping in Develop and going back to Library, the sharping won’t be seen in the same way. That’s a bug. But I realized to apply sharping in Library when doing some zooming on that picture (in Library). However, that’s really annoying.
      Also, it seems to me not so smooth as in previous versions – some processing is taking longer, even to switch from one module to another.
      … using Win7 x64

  60. Russ says:

    Upgraded to 5.4, all the images in a recently published book have gone missing from the Collection to which they were associated. How do I get the images back? I had better not have to re-place them all over again. This would be a huge boondoggle on Adobe’s part, then this upgrade would mean that I have to relayout a 64 page book with 300 images! I don’t think so.

  61. Paul says:

    Since upgrading to Lightroom 5.4 (using OSX) whenever I select Develop (D) then Fullscreen (F) the system will not allow me to make any other selection. If I select Grid (G), for instance, it will flash up a grid view but immediately switch back to the (F) screen. The only way out is to Force Quit the program. I really wish I had not taken the upgrade. I can only hope 5.5 is issued really fast to fix this software.

  62. Shashi says:

    LR 5.4 crashes whenever I click on preferences. Need Help

  63. Dennis says:

    I have a whole list of preset folder containing presets in the Develop Module. When I go to Preference and click on ‘Show Lightroom Presets Folder’ the folders in there does not contain any presets. But in Lightroom, when I roll my mouse over to the presets it works. And also when I right click on the preset folder in Lightroom, I only got 2 options which is NEW FOLDER and IMPORT. When I click on the presets, I only have 3 options which is NEW FOLDER. Apply on Import and EXPORT.

    My objective is to clear all the presets in the Develop Module and create my own presets. Kindly help.

  64. BillK says:

    I upgraded to Adobe Lightroom 5.4 latest update on Adobe CC. Now when editing raw photos in the develop module the program randomly crashes stating the Adobe LR has encountered an error and has quit working. I am using an HP Pavilion Windows 7 (x64bit) PC with 10 gigabytes of memory. I have not had any problems in the past with LR3 or LR4. Do you have a fix for this problem?
    BK

Leave a Reply

Your email address will not be published. Required fields are marked *


6 − = one

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>