Lightroom 5.7.1 is now available

Lightroom 5.7.1 is now available as a final release on Adobe.com.  The goal of this release is to provide additional camera raw support, lens profile support and address bugs that were introduced in previous releases of Lightroom.

Release Notes

New Camera Support in Lightroom 5.7.1

  • Sony ILCE-A7M2

New Lens Profile Support in Lightroom 5.7.1

Mount Name
Canon EF Canon EF 24-105mm f/3.5-5.6 IS STM
Canon EF Canon EF-S 24mm f/2.8 STM
Canon EF Tokina AT-X 12-28 F4 PRO DX
Leica M Zeiss Distagon T* 1,4/35 ZM
Nikon F Tokina AT-X 12-28 F4 PRO DX
Nikon F Tokina AT-X 70-200mm F4 PRO FX VCM-S
Sony Alpha Tokina AT-X 166 PRO DX II 11-16 F2.8

Bug Fixes:

  • Fixed issues with chromatic aberration specific to the Samsung NX1.

Download Links

Lightroom 5.7.1

Mac – http://www.adobe.com/support/downloads/detail.jsp?ftpID=5856

Win – http://www.adobe.com/support/downloads/detail.jsp?ftpID=5857

Thanks!

 

81 Responses to Lightroom 5.7.1 is now available

  1. David Adshade says:

    When can we expect to see LR Mobile for Android? Been waiting anxiously for news of its release.

  2. How long does it take to add tether support for a new camera? I’d love to be able to shoot tethered into Lightroom with my Nikon D750.

    • Mike says:

      I think it’s disgraceful that Nikon and Adobe cannot sort out a tether link between the new d750 and the latest Lightroom …I will have to continue to use my D300’s until it gets resolved

      • The D750 is supported in the latest version of Lightroom 5.7. Please make sure you have the 5.7 update installed.

        Have you used Nikon Transfer? Older versions of Nikon Transfer are known to damage the raw files making them incompatible with other application. Please also make sure that you’re using the latest version of Nikon Transfer, or eliminate it from your workflow and import directly to Lightroom: http://feedback.photoshop.com/photoshop_family/topics/nikon-d750-compatibility-with-raw-files

        • PJS says:

          5.7 doesn’t support tethering for the D750 nor does the recent 5.7.1
          I’ve tried them both. I’m going directly from my camera to the computer (I have never used Nikon transfer and don’t know what it is or what it does nor understand why it would be used in a tethering situation).

          • Rikk Flohr says:

            That is correct. Tethering is not yet supported for the D750. Nikon added support for it to their SDK on 11/12/2014. Lightroom 5.7 was released 11/18/2014. There was too little time for programming, testing and deployment to make this release cycle. Now that is released by Nikon in the SDK, it can be included in a future version of Lightroom.

          • Mike Reynolds says:

            Well !you try to connect a D750 through Lightroom and if you can do it? I’ll kiss your **** . I pay for CC every month and there has no justifiable reason for the lack of tethering for a popular camera aimed at the prosumer market. All I have heard is excuses and I have had to by a a competitive product in the meantime. A disgrace Adobe.

  3. Sam says:

    In the next update please include raw support for the Fujifilm X-T1 and the Fujifilm 56mm, 55-200mm and 35mm lenses.

  4. Michael Fleck says:

    When will the mess with Fujifilm X-Trans Sensors be fixed? It is Time for better Support!

  5. Joshua Tashman says:

    Is it possible to get the Canon EF-S 24mm f/2.8 STM profile for Lightroom 4? I have the profile downloader, but the lens isn’t in the database yet.

  6. ejor says:

    with a good Fujifilm raw support ?

  7. Lance King says:

    As others have said, it would be helpful to see more support for the Fujifilm X series cameras, including the Fujinon lenses. Fujifilm keeps churning out some amazing glass, and a number of prominent photographers have switch to their system.

  8. Vaikis says:

    Please add Fuji X-trans better support.

  9. Kesavan Duraisamy says:

    I recently bought Sony alpha A 7 II and got latest light room installed but I could not import any of raw files.
    Please let me know what I am missing.

  10. Mike Griffiths says:

    I updated to v5.7 from v5.6 (in Win 7) now unable to choose Lightroom as the default program for canon .c2r files. Selecting the lightroom exe in ‘Open with’ does not add lightroom to the possible default choices, yet checking the registry OpenWithList and UserChoice shows lightroom.exe. Is this a known issue?

  11. Kyle says:

    Does 5.7.1 support tethering with the A7II?

  12. Mike Griffiths says:

    Thanks for the reply. However, before the update I was able to select a raw image in my main photo directory which had been associated with Lightroom (ie as the program of choice to handle raw files) and take me straight to LR (at present only able to associate ”Photoshop’ and ‘Paintshop’, the problem is – unable to add Lightroom) the images if previously cataloged would then allow me to go to the Develop module. Also right clicking a jpeg for example to point to LR would take me directly into LR and then following ‘Import’ allow me to use the ‘Develop’ module. More convenient.

    • Rikk Flohr says:

      Since you mention Paintshop, I will assume you are on Windows. Setting the default program by file type is a feature of Windows OS – not of Lightroom. It can be done via the Choose Default Program… dialog. If you do this, it will take you to the Import dialog in Lightroom when use the Open With option. (Note: in some former instances of LR/OS a registry hack was required to make this work)

      Realize that the Lightroom workflow is designed around having your images all within the database and not as an ad-hoc image editor.

  13. Mike Griffiths says:

    Thanks Rikk – Exactly the issue, I can no longer choose the default program, even going to the browse section and navigating to the LR exe, and choosing this does not populate the the selections with the chosen application. As I also noted the Registry entry shows ‘Lightroom’ in the application of choice for file type ‘c2r’ etc.
    I agree that this seems to be a ‘Windows’ issue (which from web searches has shown to be a an issue for some at earlier LR revs and other applications e.g. zip files) – but without a ready simple solution. During the update of LR, files are deleted ready for the new revision, I think that a glitch may have occurred at this point. My query was to see if anyone else had this issue following update to 5.7.1 (I updated to v5.7 – which gave the error and then onto v5.7.1). I did get back to v5.6 via a restore point and then had error message: “Unexpected error opening catalog … could not be opened…”. I am aware of the database design of LR, the images are all cataloged – I just want to get back to the added functionality I had previously. I guess I’ll just have to live with it for the present.

  14. Mike Griffiths says:

    I have now confirmed that this is a Registry glitch – HKEY_CLASSES_ROOT\Applications\lightroom.exe\shell\open\command and
    HKEY_CURRENT_USER\Software\Classes\CR2_auto_file\shell\open\command data fields still shows the path to Lightroom exe for version 5.6, i.e. has not been revised to v5.7.1
    When I’m brave enough I’ll edit (once I’ve figured out how to do this safely) which will hopefully resolve the matter.

  15. Oliver says:

    Do I have to update if I’ve got version 4.7? I’m not using any of the cameras listed. Thank you.

  16. Tony Bennett says:

    I have recently bought a D750, up-grading from a D700. I have also up-graded my Lightroom to Version 5.7.1.
    It works well, this version of LR allows direct import of NEF files to the hard drive and the LR catalogue. So far, so good.

    HOWEVER, I use the second memory card in my D750 as a back-up, and LR downloads BOTH images so I have two of everything. Is there any way I can ‘tell’ LR to download only those images from one, or the other card, or even from both cards if I ever use the second card for overflow purposes?

    Any help would be welcome.

    Happy New Year to all

    Tony

  17. Ronny says:

    Just wondering on how many computers you can have Lightroom on with just one license

  18. Jade says:

    That’s good news, hope new lightroom will rock the ground.

  19. Scott Kennelly says:

    Does Lightroom support the raw files from the Sigma SD1 Merrill yet? When it does, I will get it.

  20. Cindy says:

    I downloaded the LR 5.7 update in November and since then I’ve had problems with LR that I never had before, namely the software locking up and not responding while in Develop editing an image, and the whole program running much, much slower. Does 5.7.1 solve the problem I mention? I think I’m legitimately worried about another update that might make it even worse.

    • Rikk Flohr says:

      Cindy, there haven’t been many reports of the update causing problems of this nature. My guess is that your install had a problem. I would recommend you download a fresh copy, just in case, uninstall LR and then reinstall from the fresh copy. Your data should remain intact. If you still have problems, let us know and we will try a couple of other possibilities.

      • Cindy says:

        Thanks. Will downloading the 5.7.1 provide the fresh copy? Whichever link I use to download, do I save it to my computer, uninstall LR, then reinstall? And I don’t need to do anything that will save my images before I uninstall LR?

  21. J.D. says:

    That’s good news, hope new lightroom will rock the ground.

  22. Arthur says:

    I updated from LR 5.4 to 5.7.1, but now cannot export some of my largest images (converting from TIFF to JPG). I get a “not enough memory” error. I am running Windows 7 (32 bit) maxed out with 4GB RAM. Until I can get budget to upgrade hardware and OS I’d like to roll back to 5.4 which seems to run fine with my current hardware. Will the 5.4 installer be able to do this automatically, or do I need to remove 5.7.1 first, or is it a bad idea to roll back like this? I have an old-fashioned (not CC) license.

    • Rikk Flohr says:

      You can uninstall 5.7.1 and reinstall 5.4 (the files are available at the Adobe Website). As long as non of the fixed bugs or camera support is going to be a problem for you, you can move back a version. I am skeptical that it will actually help you but, given that you can do the uninstall, reinstall and revert (if necessary) in less than an hour, it might be worth a shot.

      • Arthur says:

        Thanks for the quick response Rikk. I switched back to 5.4 and that solved my problem. I notice that for the same tiff image, the jpg export is 5-10% larger in 5.4 than with 5.7.1 (all settings the same) so it looks like some changes were made in the jpg codec or the export process. I’m exporting large images (10000×7500 pixels, 48 bit tiffs) so I suspect most people won’t have this problem even if they are memory challenged like me. I’ll stick with 5.4 until I upgrade hardware.

  23. Stuart says:

    I upgraded to LR 5.7, now the Develop mode only has limited functionality with split toning, detail, lens corrections, effects and camera calibration.
    How do I update to include the same functionality I had with the prior version?

    Thanks

  24. Christina says:

    When trying to update my lightroom 5.2 to 5.7, I get an error message that application is not found.

  25. Denis Castonguay says:

    who do i call to get lr running again

    • Rikk Flohr says:

      That depends: are you a perpetual license or a creative clouds subscriber?
      What is wrong with your Lightroom? Error messages? Description of the problem?

  26. Karl-Heinz says:

    Sorry the Download links for Mac and Windows are not Working !!
    The only result is “Temporarily server Error”

  27. Aly Trausch says:

    I own a version of LR 4 an want to upgrade, maybe, to LR 5.7. I want to try a demo version to see if the upgrade is profitable. If not, I will wait for the release of LR 6.

  28. John Ryan says:

    why can’t I tether my new Nikon D750 into Lightroom

  29. ProPhoto says:

    Adobe – please improve Fujifilm X-Trans Sensor support!

  30. econ3000 says:

    Lightroom is not importing the movie files from my sony a7ii. The raw files are coming in fine, Am i missing something?

  31. fiona says:

    Hi i was just wondering if i can upgrade from lightroom version 4.4 to 5.7.1 as i bought a fuji xt-1, or do i have to completely pay for a new version?
    regards
    fiona

  32. I have recently bought a D750, up-grading from a D700. I have also up-graded my Lightroom to Version 5.7.1.
    It works well, this version of LR allows direct import of NEF files to the hard drive and the LR catalogue. So far, progressing well…

  33. Will the next update to Lightroom 5 support the new Nikon D7200? I can’t do ANY editing with my new camera until it supports this camera!!! And when can I expect the next update to be released? PLEASE let it be soon!!!! It’s killing me to have to use my old camera to shoot all my sessions when I have the new camera sitting in my bag….. 🙁

  34. vinh says:

    Bonjour,
    Nous avions acheté en novembre 2014 lightroom 5.7 et nous avions besoin du no série, merci et notre organisme est Ecole Normale Superieure de Cachan. Le no série à ma disposition ne marche pas.
    Bien cordialement.

  35. Lee Laird says:

    I have monthly $9.99 CC photoshop 14.2.1 & Lightroom 5.7. How do I download 5.7.1? I click on download but it takes me back to the promo page. It also ask me if I want to buy now. I really want a nice clear statement about what comes with my CC subscription.

    If I use this address (Win – http://www.adobe.com/support/downloads/detail.jsp?ftpID=5857) will have the same problems others are having? The new features are enticing, but I don’t want problems.

    • Rikk Flohr says:

      Updates to the Monthly program are installed via the Adobe Creative Cloud app. You need to launch the app and install the update from there. If it doesn’t show it as available, you can click the Gear icon and select preferences. Sign out and then sign in again. It should show the update now.

  36. Sandy Noyes says:

    I have the SONY ILCE-7mII with the SE24240 zoom lens but see there is still no lens profile for this lens. When will it be available?

  37. Castro says:

    I love that the lens support now works for LR 6

  38. Mario says:

    Hi,
    I’m having troubles to open my NEF (from a Nikon 550) to Lightroom 5.7.1. Any suggestions?

    • Rikk Flohr says:

      The Nikon D5500 requires Lightroom 6.0 or higher to read the raw files.

      Lightroom 5.7.1 was the last version of the Lightroom 5.x series. For support with newer cameras on Lightroom 5.x, you would need to use the free Adobe DNG Converter to convert your Nikon NEF files to DNG which can be read by older versions of Lightroom and Adobe Camera Raw.

      Otherwise you can upgrade Lightroom to 6.x or subscribe to Lightroom CC 2015 via the Creative Cloud Photographer’s program to get native D5500 NEF support.

  39. Leon says:

    Hey,
    When I import my nef files into lightroom from my d750 my presets are off in colour compared to my 5d. But when I convert the nef files to tiff the presets are same as my 5d raw files. Is there any way of getting them the same without converting to tiff??
    Thank you

  40. leon says:

    the tiff file says embedded and i cant change it. nef file says camera standered

  41. leon says:

    closest i can get to it is adobe standard which flattens the contrast but its close.

  42. Tethering for the D750 with LR5 please!