Waldo Smeets

Disease:
After installing a new Jboss turnkey instance of Adobe LiveCycle, some people run into an issue when the LiveCycle Configuration Manager is doing it’s work. At about 40%, the configuration manager might display the following error:

 

Failed on ‘Verifying JBoss for Adobe LiveCycle ES service is installed’
Windows turnkey service JBoss for Adobe LiveCycle ES does not exist

When checking in the Windows Service Panel, indeed there is no such service defined, even though the installer should have created it. I have not been able to replicate this issue, but it happened to me at a customer site and by searching Google it seems that others have run into it as well.

Prescription:
The Google search results tells us that some people forget to set the Java_Home system variable and that you should be using the right version of the JDK. However, this did not seem to be the problem in this case.

Through the install documentation you can find the steps needed to re-create the JBoss for Adobe LiveCycle ES service (page 62). You can use those to try and create the service ‘manually’. For our install, the problem seemed to be in the [LC_INSTALL_ROOT]jbossInstallJBossService.bat script file. Somehow the username / password did not seem to work, whatever we tried it failed. Well, sort off: strangely enought the command prompt output first mentions that there was an error, though still reports that the script was executed succesfully. Still no service created though.

The solution was too simple to come up with: just remove the username / password parameters from the script and execute it. This time the script did not fail and as expected created the service for us. Next thing to do is go into the service panel, select the ‘JBoss for Adobe LiveCycle’ service, right click to go to it’s Properties and in the Log On tab specify Log In As This Account. Then specify the username password (in my case “.administrator” and the password), click OK and you are done.

Now run the LiveCycle Configuration Manager again and most likely it won’t fail anymore cause of the missing service. This seemed to have overcome our issue.

Tip to stay healthy:
When installing the turnkey solution, it is highly recommended to keep the right documentation at hand: Installing and Deploying LiveCycle® ES Using Turnkey.

Did you run into this issue as well? Please let us know if this worked for you or if you have additional tips for our readers.

—-
Original article at http://www.drflex.eu/2009/03/turnkey-service-jboss-for-adobe-livecycle-does-not-exist/.