Flex / ActionScript 3 Development SDK for Mac / Linux

With the release of Flex beta 2 last week, we also added a new SDK only download. This makes it easy to download and install the SDK on Mac, Windows and Linux (no more install on Windows and copy to Mac).

While this does not provide support for Flex Builder, it does allow you to create, compile and debug your applications on Mac, Windows and Linux using your editor of choice (including Eclipse).

You can download the SDK from here.

5 Responses to Flex / ActionScript 3 Development SDK for Mac / Linux

  1. Simeon says:

    I was very excited to see this happen. I had found ways to get the Framework files from other sources before the SDK was available, but this is certainly easy. On my blog over at http://simb.net I show an ant script you can use to have your code compile for you in Eclipse. Without Flex Builder its a close second.I also cover what you need to do to get the files for the Mystic updates running on your mac so that you can enjoy all the fun of Flex 2 and CF.

  2. John says:

    I have a question?My friend download the flex 2 builder on a windows machine today, and tells me that there is an eclipse plug-in version. We are meeting tomorrow, and I am wondering if I can take the plugin and use it with eclipse on the mac?Sorry if this is dumb question, but tomorrow is my first try with flex, looks really cool, and I just want to try it.I am going to download the framework now:)Thanks,John

  3. mike chambers says:

    Right now, the Flex Builder plugin is not supported on Mac, so some things might not work (it hasnt been tested).I would expect that it would not work well right now.But you an use eclipse to edit the files, and then use ant to compile them via MXMLC.mike chambersmesh@adobe.com

  4. John says:

    Hi,Thanks for getting back to me.I downloaded the framework, but having troubles getting it to work:(when I try to compile, there is a problem findng the mxmlc.jar file, but it is there.It is so late here, but I will try tomorrow.Thanks so much for your help, it really means a lot to me:)John

  5. Mark says:

    Someone Help I am looking for Macromidia 6.0 SDK with source for Linux…PLEASE HELP!!!!PS Thanks..