Guidance for IT Admins for Adobe Certificate Revocation

Adobe is currently investigating what appears to be the inappropriate use of an Adobe code signing certificate for Windows*. We plan to revoke the impacted certificate on October 4, 2012 for all software code signed after July 10, 2012. We have created a web page with guidance for IT admins and will continue to update that page as we learn more and can refine our advice as well info for the public:

Security Certificate Updates
http://helpx.stage.adobe.com/x-productkb/global/certificate-updates.html

[Note: Please review the updates that are available for applications that you manage in your environment. It is always our guidance that our updates be distributed when made available once tested in your environment. If packaging Suite-based applications, please do so with the updated AAMEE 3.1.]

Adobe Certificate Revocation FAQ:
http://helpx.adobe.com/x-productkb/global/certificate-revocation-faq.html

Guidance for IT administrators for Adobe certificate revocation
http://helpx.adobe.com/x-productkb/global/guidance-administrators-certificate-revocation.html

*Adobe Muse and Adobe Story AIR apps as well as Acrobat.com desktop services, are affected and run on both Windows and Macintosh. If you have them in your environment you will need to update them from within the AIR application. No remote updating is available for these AIR apps.

Jody Rodgers | Sr. Product Manager | Enterprise + Volume | Digital Media | Adobe

6 Responses to Guidance for IT Admins for Adobe Certificate Revocation

  1. René Frej Nielsen says:

    Hi,

    Does this mean that there are updated versions of AAMEE, AUSST and RUM for Windows but without new version numbers? If yes, when were they updated?

    Do I have to recreate all my AAMEE packages if they also include updates ind the package or will installation packages continue to work?

    I think we need more detailed instructions!

    /René

    • Jody Rodgers says:

      René,

      Hello. That is correct. We have replaced the existing Windows versions that were posted on our website and on our Licensing Web Site (LWS) on 9/27/12 at 1:15 PDT.

      If you have Windows-based AAMEE 3.1 packages that contain updates our recommendation is to remove them from your system/server and rebuild them with the latest updates that are available. Every product that had an update that had the cert that we are revoking has new versions of the update with the new cert. Therefore we recommend building a new package(s) using AAMEE 3.1 that is currently available for download.

      Please let me know if you need additional clarification.

      Jody Rodgers | Sr. Product Manager | Enterprise + Volume | Digital Media | Adobe Systems

    • Rahul says:

      Hi Rene,

      please download the latest build of AAMEE (for win) 3.1 from http://www.adobe.com/devnet/creativesuite/enterprisedeployment.html and install it over existing AAMEE on your machine. This will update AAMEE on your machine to version 3.0.108, which will be visible on welcome screen of AAMEE.

      thanks,
      Rahul Baiswar| rbaiswar@adobe.com | Lead Software Engineer

      • René Frej Nielsen says:

        Hi,

        What about CS5.5 packages created with AAMEE 2.1? Will they have to be recreated with an updated AAMEE?

        Are Mac packages totally unaffected? I just had a problem with a Master Collection installation where it complained about certificate for a Flash part in Extension Manager.

  2. Jim M says:

    I work for a very large enterprise. We have Adobe Reader, Flash Player, and Shockwave installed on the workstations. What will the end user impact be if we do not have the latest version(s) of the software installed? Does this affect the browser plugin for IE and Firefox as well?

    • Jody Rodgers says:

      There shouldn’t be any impact to software installed for any browser plug-ins already installed. However, we recommend you deploy the lastest of all three of those. Also, if the older installer are part of an imaging or depository of locally available installers we recommend replacing them with the newest installers as this is the type of scenario post-Oct 3 that would be problematic during installation.

      Jody Rodgers | Sr. Product Manager | Enterprise + Volume | Digital Media | Adobe Systems

Leave a Reply

Your email address will not be published. Required fields are marked *


9 + nine =

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>