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A PDF Production Handbook
This handbook captures a generic workflow that you can use to produce PDF files from 
FrameMaker documents in a team authoring environment. It is assumed that a version 
control system such as Perforce is in use to control access to the shared source files.
The following sections are included in this handbook:

• Relevant scenario
• Prerequisites
• Important considerations
• Equip yourself with relevant details
• Stage 0: Prepare the content
• Stage 1: Clean up the source
• Stage 2: Prepare the book and create PDF
• Stage 3: Test the PDF
• Stage 4: Prepare the PDF for publication
• Stage 5: Optimize the PDF in Acrobat
• Appendix: Best practices for using conditional text
• Appendix: Keeping track of content changes across versions in a collaborative 

environment

Relevant scenario
A typical scenario where this workflow will come handy is as follows:
• Your team uses single-sourcing to produce output in multiple formats from the same 

FrameMaker source files.
• The documentation set under consideration consists of multiple files shared across 

several books.
• The source files have multiple text insets.

Prerequisites
Before you get started with creating a PDF, ensure the following:
• Your peers have checked in the latest source files into the version control repository.
• You have complete access to all the files and folders.

Important considerations

Cross references
Cross-references are 
not updated automat-
ically when the 
reference destina-
tions are within text 
insets.

• Cross-references are not updated automatically when the reference destinations are 
within text insets.

• Application of conditional tags drastically alters cross-references. 
Make sure that a cross-reference destination is not hidden in your book because of 
conditional text. In such cases, you'll get many unresolved cross-references when you 
update the book.



2A PDF PRODUCTION HANDBOOK

Variables and special characters
• You cannot search in FrameMaker for text that appears as variables in your 

document. To search for such content, generate a makeshift PDF and search in it.
• You can't search for special formatting and nonprinting characters, such as non-

breaking space, the usual way in FrameMaker. 
For example, if you used a non-breaking space or non-breaking hyphen in a long 
product name so that it doesn't break across lines, typing the product name in plain 
text as it appears in the Find dialog will return no results. 
See About typing in dialog boxes in FrameMaker Help to see how you can input 
special characters in the Find dialog box. If you suspect that the product name is 
not returned in searches, turn on the text indicators. Alternatively, create a PDF, 
even by ignoring the warnings about pagination, and so on, to search for special 
formatting and nonprinting characters.

Change bars

When you are creating the final PDF for publication, remove the change bars. Note that 
change bars appear again if you flatten the text insets in a book after you have cleared 
all change bars across the book.
If you want to preserve the change bars in the 
source, you can set their color to white in the 
Change Bar Properties dialog (Format > 
Document > Change Bars), so that they are not 
visible in the PDFs. Later, if required, you can 
set the change bar color again to a visible color. 
See Identify revised text with change bars in 
FrameMaker Helpfor more information.
If you choose to make the change bars white, 
ensure that you don’t have a black background 
for the page numbers in the header/footer. Otherwise, white change bars will be visible 
alongside changed page numbers in the PDF.

Latest patches, service packs, and fixes
Install a Microsoft 
hotfix from 
http://bit.ly/18312x if 
you are facing 
problems while trying 
to generate PDFs from 
FrameMaker 7.2 or 
FrameMaker 8.0 files.

Download and install the patches for FrameMaker from Adobe.com and other patches 
from Microsoft.com. 
In particular, install a Microsoft hotfix from http://bit.ly/18312x if you are facing 
problems while trying to generate PDFs from FrameMaker 7.2 or FrameMaker 8.0 files.

Equip yourself with relevant details
Gather as much editorial and production information from your publishing team and 
editors as possible.
• Book Conditional Text settings. If you don't have a set already, create one yourself.

• Create a table with a list of books and their corresponding conditional tags to 
show/hide. Take a printout of this table and pin it to your cubicle wall so that 
you have an easy reference.

• Document metadata

http://bit.ly/18312x
http://bit.ly/18312x
http://bit.ly/ju6xw
http://bit.ly/2NyNme
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Consult your editor for standard PDF settings such as the following that your organi-
zation applies to PDF documents:

• Document information such as the correct document title, copyright, author 
information, etc.

• File naming conventions. 
• How the PDF should open, how navigation should be, and what to show on the 

Acrobat or Adobe Reader title bar.
• Document security. Understand the security settings that your organization 

applies to published PDFs, such as allowing users to print, extract text, etc.
• PDF settings (joboptions file) 

Specify the PDF 
settings for Adobe 
Distiller.

• Specify the PDF settings for Adobe 
Distiller. 

• Style guide and production instruc-
tions
• For quick reference to verify 

paragraph formats, naming 
conventions, etc.

• Template files. You may have to import 
and reapply the variables, paragraph, 
character, and cross-reference formats 
with the standard definitions from the 
template files.

If you are creating the 
PDF on a machine 
different from the one 
where you created the 
documents, ensure 
that you have all the 
required fonts on your 
machine.

• Fonts. If you are creating the PDF on a machine different from the one where you 
created the documents, ensure that you have all the required fonts on your machine.
FrameMaker displays the list of missing fonts when you open such documents. 
Copy such fonts to your machine. Typically, fonts such as dingbats used in bullet 
styles may be missing.

Stage 0: Prepare the content
From the following list, carry out all the steps that are required:
• Spell check. Use the spell-checking guidelines of your organization. Do remove all 

the spell-checking overrides:
a In FrameMaker 9, click Edit > Spelling Checker.
b Click Options.
c In the Spelling Checker Options dialog, ensure that no options are selected 

under Ignore.
Text insets and variables within the text are not spell-checked at this stage. To spell-
check the insets, check out the inset files from the version-control repository, spell-
check them, and check your changes back in.
Note: Preferably, spell check after applying the required conditional text show/hide 
settings. For example, hide all editorial comments and author notes before you spell 
check. If you applied word-or character-level conditional text settings, there could be 
words running into each other that may be incorrectly flagged as misspelt words. 
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Note: If you have Straight Quotes 
selected under Find in the Spelling 
Checker Options dialog, ensure 
that you do not change straight 
quotes in code snippets. This step is 
especially relevant for administrator 
and developer documentation 
where readers can use the code as-
such by copy-pasting it.
• Show all conditional text 

except comments and other 
editorial remarks.

• Check linked files
Ensure that 
linked/referenced files 
such as images are 
present.

• Ensure that linked/referenced files such as images are present. Use the Insets 
pod in FrameMaker 9 to quickly wade through text and image references and 
resolve them.

• If you are using a version control system, update the links (or get the latest version 
of the files)

• Remove format overrides. See About format overrides in FrameMaker Help for 
more details.

http://bit.ly/3KZ8q6
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Stage 1: Clean up the source
At this stage, clean up the source in the repository. You must have all the files open in 
FM to conduct most of the production tasks laid out in this section. 
Caution: Do not flatten (convert to text) any text insets right now. 
1 Check out all files that are required for the book.
2 Open the book file and then open all files in it. Ignore all warning messages for the 

while, except for the missing files alerts. 
3 Open the template file that contains the official final set of variables. Do not check 

out this file or any such template files.
4 Import the variables from the variables file:

a In the Book window, ensure that all files are selected and opened.
b Select File > Import > Formats and then select the template file that contains 

all the standard variable definitions. 
c Click Deselect All and then select only Variable Definitions.

d Click Import.
5 From the Book window, select and open all files and do the following:

a Select all files and apply the conditional text show/hide setting:
• Select View > Show/Hide Conditional Text.
• Select the tags that you want to show. 



6A PDF PRODUCTION HANDBOOK

• Clear Show Condition Indicators and click Apply.

b Clear the change bars:
• Select Format > Document > Change Bars. As explained before, this step 

is only required when you’re creating the final PDF.
• Select Clear All Change Bars (No Undo) and click Set.

c Update the book:
• Select Edit > Update Book. Ignore the errors and ensure that the Table of 

Contents and other required files such as indexes, list of tables, list of refer-
ences, etc are generated.

• Note the list of errors shown in the error log.
Ignore errors such as 
mismatch in print 
settings of colors.

• Ignore errors such as mismatch in print settings of colors.
6 Search and resolve unresolved cross-references. 

a Select Edit > Find.
b In the Find pop-up menu, select Unresolved Cross References.
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c Select Book for Look In. 

Caution: This is a partial step, as some of the cross-references may have their destina-
tions inside text insets. Resolving such broken cross-references will necessitate 
flattening the insets to resolve. We will come to that step later. DO NOT flatten the text 
insets now.

7 Set the document properties. Select File > File Info. Fill in the details according to 
the metadata information that your organization requires.

For final production, 
once the content is 
already frozen, find 
the editorial and self-
note character tags 
and delete them. 

8 For final production, once the content is already frozen, find the editorial and self-
note character tags and delete them. 
For interim builds, such as for beta release, comments or other such conditional text 
would be hidden in the PDF. Here's an easy way to find such character tags:
a Select a word and apply the Comment conditional tag to it.
b Select Edit > Copy Special > Copy Conditional Text settings.
c Select Edit > Find and then do the following:

• Select Character Tag and type the name of the character tag (for example, 
checkthis, "Author Note", or "Author Question").

• To change all occurrences, in the Change pop-up menu, select By Pasting 
and then click Replace All.

• To find each occurrence and manually change, click Find and then press 
Ctrl+V to apply the Comment conditional tag to the highlighted text.

9 Check all the files back to the version control system.
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Stage 2: Prepare the book and create PDF
After you have made 
the necessary changes 
in the source, create a 
local copy on which 
you will carry out the 
production tasks.

After you have made the necessary changes in the source, create a local copy on which 
you will carry out the production tasks. This is necessary because the production 
processes involve altering the source files permanently. For example, you would be 
flattening the text insets.
1 Create a local copy for production. After checking in all files, complete the 

following tasks:
a Copy the entire folder from your local repository to a local location.
b Right-click the folder in Windows Explorer and click Properties.
c Clear the Read Only attribute and click OK.

2 Flatten the text insets. Do the following tasks:
a In FrameMaker 9, select a 

text inset from the Insets 
pod.

b Double-click the first text 
inset and click Convert to 
Text.

c Repeat this for all files in 
the book.

You can also find text insets 
using the Find/Change pod. 
See the screenshot to the right.
Note: Do not save the 
FrameMaker documents after flattening text insets. If more PDFs or output files need 
to be produced from the same source, the cross-references relevant for a different set of 
condition tags may not work after you save the FrameMaker documents.

3 Apply conditional tags. In the Book window, select all files and apply the condi-
tional tag required for the book.
a Select all files (Ctrl+A).
b Select View > Show/Hide Conditional Text.
c Set the conditional text to Show/Hide. Deselect Show Condition Indicators.
d Click Set.

4 Update the book. Click Edit > Update Book. Make sure that all necessary options 
are selected.

5 Once more, resolve cross-references. This time, you will be able to resolve the 
broken cross-references in the text insets you flattened.

6 Ensure that the page numbering properties for the different files in the book are set 
correctly.

7 Clear the change bars.
a In the Book window, select Format > Document > Change Bars.
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b Click Clear All Change Bars and then 
click Set.

8 Update the book again.
9 Click File > Save As and select PDF.
10 Set the required PDF settings.
11 Click Set.

Stage 3: Test the PDF
Because you can't search for text inside 
variables or text insets in FrameMaker, you search for such text in the PDF to check if 
the text to be hidden through conditional tags actually shows up in the PDF.
• Search for product names that shouldn't be there in the document.

Search for inline 
comments that may 
not have been tagged 
conditional.

• Search for inline comments that may not have been tagged conditional. 
If you followed some of the best practices in inserting comments in the source, 
search for the distinct comment placeholders. For example, if you inserted the 
comments within double angular brackets <<comment>>, search for << to locate 
any such inline comments.

Locate external 
hyperlinks and ensure 
that they work

• Locate external hyperlinks (such as to web pages) and ensure that they work. Use 
the following conventions:
• If you inserted fully qualified web page address (those starting with http://), 

then search for http:// and ensure that those links are live.
• Use a production checklist. You can create a spreadsheet and then convert it to 

a PDF form.

Stage 4: Prepare the PDF for publication
After the PDF is created, open it in Acrobat Professional and then do the following 
tasks:
1 Press Ctrl+D to open the Document Properties dialog box.
2 In the Description tab, update the document properties, if necessary. If you had 

entered the document information in FrameMaker, those details are shown here.
3 In the Security tab, set the document security options, if necessary.
4 In the Initial View tab, set the following and click OK.

a Navigation Tab: Bookmarks Panel and Page
b Page Layout: Single Page
c Magnification: Fit Page
d Set the Open to Page option to the first content page of the document.
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e (Optional) Under the Window Options group, select Show: Document Title 
This option will display the document title in the window title instead of file 
name.

5 Set any required watermarks.
6 Click OK and then save the PDF.

Stage 5: Optimize the PDF in Acrobat
After generating the PDF, make the following changes to it in Adobe Acrobat 9 Pro 
Extended:

If there are any 
broken cross-refer-
ences in the PDF you 
created, you can fix 
them using Adobe 
Acrobat.

• Fix cross-references: If there are any broken cross-references in the PDF you 
created, you can fix them using Adobe Acrobat. Do the following tasks:
• In Acrobat. click Tools > Advanced Editing > Link Tool in Acrobat. 
• Double-click a highlighted cross-reference.
• On the Action page in the Link Properties dialog, select Go to a page view 

from the Select Action drop-down menu. Click Add.
• Scroll to the destination page for the link and click Set Link.
See Create a link in Acrobat Help for more information.

• Touch up text: You can also touch up text to correct minor typos, punctuation 
errors, and other issues that do not require significant shifting of text. 
The text that you add/edit will appear only in the default style of the paragraph to 
which you are adding it. For example, you cannot insert italicized text in the middle 
of a bolded paragraph. See Edit text in Acrobat Help for more details.

• Optimize the PDF size. In Acrobat Professional, use the PDF Optimizer tool 
(Advanced > PDF Optimizer). See PDF Optimizer options in Acrobat Help for 
more information about PDF optimizer options. Keep the following tips in mind:

• You need to optimize only the final PDF meant for delivery.

http://bit.ly/3AtYpQ

http://bit.ly/1UPFaq
http://bit.ly/1Xpucp
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• If your PDF will only be printed and not hosted online for download by 
users, you do not need to optimize the PDF size.

• Any attachments to the PDF are not optimized.
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Appendix: Best practices for using conditional text

Do...

Standardize 

Create template files for each document type with only the relevant tags.
• Import the latest condition tags to documents from the latest template file.
• Create document-specific template files. Do not use a single template file for all 

document types. 
For example, conditions vary across different product lines. A general condition 
repository could lead to an unmanageable list of condition tags that are irrelevant 
to any book type.

• Name the condition tags intuitively. 
For example, if you use condition tags to separate contents for the standard, profes-
sional, and enterprise versions, name the condition tags such as 
sta_<product_name_prefix>, pro_<prefix>, etc.

• Create a list of housekeeping condition tags required for internal use. Text marked 
with these tags should not appear in the output PDF.
For example, editorial comments, draft comments, obsolete notices, review notes, 
etc, are housekeeping tags. These tags should have the same text formatting and 
naming across your entire organization so that editors can easily recognize them.

• If you embedded web page addresses in text (such as Go to the Downloads page), 
follow a standard lead word or phrase. For example, precede all such web page 
addresses with See or Refer to.

Use conditions sparingly
See if you can avoid 
applying condition 
tags altogether by 
rewriting the content.

See if you can avoid applying condition tags altogether by rewriting the content. For 
example, if you are writing about installation procedures for three versions of the 
product, list out the differences among them from the standard procedure in a separate 
paragraph or topic than inserting these within the procedure itself. 
This way, your entire procedure becomes unconditional, with only the differences 
highlighted in a separate topic or paragraph. Also, use pronouns rather than product 
names to refer to the product as far as possible. 

Apply condition tags carefully to paragraph symbols

Do not apply conditions to the paragraph symbol if only part of the paragraph is condi-
tional, or if more than one condition is in use in a paragraph.
Always choose to display text symbols when you work with conditional tags. Click 
View > Text Symbols.

Create paragraph formats for comments and editorial text

Create one or more paragraph formats for comments and internal, editorial text.
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For example, create a text format, Author Question, that would make critical questions 
that you want the reviewers to notice stand out. For such as paragraph format, use red, 
bold, sans-serif font (if the body text is serif font such as Arial), and with 1.5 lines of 
vertical space above and below the para. For added effects, make the paragraph cover 
both columns if you have a two-column layout.
In the same vein, make the notes to self such as Author Note appear faded out, as they 
are for your own view. When you create a review version, hide such notes to self.
For such paragraph formats, you can set the auto numbering to Author Note/Author 
Question or a referenced graphic. Use auto-numbering in conjunction with a condition 
tag such as Author Note, so that you can show the Author Notes in the internal review 
PDFs to alert the reviewers to sections that you want them to focus on, ask questions, 
or even as a note to self. 
For example, if you are sending a PDF for review with a section that would change 
pending a UI change, you could write thus:
Author Note: The User Management screen to change by Sprint 4. The topic "User 
Management" will change accordingly.
Author Question: Is 32-bit Windows Server 2003 supported as well? 

Follow good housekeeping practices
Insert your initials 
with comments.

• Insert your initials with comments and if possible, the timestamp along with the 
comment, so that other writers or editors can easily recognize the context of the 
comment. For example, if you are John Doe, you could insert the comment thus: 
<<JD-6/27: Will this feature be removed?>>

• Retain important comments and follow up on them until the final review. 
For example:

<<JD-6/27: Will this feature be removed?>>
<<JD-7/15: Retained feature, but deprecated the backward compatibility, so 
removed mention of previous versions>>

• Search for internal, inline comments and remove them: At the time of final 
production, search for any inline comments that are enclosed in double angle 
brackets and remove them.

At the time of final 
production, search for 
any inline comments 
that are enclosed in 
double angle brackets 
and remove them.

• Insert comments in new lines: Do not bury them within paragraphs or sentences. 
Ensure that the complete comment text is tagged conditional, including the end 
paragraph symbol. To ensure this, display the text symbols.

• Apply character tags in addition to the conditional tag. This helps the comments 
stand out even when you hide the condition indicators.

• Apply conditions at the sentence or paragraph level and NOT at word or 
character levels. If you must use condition tags within paragraphs or sentences, 
ensure that the punctuation, spaces, paragraph symbols, and markers (index, cross-
reference, etc.) are conditionalized appropriately.

• Repeat the entire sentence for each condition and apply the appropriate condition 
to each sentence if only a few words need to be different. 
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Don’t...

Create condition tags on the fly

If you create condition tags at will, you get inconsistent condition tags in each book 
with resulting errors. It becomes difficult to manage the build expressions.

Depend entirely on condition tags to hide comments

Use other mechanisms to demarcate comments, especially when you insert comments 
within paragraphs or sentences. 
• Enclose comments in double angle brackets, so that they are text searchable as well 

(<<your comment >>). At the time of final production, you can search for << to 
see if any comments are visible in the final output. You can devise your own 
convention, such as prefixing all comments with Comment: or such distinguishable 
text, but do not use the following:
• Single angle brackets: They are used in HTML and XML tags
• Curly brackets: These are used in code samples
• Hash (#): These are used in code samples, URLs, etc.

Condition tags are 
ORed and not 
ANDed.

Mix condition tags 

As far as possible, do not apply multiple condi-
tions to the same content. Text that has two condi-
tions applied will appear Magenta colored as per 
the FrameMaker default settings.
Note that as long as one condition is set to show, 
the content will appear in the output, even if 
second and subsequent conditions are hidden. 
Condition tags are, thus, ORed and not ANDed.
For example, if the Install _and_upgrade and 
Install_only conditional tags are applied to a piece 
of text, the text would undesirably appear in the upgrade documentation output if 
Install_and_upgrade is in the Show pane in the Show/Hide Conditional Text dialog 
box, but Install_only is in the Hide pane.
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Appendix: Keeping track of content changes across versions in a 
collaborative environment 
If you are working in a geographically dispersed team across time zones, you could run 
into occasional conflicts in managing content when you accidentally remove or 
overwrite a topic created by other writers in the team.

Use the Compare 
Documents feature in 
FrameMaker to create 
a consolidated 
document, in which 
changes between 
versions are 
highlighted.

If you suspect such a situation, you can use the Compare Documents feature in 
FrameMaker to create a consolidated document, in which changes between versions are 
highlighted with Inserted and Deleted conditional tags. 
However, you might find it difficult to go through all changes, including minor editorial 
changes, when you want to focus only on the major content changes. For this, use a 
combination of paragraph formats and conditional text tags to keep track of content 
updates. 
If you are adding, deleting, or substantially modifying a topic, add a draft note about the 
nature of change and apply special paragraph format and a relevant conditional text. 
Ensure that the paragraph format that you define for such purposes stand out from the 
rest of the content in fonts, weight, and color. If your body text is in sans-serif fonts (for 
example, Arial 10 pt), use a serif font such as Times New Roman for the paragraph 
format, and use italics for the body text. Then, to ensure that this text doesn't appear in 
your final document, apply a special conditional text to it.
For example, if you add a new topic about upgrading the software version, add a note 
thus:

<<JD: 9/27: Added section "Upgrading considerations".>>
Note that you need to add the author initials and the date of change too.
In this example, the following are used:
Paragraph Format Name: Author Note 
Default Font: Times New Roman, 12 point, Italic
Space Above and Below: One line each (ensures that the author note stands out from the 
rest of the body)
And then, the conditional tag:
Conditional Text Tag: Author Note
Format: Default Font, Color: Muave
After you have added such housekeeping information, you can add a table of contents 
(TOC) to the book before the first document in the book (usually, the cover page) itself, 
so that other authors can quickly see what has changed.  Because the new TOC contains 
only the links to notes from the authors, it is easy to navigate to their respective changes.
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