
After Effects CS4 tips of the day 
 
 
When you start After Effects, it presents a welcome screen, which includes a tip of the day. A 
few people have asked for a document that contains all of the tips of the day, so that they can be 
searched or browsed more easily. So, here it is.  

Personally, I'd think that people would have a better experience searching the much more 
comprehensive After Effects CS4 Help document, rather than a somewhat random and redundant 
assortment of tips, but I also like to give people what they want. To see more of me trying to give 
After Effects users what they want, see my blog, After Effects Region of Interest. (Here's the link 
for the RSS feed.)  

If you have tips of your own to contribute, please do so by leaving a comment at the bottom of 
the relevant page of After Effects Help on the Web. Pretty please?  

(Note: The tips in the application are specific to one operating system or the other with regard to 
modifier keys like Ctrl versus Command and Alt versus Option. I'm giving the Windows version 
here, only because my Mac is about 10km away as I write this. I trust that nearly everyone 
reading this knows how to map the Windows version to the Mac OS version. The Help document 
gives both.)  

 

Welcome to Adobe After Effects.  

To help you discover new techniques and learn about additional features, a tip of the day appears 
each time After Effects starts.  

The tip of the day should be useful for both novices and experts. The first few tips are designed 
for new users.  

You can open the Welcome and Tip of the Day window at any time by choosing Help > 
Welcome and Tip of the Day.  

 

To automatically receive notifications that keep you up to date on After Effects product and 
support information, subscribe to support announcements and the blogs of Michael Coleman 
(After Effects product manager) (RSS feed) and Todd Kopriva (After Effects documentation 
lead) (RSS feed).  

 

To create a new composition, choose Composition > New Composition. 

http://community.adobe.com/help/search.html?q=keyboard+shortcuts&l=aftereffects_product_adobelr&self=1&hl=en_US&lr=en_US&requiredfields=book%3AUsing%2520After%2520Effects%2520CS4�
http://community.adobe.com/help/search.html?q=keyboard+shortcuts&l=aftereffects_product_adobelr&self=1&hl=en_US&lr=en_US&requiredfields=book%3AUsing%2520After%2520Effects%2520CS4�
http://community.adobe.com/help/search.html?q=keyboard+shortcuts&l=aftereffects_product_adobelr&self=1&hl=en_US&lr=en_US&requiredfields=book%3AUsing%2520After%2520Effects%2520CS4�
http://blogs.adobe.com/toddkopriva�
http://blogs.adobe.com/toddkopriva/atom.xml�
http://blogs.adobe.com/toddkopriva/atom.xml�
http://blogs.adobe.com/toddkopriva/atom.xml�
http://help.adobe.com/en_US/AfterEffects/9.0�
http://help.adobe.com/en_US/AfterEffects/9.0�
http://www.adobe.com/support/aftereffects�
http://blogs.adobe.com/keyframes�
http://blogs.adobe.com/keyframes�
http://blogs.adobe.com/keyframes�
http://blogs.adobe.com/keyframes/atom.xml�
http://blogs.adobe.com/toddkopriva�
http://blogs.adobe.com/toddkopriva�
http://blogs.adobe.com/toddkopriva/atom.xml�
http://help.adobe.com/en_US/AfterEffects/9.0/WS3878526689cb91655866c1103906c6dea-7f1ea.html�


 

To add a keyframe to animate a property, click the stopwatch next to the property name in the 
Timeline panel.  

To browse the available properties, expand the layer outline by clicking the triangle to the left of 
the layer name.  

 

For a list of keyboard shortcuts, choose Help > Keyboard Shortcuts.  

 

When you create a new composition, the settings you use become the default settings that will 
appear the next time you create a composition.  

 

To import multiple files at once in the Import File dialog box, hold Shift as you select multiple 
files.  

You can also use this method to import a range of frames instead of a full sequence. Just hold 
Shift as you select the first and last frames of the range.  

 

To select all keyframes for a given property, click the name of the property in the Timeline 
panel.  

 

When you turn off the stopwatch icon for a property, keyframes for that property are 
permanently removed and the value of that property becomes the value at the current time.  

You cannot restore deleted keyframes by clicking the stopwatch. If you accidentally delete 
keyframes, choose Edit > Undo.  

 

You can quickly modify an underlined value by moving the pointer over the value and then 
dragging left or right, up or down, to increase or decrease the value.  
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To add or remove columns in the Project, Timeline, and Render Queue panels, Right-click a 
column heading, choose Columns, and select a column name.  

 

To import sequences, drag and drop folders from Finder or Windows Explorer directly into the 
Project panel.  

If you hold down Alt before releasing the mouse button, all files in that folder import as 
individual footage items.  

 

An asterisk next to the project name indicates that a change has been made since the last time the 
project was saved.  

 

Animation presets allow you to build a library of animations, effects, expressions, text, and other 
elements.  

To create an animation preset, select the item you wish to preserve and choose Animation > Save 
Animation Preset.  

The Effects & Presets panel includes hundreds of professionally-designed animation presets to 
get you started.  

 

To move a layer's In or Out point to the current time, select the layer in the Timeline panel and 
use the bracket keys:  

Set In: [  

Set Out: ]  

 

To create a new layer above or below another layer, drag a footage item from the Project panel to 
the Timeline panel's layer list and release it above or below the other layer.  

To create a new layer at a specific time in the composition, drop the layer in the duration bar area 
at the desired time.  
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To play (preview) a composition, including audio, use RAM preview.  

 

Adobe After Effects Help on the Web is updated frequently and contains much more information 
than is included in the Help document installed with the application.  

 

To create animation, you can also "sketch" a motion path.  

With the Motion Sketch panel open, select a layer in the Composition or Timeline panel.  

Click Start Capture and sketch a motion path in the Composition panel.  

As you draw the motion path, After Effects generates position keyframes, recording the speed at 
which you move.  

 

When you animate position values, After Effects displays the movement as a motion path in the 
Composition panel.  

A motion path appears as a line with dots that mark the position of the layer at each frame. A 
square in the path marks the position of a keyframe.  

The density of dots between the keyframes indicates the layer's relative speed. Dots close 
together indicate a slower speed; dots farther apart indicate a greater speed.  

 

Double-click any blank area in the Project panel list to open the Import File dialog box.  

 

A layer must be set to Best quality to take advantage of subpixel precision. However, for faster 
rendering while you work, you can switch layers to Draft quality until you render a finished 
movie.  

 

Create a new composition by simply dragging footage in the Project panel and dropping it on the 
New Composition button at the bottom of the panel.  

This also works with multiple footage items.  
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To select layers by number, use the numeric keypad. For example, type 11 to select layer eleven. 
Be sure Num Lock is enabled.  

 

To select a layer in the Composition panel when there are multiple overlapping layers, right-click 
the layer, and choose the layer from the Select submenu.  

 

Work at a resolution setting of Half and a Draft quality setting for faster production.  

Use the Full-resolution/Best settings options for checking specific frames and final renders.  

 

Press Ctrl + W to close the currently active tabbed panel or the item being viewed in the active 
panel.  

 

To change the composition background color, press Ctrl + Shift + B and select a new color.  

 

To move the current-time indicator precisely click in the time ruler; click the current-time 
display in the Footage, Layer, Composition, or Timeline panel; or press Alt+Shift+J.  

 

To display the Time Remapping property for a layer with time-remapping enabled, select the 
desired layer and press RR.  

 

All panels have a panel menu with panel-specific options. Just look for the button in the upper-
right corner of the panel.  

 

To duplicate a composition, select it in the Project panel and press Ctrl + D. To rename the 
duplicate composition, press Enter, type the new name, and press Enter again.  
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To make a layer 3D, click the 3D Layer switch in the Timeline panel switches column or choose 
Layer > 3D Layer.  

 

To create a new solid-color layer, activate either a Composition or Timeline panel and press Ctrl 
+ Y. Specify the settings you want and click OK. To adjust solid settings later, select a solid-
color layer and press Ctrl + Shift + Y.  

 

When using 3D, if you lose sight of your layers you can reset your custom view or camera using 
View > Look at Selected Layers or View > Look at All Layers.  

 

As you drag a layer name up or down in the Timeline panel, a horizontal line appears between 
other layer names, indicating the position to which the layer will move if you release the mouse 
button.  

 

Click the Fast Previews button at the bottom of the Composition panel to choose from a variety 
of options for accelerating previews and layer manipulation.  

 

Use the Hand tool for panning in the Composition, Layer, Timeline, and Footage panels. To use 
the Hand tool, either select it in the Tools panel, press H, hold the spacebar, or hold the middle 
mouse button.  

 

Paint strokes are nondestructive, so painting and erasing actions affect only the appearance of a 
layer; they do not alter the original source file of the layer.  

 

You can right-click any item to see a context menu of settings and commands for that item.  

 

To display Mask Opacity in the Timeline panel, select the desired layer and press TT.  
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In the Go to Time dialog box (Alt + Shift + J), you can move a relative number of frames by 
starting with the plus sign (+).  

For example, type +8 to go ahead 8 frames, or +-3 to go back 3 frames.  

 

To reveal specific transform properties for a selected layer in the Timeline panel, use these 
single-key shortcuts: A (Anchor Point), P (Position), S (Scale), R (Rotation), and T (opaciTy). If 
no layer is selected, properties are revealed for all layers.  

 

To reveal all animating properties (properties with keyframes or expressions), press U.  

To reveal all properties with expressions, press EE.  

If no layer is selected, properties are revealed for all layers.  

 

To enable 3D depth of field or animate the 3D point of view, you must first create a camera by 
choosing Layer > New > Camera.  

For depth of field, be sure to check the Enable Depth Of Field checkbox in the Camera Settings 
dialog box.  

(There's also a Depth Of Field effect, which uses depth information from the auxiliary channels 
of imported 3D files.) 

 

To stretch a group of keyframes in time, select the keyframe icons in the Timeline panel and hold 
down Alt while you drag the first or last selected keyframe icon.  

 

To go to the In or Out points in the timeline for a selected layer, use these shortcuts:  

In: I 

Out: O  
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To rearrange the order of effects, drag an effect name up or down in the Timeline or Effect 
Controls panel.  

 

Use the Info panel to monitor the progress and frame rate of a RAM preview.  

 

After Effects has 99 levels of undo. By default, the levels of undo are set to 32. Change the levels 
of undo by choosing Edit > Preferences > General and entering a new number.  

Higher levels of undo require more RAM.  

You can also use shortcuts for Undo and Redo: 

Undo: Ctrl + Z 

Redo: Ctrl + Shift + Z  

Or use the Edit > History menu to undo multiple steps at once.  

 

To perform a slip edit (move footage without moving its In and Out point) in the Timeline panel, 
just drag the layer "ghost bar" (the part of the layer that is trimmed away). You can also drag the 
layer bar using the Pan Behind tool.  

 

You can move an effect control point by pressing the arrow keys after you click its crosshair in 
the Effect Controls panel.  

 

To view and add comments for layers, render items, and footage items, right-click a column 
heading and choose Columns > Comment to display that column.  

 

When creating composition markers with a keyboard shortcut, choosing a marker number that is 
already in use will move the existing marker to the current time.  
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To trim the In and Out points of a selected layer in the Timeline panel, use Alt and the bracket 
keys:  

Trim In point: Alt + [ 

Trim Out point: Alt + ]  

 

To set the beginning of the work area to the current frame, press B on the keyboard. To set the 
end of the work area to the current frame, press N.  

 

To view mask properties for selected layers, use the solo keys:  

Mask Shape: M 

Mask Feather: F 

Mask Opacity: TT 

all mask properties: MM  

 

You can copy and paste styled text between After Effects, Adobe Photoshop, Adobe Illustrator, 
and Adobe Encore.  

 

You can set the Motion Blur Shutter Angle in the Advanced tab of the Composition Settings 
dialog box.  

 

To view more information about the composition as it renders, click the triangle to the left of 
Current Render Details. To view details of a completed rendering, review the log file (if 
enabled).  

 

Sometimes it is easier to move a camera in the Composition panel by viewing the composition 
from another point of view. Use the 3D View menu in the Composition panel to select another 
view.  
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To show the Audio Levels or Waveform properties in the Timeline, use these keyboard 
shortcuts:  

Audio Levels: L 

Audio Waveform: LL  

 

To speed up 3D rendering, click the Draft 3D button at the top of the Timeline panel to 
temporarily disable shading, shadows, and depth of field.  

 

Submit your Adobe After Effects feature requests, ideas, and bug reports using the feature-
request/bug-report form.  

 

To remove all effects applied to a layer in the Timeline or Composition panels, select the layer or 
layers from which you want to remove all effects and then choose Effect > Remove All.  

 

To set render queue output module crop values visually, first set a region of interest using the 
Region Of Interest button at the bottom of the Composition panel. Then check the Use Region of 
Interest button in the Crop section of the Output Module Settings dialog box.  

 

To animate a text property in a text layer, choose Animation > Animate Text > [property]. 
Modify the property, then set keyframes for the newly added Range Selector's Start and/or End 
properties.  

 

To split a layer in the Timeline panel, move to the point in time when the layer should be split, 
select the layer, and press Ctrl + Shift + D.  

 

To open or close the Effect Controls panel quickly, select a layer and press F3 or Ctrl + Shift + 
T.  
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To change the keyframe interpolation method, Ctrl-click a keyframe in the Timeline or 
Composition panel.  

If the keyframe uses Linear interpolation, it changes to Auto Bezier.  

If the keyframe uses Bezier, Continuous Bezier, or Auto Bezier, it changes to Linear.  

To toggle Hold interpolation, Ctrl + Alt-click the keyframe.  

 

To change color of a mask outline, click the color swatch next to its name in the Timeline panel.  

 

Use the camera tools to orbit and move the current view. Press C to select the current camera 
tool. Press C again to cycle through the other camera tools.  

 

To open or close panels, use shortcuts such as these:  

Tools panel: Ctrl + 1 

Info panel: Ctrl + 2 

Preview panel: Ctrl + 3 

Audio panel: Ctrl + 4  

 

Turning off effects, motion blur, and the frame blending switch (after they are set up properly) 
speeds production.  

Remember to turn them back on before rendering, or use the Render Settings dialog box's 
override options instead.  

 

To automatically adjust preview resolution to provide optimum performance at the current zoom 
setting, choose Auto from the Resolution menu at the bottom of the Composition panel.  
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To toggle between the current and previous camera views, press Esc.  

 

For information about individual effects and their settings, consult After Effects Help. Choose 
Help > Effect Reference.  

 

Auto-orient an object (camera, light, or layer) along its motion path by choosing Layer > 
Transform > Auto-Orient and selecting the Orient Along Path option.  

 

The expression pick whip makes it easy to write expressions. Drag the pick whip to almost any 
property to reference that property in the expression.  

 

A light illuminating a 3D layer can cast soft-edged shadows. Simply increase its Shadow 
Diffusion property value.  

 

You can perform simple math operations in dialog boxes that take numeric values. Just use the 
symbols +, -, *, and / to add, subtract, multiply, and divide, respectively.  

Timecode fields support relative movements. Use + to move forward in time and +- (plus and 
minus) to move backward in time.  

 

To change the default motion blur values, choose Composition Settings from the Composition 
menu, click the Advanced tab, and change the Shutter Angle and Shutter Phase settings for this 
composition.  

 

If you need to align or distribute multiple objects, select them in the Composition panel and then 
choose Window > Align to display that panel. Click the button that arranges objects the way you 
want them.  
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When adjusting speed on a motion path, set the shape of a motion path first, and then use the 
ease handles to fine-tune the speed relationships in the speed graph. If you want a handle to have 
influence over more than one keyframe, set adjacent keyframes to be roving keyframes.  

 

To zoom in the Composition, Layer, or Footage panels, use these keyboard shortcuts:  

Zoom in: . (period) 

Zoom out: , (comma)  

 

Although you cannot directly add a composition to itself, you can duplicate a composition and 
add the copy to the original.  

To duplicate a composition, select it in the Project panel and press Ctrl + D.  

To rename the duplicate composition, press Return, type the new name, and press Return again.  

 

When aligning layers using the Align panel, you must select two or more layers; to distribute, 
you must select three or more layers.  

 

Resize the expression text field by dragging the top or bottom edge of the text field.  

 

Adobe After Effects Help on the Web is updated frequently and contains much more information 
than is included in the Help document installed with the application.  

 

The Current Render Details display in the Render Queue automatically closes after 2 minutes to 
speed rendering.  

To stop the details from closing, Alt-click when showing the details; Alt-click again to restore 
the 2-minute limit.  

Showing details may increase render time.  
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For 2- and 3-dimensional properties in the Timeline panel, you can Alt-click the Constrain 
Proportions switch to set all dimensions to be equal.  

For example, doing this for the Scale property would reset the scale to be proportional.  

 

Alt-click a property's stopwatch in the Timeline or Effect Controls panel to add an expression.  

 

To show or hide the grid in the Footage, Layer, or Composition panels, choose View > Show 
Grid or press Ctrl + ' (apostrophe).  

 

To bring up the dialog boxes for standard Transform properties, use the following keyboard 
shortcuts after selecting a layer:  

Position: Ctrl + Shift + P 

Opacity: Ctrl + Shift + O 

Rotation: Ctrl + Shift + R 

You can also double-click a keyframe in the Timeline panel.  

 

Anchor point coordinates are relative to the layer, not the composition frame.  

 

By default, when adding a vertex to a mask, the new vertex appears on the mask throughout the 
mask's duration but reshapes the mask only at the time it was added. When you delete a vertex 
from a mask at a specific point in time, the vertex is deleted from the mask throughout the mask's 
duration. You can change this default by choosing Edit > Preferences > General and deselecting 
Preserve Constant Vertex Count when Editing Masks.  

 

Modify the settings for a camera, light, or solid-color layer by selecting the desired layer and 
pressing Ctrl + Shift + Y.  
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Safe-zone margins represent the percentage of image dimensions not included in the safe area. 

Widescreen compositions can also have center-cut margins for designing for 4:3 and 16:9 
viewing of the same composition.  

To change the Composition panel safe-zone margins, change the Action-safe or Title-safe 
percentage settings in the Grids & Guides Preferences.  

 

When working in 16- or 32-bit-per-channel color depth, plug-ins that are not 16- or 32-bpc-
aware are indicated by a yellow warning sign next to the effect name in the Effect Controls 
panel.  

 

To create a 3D layer that casts shadows but cannot be seen, set the layer's Material Options > 
Casts Shadows property to Only.  

 

Transformations on adjustment layers behave slightly differently; they transform only the matte 
but not the fill.  

 

You can hide any property or group in the Timeline panel by Alt + Shift-clicking its name.  

 

To make a keyframe's properties remain unchanged (that is, Hold) over time until the next 
keyframe, select one or more keyframes in the Timeline panel and press Ctrl + Alt + H. Press 
these keys again to remove the Hold interpolation.  

 

When rendering at reduced resolution, set the quality of the composition to Draft. Rendering at 
Best quality while reducing resolution does not produce a clean image and takes longer to render 
than if you use Draft quality.  

 

Because a layer's Anchor Point and Position properties change when you drag the anchor point 
using the Pan Behind tool, using the Pan Behind tool to change the anchor point of a moving 
layer alters the motion path. If your layer contains a motion path, move the anchor point in the 
Layer panel and then select the motion path and adjust it accordingly.  
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While the rendering process is paused, you will not be able to change settings or use After 
Effects in any other way, but you can use other applications.  

 

Rearrange columns in the Timeline, Project, and Render Queue panels by dragging them left or 
right.  

 

The stencil and silhouette blending modes affect all layers below the layer to which they are 
applied. To keep the silhouette and stencil blending modes from cutting through or blocking all 
layers underneath, precompose the layers to be affected.  

 

Before rendering, check the Audio Output settings in the Output Module Settings dialog box to 
ensure that they are correct. If your project includes audio, be sure that Audio Output is selected. 
If your project does not include audio, do not select Audio Output so that the size of the rendered 
file will not increase needlessly.  

 

It is best not to use output module stretching to change the vertical dimensions of a movie when 
field rendering is on. Stretching vertically mixes the fields, which distorts motion.  

Use either cropping (by an even number of pixels) or composition nesting if you need to 
vertically resize a field-rendered movie.  

 

To lock focus to zoom for a camera, select Focus Distance in the Camera Options property group 
in the Timeline panel, press Alt + Shift + = to add an expression, and use the expression pick 
whip to select the Zoom property.  

 

After selecting one or more masks, press Ctrl + T to enter Free Transform mode.  

 

You can scale masked solid-color layers to be as large as you want with no pixelation by turning 
on continuous rasterization for the solid-color layer. (Or you could just use a shape layer.)  
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You can set the mode for a 3D layer's axes with the Axis Mode buttons in the Tools panel. They 
change the alignment of the layer axes to orient towards local (layer), world, or view. This 
allows more options for rotating or translating objects interactively.  

 

Any changes to the interpretation rules.txt file take effect the next time you start After Effects. If 
After Effects is already running when you edit the file, you must exit and restart the application 
to activate the new rules.  

 

You can copy and paste keyframes into a text editor or spreadsheet application, such as 
Microsoft Excel, and modify the values. This method works for all keyframe types except masks 
and some effects properties.  

 

Mask and shape paths can be hidden by turning off the Mask And Shape Paths checkbox in the 
Composition View Options dialog box. This dialog box can be opened using the menu in the 
upper-right corner of the Composition panel or by pressing Ctrl+Alt+U when the Composition 
panel is active.  

 

The output module settings in the Render Queue panel allow you to crop or pad rendered 
compositions. Specify the number of pixels to be added or subtracted from the top, left, bottom, 
and right sides of the movie. Enter positive values to crop pixels and negative values to add 
pixels.  

 

If you remove 3:2 pulldown from interlaced video footage, After Effects automatically sets the 
frame rate of the resulting footage to four-fifths of the original frame rate. When removing 3:2 
pulldown from 30-fps video, the resulting frame rate is 24 fps. Removing 3:2 pulldown from 
29.97-fps video produces 23.976-fps footage.  

 

Gray lines between tiles in the Flowchart panel indicate that the Video or Audio switch for those 
items is turned off in the Timeline panel. Black lines indicate that the switch is turned on.  
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Use the menu in the Preview panel to choose between using the RAM preview options and using 
the Shift + RAM preview options.  

 

To temporarily switch to the Hand tool, hold down the spacebar or middle mouse button.  

 

To create a new composition with the same dimensions, duration, and frame rate as the first-
selected footage item, drag one or more footage items to the New Composition button at the 
bottom of the Project panel.  

 

You can maximize the panel under the mouse pointer by pressing the ` (accent) key. This is 
especially useful when viewing the Timeline panel of a composition with many layers.  

Press the ` (accent) key again to restore the panel to its original size.  

Far too many people mistakenly refer to this key as the tilde (~) key because the tilde is the 
shifted character over the accent grave on standard US keyboards.  

 

When using Paint tools on a layer, you can start over at any time by deleting the Paint effect 
applied to the layer. To delete the effect, select Paint in the Effect Controls panel and press 
Delete or Backspace.  

 

When dragging an underlined value in the Timeline panel, hold Shift to change values in larger 
increments (multiplied by 10); hold Ctrl to change values in more precise increments (divided by 
10).  

 

To produce rolling credits, try creating the credits in Adobe Illustrator. Import the Adobe 
Illustrator file into After Effects, and then animate the position.  

 

To play a layer backwards, choose Layer > Time > Time-Reverse Layer.  

You can also press Ctrl + Alt + R.  
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To move one or more keyframes along the timeline, select the keyframe icons in the Timeline 
panel and then press Alt + Left Arrow or Alt + Right Arrow.  

 

Double-click the Hand tool to zoom the Composition panel view to fit. Double-click the Zoom 
tool to zoom the Composition panel view to 100%.  

 

To toggle the Casts Shadows property for a 3D layer, press Alt+ Shift+ C.  

 

To reset the work area to be the same duration as the composition, double-click the Work Area 
bar in the Timeline panel.  

 

To edit footage in the associated application, select the item in the Timeline or Project panel and 
press Ctrl + E.  

 

To open the most recently opened project, press Ctrl + Alt + Shift + P.  

 

To improve render speed, turn off your anti-virus software.  

 

To show only frames that are currently cached in RAM, first press Caps Lock and choose RAM 
Preview or click the Play button in the Preview panel.  

 

To rename a layer in the Timeline panel, select the layer, press Enter, type the new name, and 
press Enter again.  

You can also rename an item by Right-clicking the item name and choosing Rename.  
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When rendering for final output, you can see the entire path to the output file, including file 
name. Click the triangle to the left of the Output Module heading in the Render Queue panel to 
see the full path. When the render and output operation is completed, click this link to reveal the 
file in Finder or Windows Explorer.  

 

To preview a composition using your full computer screen (with surrounding areas in black), 
select the Full Screen option at the bottom of the Preview panel.  

If the Preview panel is not visible, choose Window > Preview.  

 

To hear audio while scrubbing, hold down Ctrl as you drag the current-time indicator.  

 

To change the screen layout, use the Workspace menu in the Tools panel.  

You can create custom Workspaces by choosing Window > Workspace > New Workspace.  

 

When doing test renders, use the Timecode effect for a visual reference to specific times. This 
simplifies locating exact frames for adjustments.  

 

For added editing tools, hold down Alt while double-clicking a QuickTime or AVI movie in the 
Project panel to open an After Effects Footage panel.  

 

Shininess affects the size of the specular highlight on a lighted 3D layer.  

 

For intuitive control while panning and scaling a large image, animate a layer's anchor point 
instead of its position.  

 

To make many actions in After Effects more efficient, use keyboard shortcuts. Choose Help > 
Shortcuts for a complete list.  
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In the Footage, Layer, or Composition panels, you can display safe zones for titles and action. To 
toggle the safe zones, first make sure that the panel is active, and then press ' (apostrophe).  

 

To make your work area duration match the duration of selected layers, press Ctrl + Alt + B.  

 

Rename an effect by selecting the effect name in the Timeline or the Effect Controls panel, 
pressing Enter, typing the new name, and pressing Enter again.  

You can also rename an item by Right-clicking the item name and choosing Rename.  

 

The Brush tool is used to draw paint strokes directly in the Layer panel. Each stroke is added 
under the Paint effect in the Timeline panel, where you can animate its properties like Color and 
Hardness.  

 

To quickly change the quality settings for multiple layers in a composition, select the layers you 
want to change and then click the quality switch for any selected layer to toggle between Best 
and Draft quality.  

To set all selected layers to Best quality, press Ctrl + U. To set all selected layers to Draft 
quality, press Ctrl + Shift + U.  

 

To hold (freeze) the last frame of footage, enable time remapping (Layer > Time > Enable Time 
Remapping), and then extend the Out point for the layer.  

 

To show or hide rulers in the Composition panel, press Ctrl + R.  

 

To change how the Info panel displays color information, use the panel menu.  
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To show only properties that have keyframes or expressions, press U. If you select layers first, 
properties are only shown for selected layers. If no layers are selected, then properties are shown 
for all layers.  

 

To update imported items in your composition that have changed on the hard disk, select the 
item in the Project panel and choose File > Reload Footage. You can also Right-click the item in 
the Project panel and choose Reload Footage.  

 

You can replace the source footage for a layer without modifying any keyframes or effect 
settings. Select the layer and hold down Alt while dragging the new source footage from the 
Project panel into the Composition or Timeline panel.  

 

To prevent After Effects from updating the Composition panel while rendering, press the Caps 
Lock key.  

 

FLV cue point data, URLs, comments, and other information can be added to After Effects 
markers. Double-click a marker to add the data.  

 

To make your layers play sequentially, select them in the Timeline panel in the desired order. 
Then choose Animation > Keyframe Assistant > Sequence Layers. Specify any overlap and 
transition desired, and click OK.  

 

To accelerate panning with the Hand tool, hold down Shift while using the tool. This is useful for 
panning long distances. This works in the Composition, Layer, and Footage panels.  

 

You can quickly enable or disable switches and keyframes for multiple layers in the Timeline 
panel by dragging up or down in the appropriate column.  

 

To select all layers with the same label, click a layer's label and choose Select Label Group from 
the menu.  
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In the Render Queue panel, you can rerun a finished render by selecting it and choosing Edit > 
Duplicate With File Name.  

 

Effects applied to an adjustment layer affect all layers beneath it in the stacking order in the 
Timeline panel.  

 

Text layers can have multiple animator groups, and each animator group can have multiple 
selectors and animated properties.  

 

To restore the original Composition Settings presets or camera presets, Alt-click the trash icon 
next to the Preset menu.  

Warning: any saved custom presets will be deleted.  

 

To delete or lock layer markers in the Timeline panel, right-click the marker and choose Delete 
This Marker or Lock Markers, respectively.  

 

To control how a property changes over time, select a keyframe and use the Keyframe 
Interpolation dialog box: Ctrl + Alt + K  

 

To move the active window to your main monitor and resize it, press Ctrl + Alt + \.  

This is useful for rescuing a window that is hidden off screen (such as on a second monitor when 
the second monitor is off).  

 

Double-click a precomposition layer to open the source composition. Alt-double-click to open 
the precomposition layer in the Layer panel.  
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When copying and pasting between the same properties, you can copy from more than one 
property to more than one property at a time.  

However, when copying and pasting to different properties, you can copy only from one property 
to one property at a time.  

 

Free up memory immediately by discarding undo and redo information, image caches, and 
snapshots all at once. Press Ctrl + Alt + / (on the numeric keypad). You can also choose Edit > 
Purge > All.  

 

When using QuickTime Video Out (Video Preview), press / (slash) on the numeric keypad to 
output the current frame to the selected video device or monitor.  

 

You can create several different output files from a single render. Select the render item in the 
Render Queue panel and choose Composition > Add Output Module, or click the plus sign to the 
left of the Output To heading in the Render Queue panel.  

 

Control the starting vertex of a closed mask by selecting the desired vertex and choosing Layer > 
Mask > Set First Vertex.  

The first vertex affects the shape correspondence when animating masks. The first vertex also 
affects effects like Path Text when set to use a mask.  

 

To replace every instance of a layer's source in the project, press Alt and drag the new source 
footage item onto to the old source footage item in the Project panel.  

 

Cycle through tools in the Tools panel by Alt+clicking the tool button.  

 

To paste a layer at the current time, press Ctrl+Alt+V.  
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Preview audio in the work area using Alt + decimal (.) on the numeric keypad.  

 

To show only properties that have been modified, press UU. If you select layers first, properties 
are only shown for selected layers. If no layers are selected, then properties are shown for all 
layers.  

 

To switch to the next/previous blending mode in the Timeline panel, press Shift+= (equals) or 
Shift+- (hyphen) on the main keyboard.  

 

To reset the position and anchor point of a layer, select the layer and Alt+double-click the Pan 
Behind tool.  

 

To remove a footage item from the project without receiving a warning, hold Ctrl while deleting.  

 

To convert a text layer's characters to shapes or to masks on a solid layer, select the characters to 
convert and then choose Layer > Create Shapes From Text or Create Masks From Text.  

 

Animation presets will automatically appear in the Effects & Presets panel when you save them 
in the Presets folder within the After Effects program folder.  

 

To open the View Options dialog box quickly, press Ctrl + Alt + U.  

 

To prevent a mask from being edited, click the mask lock switch in the same Timeline panel 
column as the layer lock switch.  

 

Before you paste keyframes from one layer to multiple layers, select the destination layers.  
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To locate layers based on a source footage item, right-click the footage item in the Project panel 
and choose a composition from the Reveal in Composition submenu.  

 

To create compositions automatically for file conversions and prerendering, drag footage items 
from the Project panel directly to the Render Queue panel.  

 

To control motion blur on a per-mask basis, select a mask, choose Layer > Mask > Motion Blur, 
and then choose one of the three Motion Blur options.  

 

To set view options for multiple views at the same time, choose Share View Options from the 
View Layout menu at the bottom of the Composition panel.  

 

After Effects can use OpenGL to accelerate rendering for many features.  

Note: Which features can be rendered with OpenGL depends on the your hardware. Click the 
OpenGL Info button in the Fast Previews Preferences to see what your hardware supports.  

 

To select a Fast Preview method, use the Fast Preview popup menu in the Composition viewer. 
The options are:  

Off 

Wireframe 

Adaptive Resolution - OpenGL Off 

OpenGL - Interactive 

OpenGL - Always On 

 

Press PP to show only paint strokes and Puppet pins for selected layers in the Timeline panel. .  

If no layer is selected, properties are revealed for all layers.  
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To activate the Horizontal Type tool, use Ctrl + T when no mask is selected.  

Press Ctrl + T again for the Vertical Type tool.  

 

Did you know that After Effects uses many of the same text editing keyboard shortcuts as Adobe 
Photoshop?  

 

To create a keyframe on the path of a single selected mask, use Shift + Alt + M.  

 

Add an effect to all selected layers by double-clicking the effect in the Effects & Presets panel.  

 

In the Effect Controls panel, Alt-click a property stopwatch to add an expression to the property. 
Edit the expression in the Timeline panel.  

 

To display duration between two layer markers or keyframes in the Info panel, Alt-click any two 
layer markers or any two keyframes.  

 

Alt-click the Scale property's Constrain Proportions switch in the Timeline panel to set all 
dimensions to the same value. This also works for Mask Feather and any multidimensional 
property.  

 

To delete all composition markers or layer markers, use the marker context menu.  

 

To crop your composition to the region of interest, choose Composition > Crop Comp to Region 
of Interest.  
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To select all keyframes on the same property that have the exact same value, use the keyframe 
context menu command Select Equal Keyframes.  

 

The Auto-trace command in the Layer menu can be used to generate masks from an image based 
on its alpha channel, luminance, or any of the color channels. For example, you can use it to 
trace a person's head and run text around it or to trace a figure and apply the Scribble effect to the 
inside of the mask.  

 

When collecting a subset of source files in the Collect Files dialog box, select the "Reduce 
Project" option to remove unused footage items and compositions from the collected project. If 
All or None are selected in the Collect Source Files menu, the Reduce Project option is not 
available.  

 

To learn about using scripts, go to Help > Scripting Help.  

 

To select and cycle through paint tools, press Ctrl + B.  

 

To animate text characters individually in 3D space, choose Animation > Animate Text > Enable 
Per-character 3D.  

 

Use - (hyphen) and = (equals) on the main keyboard (though you may be tempted to think of 
them as the minus and plus keys) to zoom in time in the Timeline, Layer, and Footage panels.  

 

To reveal selected properties in the Timeline panel, press SS. This command will also hide any 
properties that are not selected. This is good for revealing a Path property for a mask or shape 
that you're manipulating in the Composition panel.  

 

You can adjust the tension of roto-Bezier masks by dragging with the Convert Vertex tool.  
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To duplicate a hierarchy of layers, select the parent layer, then choose Select Children from the 
layer context menu, and then copy and paste.  

 

To reveal a track point in the Timeline panel, select the track point in the Layer panel and press 
SS ("show selected").  

 

To maximize or restore the panel directly under the pointer, press the accent grave (`) key. And 
don't call it the tilde (~) key, even though these two symbols share a key on a standard US 
English keyboard.  

 

To get extra precision of imported Adobe Illustrator art, click More Options in the Interpret 
Footage dialog box and choose More Accurate from the Anti-aliasing menu.  

 

To set the magnification of the active viewer to 100%, press /.  

 

To set the magnification of the active viewer to Fit, press Shift + /.  

 

To cycle through the time display formats, Ctrl-click the Current Time display in the upper-left 
corner of the Timeline panel.  

 

To cycle forward through tabbed panels in a frame, press Alt + Shift + period. To cycle 
backward through tabbed panels in a frame, press Alt + Shift + comma.  

 

To cycle forward through items in the active viewer, press Shift + period. To cycle backward 
through items in the active viewer, press Shift + comma.  

 

To undock a tabbed panel from its frame and create a floating window, hold down Ctrl while 
dragging it.  
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To navigate to a composition that is either upstream or downstream of the current composition, 
click the Composition Mini-Flowchart button at the top of the Timeline panel.  

 

To maximize the active window, press Ctrl + \ . Pressing this key sequence again will toggle 
between showing and hiding the window title bar.  

 

To adjust brush size, hold down Ctrl while dragging left or right. Release the Ctrl key and 
continue to drag to adjust the brush hardness.  

 

Shape layers can contain many shapes. Creating a shape while an existing shape layer is selected 
will create it within the selected shape layer.  

 

Shape tools can be used to create shapes or masks. To add a new shape to an existing shape 
layer, click the Tool Creates Shape button in the tool options of the Tools panel and then draw 
the shape. To add a mask to a shape layer, click the Tool Creates Mask button.  

 

To add a shape path operator, use the Add menu located at the top of the shape layer properties 
in the Timeline panel or in the tool options area in the Tools panel.  

 

To cycle through fill or stroke types (none, solid, linear gradient, radial gradient), Alt-click the 
color swatch in the tool options of the Tools panel.  

 

Press Ctrl + G to group selected shapes on a shape layer. Press Ctrl + Shift + G to ungroup 
shapes.  

 

When creating shapes with the shape tools, many of the shape's properties can be adjusted using 
modifier keys (usually matching Adobe Illustrator). For instance, while dragging to create a star, 
press the Up and Down Arrow keys to increase and decrease the number of points on the star.  
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To focus your design choices on a smaller region of your composition frame, set a region of 
interest before using Brainstorm.  

 

An instance of the After Effects application can run on each of your processor cores. Each 
instance requires at least 512 MB of RAM. More RAM (1-2GB per core) is recommended. 
Configure multiprocessing in the Memory & Multiprocessing Preferences.  

 

To record the animation of Puppet Deform pins, Ctrl-drag them.  

 

To control overlapping areas of a Puppet mesh, use the Puppet Overlap tool.  

 

Use the Puppet Starch tool to reduce undesired deformation.  

 

To prevent a mask from being used when generating a new Puppet mesh, lock the mask.  

 

For faster interaction when using Puppet tools, work at lower triangle counts for the mesh. For 
higher quality, increase triangle count prior to rendering final output.  

 

For faster interaction when recording animation with Puppet pins, select Use Draft Deformation 
in the Puppet Record Options dialog box.  

 

Use Adobe Clip Notes for client and colleague review. 

Select File > Export > Adobe Clip Notes to add an Adobe Clip Notes module to the render 
queue. Don't forget to click Render.  
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To import Adobe Clip Notes comments, select File > Import > Adobe Clip Notes Comments. 
After selecting the appropriate comment file, new composition markers will be added to the 
selected composition. Double-click the markers to see the comments.  

 

To apply a Photoshop layer style to selected layers, choose Layer > Layer Styles.  
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