Adobe Creative Cloud

Digital Video & Audio

October 10, 2014 /Product Focus /

Bugs fixed in Premiere Pro 2014.1 Release

Alongside the many new features in the Premiere Pro 2014.1 release, a great deal of known issues and bugs have been addressed. The following is a list of the key issues resolved. Many thanks to Mark Mapes for his hard work creating this list, which is arranged by functional area of the application.

 

Import

  • Import of CinemaDNG clip fails if the file has been renamed.
  • Gamma shift in some re-imported QuickTime IMX clips
  • Some QuickTime Reference files import without timecode.
  • Indexing of XDCAM clips can take an excessively long time, footage shows Media Pending until indexing completes.
  • XAVC-S files import without Timecode
  • Unable to import certain XDCAMHD 422 Long-GOP clips with Pixel Aspect Ratio of 0.7500 MXF
  • Spanned XDCAM HD422 clips not handled correctly if the clip names do not follow the normal convention
  • When a sequence is loaded from Media Browser to the Source Monitor and then inserted to a sequence without explicitly importing, two copies of the sequence are added to project.
  • Scaling values are not properly handled for clips/sequences imported via an XML file written by some shot management and conforming programs
  • If the reported duration of an XDCAM HD MXF clip shorter than the actual length in the file, then frames outside the stated duration can be accessed.
  • Some XAVC and XDCAM-IMX-MXF clips have audio noise introduced on playback
  • Some .mp4 have green frames and ‘static’ garbage when played in Source Monitor
  • Canon XF300 Footage has unacceptable performance for playback
  • .mp4 clips generated by certain transcoding programs exhibit poor playback performance
  • PPro no longer recognizes timecode from a .qtc file, referenced from within a QuickTime reference movie.
  • Some XDCAM422 clips fail to import with generic error
  • Occasional crash on opening Source Settings for DNG footage, with 2nd monitor enabled
  • Overexposed white areas in some CinemaDNG footage display magenta artifacts.
  • When scrubbing C300 clips in Project panel’s Icon view, red frames sometimes show and Event panel reports error decoding frame.
  • If SpeedGrade was installed before Premiere, then double-clicking a prproj file launches SpeedGrade (Mac Only)

Growing File

  • The last frames of some growing file are green. Must relaunch Premiere to correct the problem.
  • Importing a growing file can take an exceedingly long time, with footage showing as Media Pending
  • When a growing file refreshes, it stops voiceover recording
  • The incorrect timecode is shown in the Timecode Panel for growing files.
  • Timeline playback of growing files drops audio for about 1 second each time the growing file refreshes.
  • QuickTime reference files for growing files fail to import.

 

Export

  • When source is 120fps, export fails if Match Sequence Settings enabled
  • The Advanced XDCAM Settings section in Export Settings is blank for imported XDCAM presets
  • In QuickTime encodes, audio exported as uncompressed stereo imports into FCP as dual mono.
  • When you export to 5.1 AAC with the “Import into Project” option enabled, the resulting clip fails to import, throwing
  • “File import failure”
  • Image flicker is introduced in some constant-bitrate MPEG2 encodes
  • When the only variable blocking smart rendering is an adjustment layer, the effect(s) thereon are ignored and the segment is smart rendered.
  • ProRes media encoded by Premiere causes are not compatible with certain video QC programs.
  • AAF export: 88.2kHz and 96kHz audio clips exported to AAF do not appear in some audio production programs.
  • Audio EDL gets wrong source timecode if clip is nested or part of a multicam source sequence
  • EDL does not give correct Source In and Out for clips with speed reversed.
  • EDL does not give correct source in and out on reversed clips.
  • OMF export fails with some multicam sequences, reporting Audio Export Failure.
  • Hang during OMF export when the sequence contains a 5.1 audio track/clip.
  • Smart rendering can introduce black and red frames

 

Playback

  • Playback of IMX 50 clip freezes after 12 seconds.
  • With XDCAMHD and DVCProHD footage, frames are sometimes dropped though the render bar is green.
  • Audio for some mp4 files plays back at double speed
  • When pre-roll is set to 1 frame, timecode and video of XDCAM .mxf files are out of sync
  • Some DNxHD do not decode properly, resulting in frames being played out of order
  • Performance of playback for some QuickTime is poor because they are unnecessarily falling back to QT32
  • Dropped frames when playing R3D clips with RocketX enabled and Playback Resolution at ¼

 

Audio

  • With Maintain Pitch enabled, no audio when playing at slower than real-time
  • Solo buttons in Audio Meters do not work for clips loaded into the Source Monitor
  • Mono and Standard track puck and tray panner routing for Ls, Rs, C and LFE channels do not adhere to ITU-R BR.1384 standard.
  • Occasional crash on switching a clip from mono to stereo via Modify>Audio Channels
  • 1 channels are not properly mapped for some Dolby content.
  • 1 clip changes to a 6 mono channel clip when “Extract Audio” or “Edit in Adobe Audition>Clip” is performed on a project item or track item.
  • Changes to Frame Rate via Interpret Footage are sometimes not applied to saved for all audio streams, causing most audio channels to be out of sync after closing/reloading project.
  • Constant Power audio transitions introduce buzz if either track item has zero channels (generally limited to multicam clips)
  • Crash on applying changes in Modify Audio Channels dialog [Mac Only]

 

Project panel

  • Sorting by Duration is broken if the column has been moved during the current session
  • If the Project panel is filtered via Rapid Find when a bin is created, the edit control for naming the new bin does not become active automatically, and it cannot be activated manually until Rapid Find is cleared.
  • Project items cannot be deleted or renamed if the list view is scrolled to the right.
  • Project panel does not autoscroll to the left when a column is dragged to the right side of the Name column
  • When a timecode value is typed in the Video Out control for a clip in the Project panel, the value gets reduced by 2 frames upon committing the change

 

Subclip

  • When a soft subclip with only an Out Point set is edited into a sequence, the Subclip Start is ignored; the resulting track item extends all the way to Media Start.
  • The Media Start/End and Subclip Start/End times for subclips from a merged clip are incorrect

 

Editing/Timeline

  • 3-Point edit: If the source is a sequence and only an Out Point is set for the source, the wrong segment gets inserted when KEM Roll is set to Insert as Individual Clips
  • Keyboard trim commands do not affect clips on targeted tracks that are outside of visible area of in the Timeline
  • Switching between sequences can turn the render bar red.
  • Frame Hold option doesn’t generate the freeze frame when speed change is in effect
  • In the Timeline, the FX badge gets hidden when the clip is not wide enough to show the full clip name.
  • If the Left/Right Balance control is displayed in Timeline header, the balance will change if the mouse strays over the Header region during click-and-drag operations in the Timeline (such as trimming out)
  • ‘Select In to Out’ selects clips on locked tracks.

 

Multicam

  • If a multicam sequence’s audio is 5.1 or adaptive, then flattening deletes the audio.
  • If time-remapping is used on a Multicam Source Sequence, the Program Monitor’s multicam view continues to play at 100%; if source sequence was slowed, the Composite view goes black after the original end point.
  • When a multicam source sequence has been slowed down via speed change or time remapping, the extended of the clip goes black—no video
  • If the audio in a multicam sequence is selected when it is flattened, the audio is sometimes deleted.
  • Disabled multicam source clips are sometimes rendered to the composite output
  • Flattening multicam can remove some audio clips from the sequence.
  • Flattening a multicam sequence with reverse speed applied results in incorrect frames being used
  • The camera can be changed for a multicam clip on a locked track.
  • The overlay displays timecode in audio time units for part of a multicam sequence if the source clips are stereo and the MC sequence is mapped to mono
  • If a nested multicam sequence’s duration has been increased via Time Remapping, then upon reaching the original end point during an editing pass, the composite view restarts from beginning
  • Crash on flattening multicam clip with keyframed scale when using a camera angle that does not start at time zero.

 

Effects

  • AE Text Template] When text fields are active for editing, they’re not being visually highlighted
  • Adding mask points very close to each can result in the ordering of the points being incorrect
  • Incorrect scaling of 1920×1080 adjustment layers in 720 sequences
  • Unexpected behavior with Cross Dissolves between Adjustments Layers.
  • Applying both Echo & Levels effects to an adjustment layer causes video playback to freeze
  • Crash on rendering previews for a Lumetri filter in Software-Only mode.
  • Crash on deleting a clip from a sequence after pasting an effect mask to the clip.
  • JPG frame sequence gets scaled down if an adjustment layers is in effect above it [OpenCL only]
  • Rename GoPro lens distortion presets to include the camera name
  • Clip name effect doesn’t work correctly if Source Track is set to a different track.
  • Crash on using Clip effect or Timecode effect on a transparent video.
  • Crash on loading or applying VST Effects (Mac only)
  • Intermittent Crash with Warp Stabilizer applied (AEVideoFilter)
  • The Clip Name effect does not work when applied to a transparent video track item, with Source Track set to a video clip.
  • Crash on applying audio transition to clips with overlapping timecode
  • Previewing fails when an adjustment layer has an animated mask applied to Opacity and any other video effect.
  • In Software-Only mode, rendering previews of the new Cross Dissolve is slower than the old one.

Effects, Masking and Tracking

  • Shift-dragging a control point for an effect mask sometimes yields unexpected results
  • If a clip has an effect with a mask applied, moving the clip in the Timeline cause rendered preview files to be lost.
  • Previews rendered to a P2 codec are incorrect for the first 10-30 frames of an Opacity effect with mask applied
  • If a mask is applied to a GPU accelerated effect on an adjustment layer, the Program Monitor shows a cropped frame with Playback Resolution at Half and goes completely black at Quarter.
  • Opacity effect on Adjustment Layers fails to render within the mask with tracking.
  • After rendering an adjustment layer with multiple effects with masks applied, some of the effects are no longer confined within the mask [Mac only]
  • Crash on opening some projects with masking and tracking applied to effects
  • Direct Manipulation control fails to switch between multiple masks that are applied to the Opacity intrinsic effect.

Effects, 3rd Party

  • Certain audio filters cannot be applied to a clip in a sequence that is imported via XML
  • PPro reports audio filter missing when opening a saved project with certain audio filters applied to the clips in a sequence that was imported via XML
  • Artifacts are introduced when using certain 3rd party transitions.
  • Certain 3rd party stabilizer plug-in are not working

 

Markers

  • On mouse-up after adjusting the Out point of a marker with duration, the playhead jumps to the marker’s In point.
  • Video in Program Monitor strobes when dragging the In or Out point of a sequence marker

 

GPU

  • With GPU acceleration enabled, Gamma is being applied to some RAW media when it shouldn’t be.
  • Basic 3D effect can result in Program Monitor’s video overlay to become corrupted on some GPUs

Performance (Note: Most of these fixes are also listed under a product area)

  • Locking all Audio Tracks can significantly impair performance.
  • Performance of playback for some QuickTime is poor because they are unnecessarily falling back to QT32
  • Dropped frames when playing R3D clips with RocketX enabled and Playback Resolution at ¼
  • Navigating through projects in multiple Media Browser panels impairs performance and can culminate in a crash
  • In Software-Only mode, rendering previews of the new Cross Dissolve is slower than the old one.
  • Canon XF300 Footage has unacceptable performance for playback
  • .mp4 clips generated by certain transcoding programs exhibit poor playback performance

 

Interop

  • Crash on selecting Edit>Edit in Adobe Audition>Sequence…
  • When a 5.1 clip is sent to Audition via Edit Clip In Adobe Audition, the first channel is used for all channels.
  • Exporting from Audition to Premiere Pro opens Premiere, but the file fails to import
  • After grading a sequence in SpeedGrade, Premiere regenerates index & pek files

 

Miscellaneous

  • With some capture card hardware, captured uncompressed clips have the wrong field order
  • In the Overlay Settings dialog, the Track control is not properly constrained by the Property control.
  • A single preference flag is used for the “Import into Project” setting in the Export Settings dialog and the Export Frame dialog; they should be managed independently.
  • Custom scratch disk location for Video and Audio Preview folders get’s reset to default, “Same as Project File”
  • Changes to the label color cannot be undone.
  • In the Usage lists, all instance are ordered by track item start time; should sort by Sequence Name first, then by track item start
  • Automatic relinking fails in certain cases when the name of a folder in the relative paths are too similar. [Mac only]
  • With OpenCL GPU acceleration and Transmit enabled with some 3rd party I/O cards, the video on the output monitor is corrupted
  • Newly created projects sometimes have multiple Project Panels open.

 

 

Product Focus

Join the discussion

  • By Michal - 3:02 PM on October 10, 2014  

    hi guys,

    wow, never heard of most of them… one question, do you mean audio dropouts in the last point in “playback”? I really, really, reeeeeeally hope so!

  • By Jamie H - 8:49 PM on October 10, 2014  

    Hi Al!

    Lots of great stuff in this update! Thanks for all your hard work. However, one issue on the list above has plagued our workflow for some time now and it shows in your Editing/Timeline fixes as “Fixed”. But sadly it’s not…It’s the “Switching Between Sequences can turn the Render bar Red”. It still does this. In fact, Premiere FREEZES up for anywhere from a few seconds to a full minute while the render bar goes from Yellow to Red then back to yellow. This issue is VERY EASILY reproduced. See link below. I really hope this is actually fixed soon:

    https://forums.adobe.com/message/6807004#6807004

    Thank you again! While I’m a fan of updates, what I really love/miss is a bug-free workflow. More than anything, thank you for your team’s continued effort to deliver a stable and bug-free program. I hope this issue gets resolved. It’s certainly easy to reproduce.

  • By KEAGAN ANFUSO - 3:45 PM on October 16, 2014  

    Ever since this update none of my adobe suite programs will stay open longer than 10 minutes without crashing and Adobe Premiere absolutely refuses to allow playback of the timeline without freezing.

    3.4 GHz i7
    8GB 1600 MHz DDR3
    NVIDIA GeForce GTX 675MX 1024MB
    OS X 10.9.5