Adobe Creative Cloud

NOW LIVE! The Latest Update of Premiere Pro CC

Today we’re tremendously excited to be releasing the latest versions of Premiere Pro and Adobe Media Encoder CC (2015.3), which are accompanied by new releases of After Effects and Audition… not to mention updates to creative applications across Adobe Creative Cloud.

Creative Cloud members and trial users will be able to download and install these applications today using the Creative Cloud desktop application, or online from http://www.adobe.com/creativecloud.html.

Please note that 2015.3 requires an update to the project file format, and as such projects saved in 2015.3 can not be opened in previous versions.

The new versions of Premiere Pro and Adobe Media Encoder contain all the features we previewed at NAB in April, including powerful new Media Management features, which allow you to copy media and edit it during ingest, transcode media on ingest, and generate lightweight proxy versions of RAW/Native files which can be switched to and from with a single click. New features in the Lumetri color panel include powerful new HSL Secondaries, new SpeedLooks linear looks, support for color control surfaces, enhanced Lumetri scopes and support for monitoring Rec2020 color space. Also new is amazing new support for VR Video workflows, which enables you to enter a specific monitoring mode with equirectangular stitched media to experience the view from inside the sphere. When you have completed your editing – publish to Facebook or YouTube with the correct metadata tags for a 360 viewing experience.

Adobe Media Encoder also now features the familiar Media Browser making it easy to work with file-based video media and projects. Our destination publish adds Publish to Twitter for easy, direct sharing with your followers.

Alongside the key features listed above, there are many other new features and enhancements to both applications, a full list of which appears below.

Performance optimizations

  • Apple Metal GPU supported by Mercury Playback Engine (Initial support – some effects not currently supported)
  • Native decode (i.e. no QuickTime installation required) on Windows of Apple ProRes
  • Improvements to MorphCut face detection and tracking
  • H264 playback GPU acceleration (Windows platform with Intel IRIS chipsets only)

Enhancements to the editing experience

  • Import, edit, and create Open Captions (subtitles), including options for font, size, position, color, weight, background color and background opacity
  • In-application licensing of Adobe Stock assets from Project Panel or Timeline
  • New badge in Project Panel for unlicensed stock assets
  • Support for Arabic and Hebrew languages in the Titler
  • Timeline auto scroll when range selecting
  • See more tracks at once with smaller minimum timeline height
  • Remove Attributes to remove individual effects from clips
  • Newly assignable keyboard shortcuts:
    • Add/remove a keyframe in the Effect Control Panel
    • Nudge keyframe left or right by one frame
    • Select next/previous keyframe
    • Increase/decrease keyframe value
    • Constrain Direct Manipulation horizontally or vertically while dragging
    • Toggle timeline zoom to single frame level
  • Twirl state of intrinsic effects shared between all clips in Effect Control Panel is remembered
  • Twirl state of parameters in Export Settings dialog is remembered
  • Show all clip markers in a sequence in the Markers panel
  • Filter markers in the Marker panel by color
  • Frame count offset updates dynamically while trimming with the mouse
  • FCP XML time remapping (speed ramps) support
  • Adjust multiple clips’ field options simultaneously
  • Create dedicated folders for each Scratch Disk file Premiere generates
  • Multiple fixes to known issues with voice-over recording using Mercury Transmit

New and improved format support

  • AS-10 export
  • Direct export to XDCAM HD disc
  • HEVC 10-bit export
  • Improvements to J2K export (24p and 30p now supported)
  • Panasonic AVC-LongG export
  • RED Weapon 8K, RED Raven support
  • QT XDCAM HD to MXF XDCAM HD Smart Rendering
  • ‘Sony device compatibility’ checkbox added to XAVC export settings
  • Match Source controls for still image formats
  • Create separate mono channels for DNxHD exports
Product Update, Video Editing

Join the discussion

  • By Manpreet - 11:03 AM on June 21, 2016  

    Thank you!! will this improve performance on El Capitan??

    • By Manpreet - 11:04 AM on June 21, 2016  

      update is not showing up on my updates in adobe premiere..

  • By Tiffany - 2:22 PM on June 21, 2016  

    Does this mean there will not be an official CC2016 release???

  • By Raymond - 6:50 PM on June 21, 2016  

    I just updated to Premiere 2015.3. Opened a current project and all media is offline except a wave file music track. Tried to re-link, but got a message “Selected file dos not contain audio media used by clip references – Audio clip reference will be deleted”. 1. Why is my media ‘offline’. 2. What happens if I OK the message?

    • By Raymond - 12:17 AM on June 23, 2016  

      Found an old blog where this happened back in 2013. Copied all media to another folder. Re-opened the project and it located the media without having the audio error. Obviously this has happened before, so why is it not fixed?

  • By Magdalena - 3:37 AM on June 22, 2016  

    I have problem after this update, “Windows Firewall” and AVT ANTYVIRUS , show some detection! and I can’t back to previous version only to CC 2015. When You Will fix it ??

  • By Javi Díaz - 4:09 AM on June 22, 2016  

    Hi there, it works like shit over a pc with windows 10. Last version was ok, and I´m feeling like nothing has changed. It´s terribly inoperative and slow. What´s the problem?

    • By Braden - 11:20 AM on July 20, 2016  

      Same problems here. Every time I switch between sequences the whole program freezes, and takes anywhere from 30 seconds to 4 minutes to play the timeline. Experiencing a lot of down time, unfortunately.

  • By Josh - 5:50 AM on June 22, 2016  

    Love that we’re getting support for Weapon and Raven…is there also support for Scarlet-W?

  • By Steve - 7:25 AM on June 22, 2016  

    Installed on 2 machines – bitterly regret it now – my fault – should have left it for 6 months or so until the bugs were worked out. Huge number of random crashes with no bug reports – just frozen screen and playback… Now for the painful process of rolling back.

  • By Adam - 9:44 AM on June 22, 2016  

    Multicam audio sync isn’t available. anyone have a fix for this?

    • By Adam - 10:00 AM on June 22, 2016  

      Actually it’s an import problem, audio is not being imported from one of the cameras, even though it’s the same as another one with the exact same settings.

  • By Tom - 11:31 AM on June 22, 2016  

    I’m experiencing an audio glitch in Media Encoder 2015.3 where it cuts the end of the audio track off and instead repeats the previous 1.5 seconds of the audio. Happens when I render from After Effects either from inside AE or drag and drop the comp. Does not happen with Premier Pro 2015.3 when I render from within Premier Pro or drag and drop the project. Thanks.

    • By Duke Sweden - 3:05 PM on June 23, 2016  

      Oh man, not that again! This problem has been ongoing for years and Adobe promised it was fixed in this update. Grrrrr….

    • By Will Powell - 9:06 PM on July 1, 2016  

      Having a lot of problems. On a windows 10. Can’t even open creative cloud without running in administrator mode. the playback on premiere stutters, and when I switched to memory-based playback the clip now the playback is faster than the fps. I bought premiere last month and it worked fine but this release feels like a broken mess. Very disappointed and I wish it would be fixed soon.

  • By Raymond - 12:23 AM on June 23, 2016  

    Open Captions. I have not used this before. Saw the demo video for 2015.3, and gave it a try on a project where the interviewees have speech problems. Made the captions fine. When I tried to play them, Premiere crashed. Restarted with the recovered project and everything was there. Played the project but they do not display. Yes I have got them at the highest video layer. I have titles which work fine. Is there another setting to display them?

  • By Hanspeter Wagner - 7:14 AM on June 23, 2016  

    “create proxies” doesn’t work with multichannel audio (e.g. SONY PXW-Z100, 8 channels, but only 2 are recorded). How to handle this?

  • By Jack Morgan - 12:54 PM on June 23, 2016  

    Yep, made the same mistake. Lost all pre-sets and worse all LUTs on any Log-C footage…

  • By Joshua - 7:34 AM on June 24, 2016  

    When i used to prepare to export my gameplay video with webcam before queuing it to the encoder, i would simply chose the Youtube 1080p preset and it would auto-fill everything in an MP4 file. Now that preset is gone in Premiere and no MP4 option. Any help?

  • By Adam - 2:26 AM on June 25, 2016  

    Hey folks in need of help. I have Media Offline in Media Encoder, it’s fine when i export from Premiere. I have deleted the media cache and files, restarted computer, moved the cache folders etc… still not working, have a big deadline and lots of editing to do so can’t render out of premiere. any help is appreciated.

  • By Robert Hanson - 8:17 PM on June 26, 2016  

    What happened to exporting video as MP4? all of my presets were set up for that.

  • By Kaiyuan - 7:13 AM on June 27, 2016  

    It does not support h.265 and VP9?

  • By Paula Gillan - 11:21 PM on June 27, 2016  

    Please could you tell me has there been support added for the Imac 2015 5k graphics card AMD Radeon R9 M395X 4096 MB? In 2015.2 I am having to render in software only which is very disappointing and frustrating.

  • By willem - 2:20 AM on June 28, 2016  

    just updated my system. lots of problems. any chance to go back to version cc 15.2 in premiere pro cc?

  • By Able - 9:01 AM on June 29, 2016  

    Getting a lot of weird glitches on my screen when using the new update and then it will come up with a serious error and need to reboot. Also had several hard crashes. Tried using adobe.com bug report feature but will not accept a form long enough to show the error messages ;( 2013 rMBP with El Capitan.

  • By Calle - 11:49 AM on June 29, 2016  

    I can’t export anymore to Media Encoder! This is driving me nuts! I just have to export to a mp4 and I’ll be done. What is going on?

  • By kirm - 2:53 PM on July 2, 2016  

    how do you add 4k?

  • By demi - 8:23 PM on July 2, 2016  

    Just updated and it sucks. Had to relink to Adobe Effects Project – but it would NOT – crashed every time. Tried it the other way from AE and “dynamic link server not responding” from either side (AE or PP). Tried renaming projects since it was a long string. I was literally one tweak away from wrapping up a 4 year project to release this weekend. I only updated because I had partially started update and canceled midway (at 20%) because I figured I better not till next project. But then I returned to PP and it was behaving poorly so I suspected my canceling mid-update was the problem so I finished the update only to have the most dysfunction I’ve ever encountered on PP. Ever!

    • By demi - 9:25 PM on July 2, 2016  

      Why are the LUTs and LOOKS changed for the worse such that I lost something I color-graded and redoing it is subpar using the same LUTs and LOOKs I had before. For such a SMALL LEVEL UPGRADE it sure has come with a LOT of PROBLEMS in just the first couple of hours of using.

  • By Neil Bastin - 10:39 AM on July 5, 2016  

    There are reports that support for older NVIDIA video cards in both MAC & Windows platforms has been dropped due to the use of a newer CUDA architecture. This means no more GPU acceleration for a long list of cards and systems. As of today, July 5th, this change is NOT documented and has already impacted a lot of users who where forced to rollback to 2015.2, use Mercury Playback in Software Mode or invest in new hardware right away. I’ve only found one Adobe staff member that has acknowledged this: https://forums.adobe.com/thread/2172957. Mr. Mooney, please take note of this and ask your team to update the documentation at the very least.

  • By cody - 12:15 PM on July 5, 2016  

    Hi!

    In Premiere 2015.3 importing SRT caption files with German text is broken. Where accent marks should be there are only asterisks, as in **ber and f**r etc, and some of the letters are just missing entirely if they’re near accent marks.

    This makes it unusable for my current job which is a shame. Also the inability to change global SRT properties (font, size, etc) for existing captions makes the ability to change anything a complete waste of time compared to using the titler.

  • By Al Fischer - 12:26 PM on July 6, 2016  

    Since the upgrade I’m having trouble using shot match between Speedgrade and Premiere. Speedgrade wont open and giving an error message stating “the project is from a new version of Premiere and cant open”

    Is there a new way to do this since the upgrade?

    • By Nate - 1:42 PM on July 6, 2016  

      They removed the compatibility between Premiere project files and Speedgrade. For some reason they took the one thing we all loved most about the communication between the two programs and threw it away – in favor of the incredibly sub-par lumetri panel. To Adobe’s credit – I spoke to one of their support staff and he said there is a good chance that they will bring the direct link back in the next update, that it was a mistake to remove it. If you submit a feature request form, you can add your voice and let the engineers know you want it back. It seems like they are reconsidering this downgrade.

  • By JD - 11:46 AM on July 9, 2016  

    The latest update fucking sucks. If I am able to get all of my media and associated files situated, the playback is shit – no audio and if I stop and restart or change my place on the timeline, the program doesn’t keep up. How the fuck do you roll out an update that doesn’t allow a seamless transition for basic use? I am in the middle of a large project and don’t have time or patience to play “IT” with Adobe since their customer support sucks. Is there a fix to get my videos to play and edit where I can hear the audio? Can I remove this update and go back to the previous version?