Archive for January, 2013

CRXDE Lite: IllegalStateException: I18nManager not initialized

Issue

If you have installed a hotfix for CRX you may encounter problems accessing CRXDE Lite accompanied by the following error in the server.log:

*MARK * servletengine: Servlet threw exception:
java.lang.IllegalStateException: I18nManager not initialized
at com.day.crx.i18n.I18nManager.getInstance(I18nManager.java:59)
at org.apache.jsp.de.index_jsp._jspService(index_jsp.java:59)
at org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:98)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:802)
at org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:328)
at org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:315)
at org.apache.jasper.servlet.JspServlet.service(JspServlet.java:265)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:802)
at com.day.j2ee.servletengine.ServletRuntimeEnvironment.service(ServletRuntimeEnvironment.java:228)
at com.day.j2ee.servletengine.RequestDispatcherImpl.doFilter(RequestDispatcherImpl.java:315)
at com.day.j2ee.servletengine.RequestDispatcherImpl.service(RequestDispatcherImpl.java:334)
at com.day.j2ee.servletengine.RequestDispatcherImpl.service(RequestDispatcherImpl.java:378)
at com.day.j2ee.servletengine.ServletHandlerImpl.execute(ServletHandlerImpl.java:315)
at com.day.j2ee.servletengine.DefaultThreadPool$DequeueThread.run(DefaultThreadPool.java:134)
at java.lang.Thread.run(Thread.java:662)

Reason

This problem is usually caused by a version mis-match in JAR library files which were installed through the CRX hotfix.

Solution

You should check for JAR conflicts with the versions contained in the hotfix as listed in the hotfix release notes.

You may need to copy the JAR files from:

…\crx-quickstart\server\runtime\0\_crx\WEB-INF\lib

to here:

…\crx-quickstart\server\lib\container

If this is a non-quickstart installation, then there are instructions in the HF release notes to manually delete older versions of JAR libs:

“Make sure to delete previous versions of installed Java libraries below <crx-webapp>/WEB-INF/lib to avoid classloading issues.”

reference: (33826)

VN:F [1.9.22_1171]
Was this helpful? Please rate the content.
Rating: 10.0/10 (1 vote cast)

CQ5: ClearableComboBox widget renders with 0px width and causes text-clipping

Issue

If you are using a ClearableComboBox widget on the second tab of a dialog, the widget is rendered with 0px width after selecting a value, which means the value is hidden/clipped.

-Install attached package into a CQ instance, it’s a modified dialog for the text component
-Open /content/geometrixx/en.html and drag a text component to the parsys
-Open the dialog for the text component
-Click on the tab “Bug Test” and select a value from the Combobox “ClearableComboBox”
-Important: Click on the tab “Text” to move away from the “Bug Test” tab
-Close the dialog with OK and open it again (usually just switching between tabs also shows the issue)
-Click on the tab “Bug Test”

Result: ClearableComboBox is rendered with no width, so value is not visible

Expected: ClearableComboBox to be rendered correctly so value is visible (ComboBox works fine)

Workaround
Using the ClearableComboBox widget on the 1st tab in the dialog, works fine.

Solution

You must add a new property hideMode to the dialog tab (not the combobox) in your custom text component, and set it’s value to offsets.  See the following screenshot for more details.

solution_screenshot

With this property set, the combobox width is maintained even when the dialog tab/panel is not visible.

reference: (43540/CQ5-29349)

VN:F [1.9.22_1171]
Was this helpful? Please rate the content.
Rating: 7.0/10 (1 vote cast)

Acrobat 10.1.4 crash using LiveCycle RightsManagement ES2 Extension for Microsoft Office

Issue
If you are using the Adobe LiveCycle RightsManagement ES2 Extension for Microsoft Office with Acrobat/Reader 10.1.4 then you may experience an application crash in Acrobat/Reader.  You will see the following error in the Eventviewer log:

Event Type:    Error
Event Source:    Application Error
Event Category:    None
Event ID:    1000
Date: …
Time: …  
User: … 
Computer: …
Description:
Faulting application acrobat.exe, version 10.1.4.38, faulting module acrobat.dll, version 10.1.4.38, fault address 0×00021212.

Reason

This is an issue with Acrobat/Reader 10.1.4 affecting compatibility with this LiveCycle plugin.

Solution

This issue is fixed in Acrobat/Reader 10.1.5 and later versions.

reference: (3322093)

VN:F [1.9.22_1171]
Was this helpful? Please rate the content.
Rating: 3.3/10 (3 votes cast)