Posts tagged "I18nManager"

CRXDE Lite: IllegalStateException: I18nManager not initialized

Issue

If you have installed a hotfix for CRX you may encounter problems accessing CRXDE Lite accompanied by the following error in the server.log:

*MARK * servletengine: Servlet threw exception:
java.lang.IllegalStateException: I18nManager not initialized
at com.day.crx.i18n.I18nManager.getInstance(I18nManager.java:59)
at org.apache.jsp.de.index_jsp._jspService(index_jsp.java:59)
at org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:98)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:802)
at org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:328)
at org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:315)
at org.apache.jasper.servlet.JspServlet.service(JspServlet.java:265)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:802)
at com.day.j2ee.servletengine.ServletRuntimeEnvironment.service(ServletRuntimeEnvironment.java:228)
at com.day.j2ee.servletengine.RequestDispatcherImpl.doFilter(RequestDispatcherImpl.java:315)
at com.day.j2ee.servletengine.RequestDispatcherImpl.service(RequestDispatcherImpl.java:334)
at com.day.j2ee.servletengine.RequestDispatcherImpl.service(RequestDispatcherImpl.java:378)
at com.day.j2ee.servletengine.ServletHandlerImpl.execute(ServletHandlerImpl.java:315)
at com.day.j2ee.servletengine.DefaultThreadPool$DequeueThread.run(DefaultThreadPool.java:134)
at java.lang.Thread.run(Thread.java:662)

Reason

This problem is usually caused by a version mis-match in JAR library files which were installed through the CRX hotfix.

Solution

You should check for JAR conflicts with the versions contained in the hotfix as listed in the hotfix release notes.

You may need to copy the JAR files from:

…\crx-quickstart\server\runtime\0\_crx\WEB-INF\lib

to here:

…\crx-quickstart\server\lib\container

If this is a non-quickstart installation, then there are instructions in the HF release notes to manually delete older versions of JAR libs:

“Make sure to delete previous versions of installed Java libraries below <crx-webapp>/WEB-INF/lib to avoid classloading issues.”

reference: (33826)

VN:F [1.9.22_1171]
Was this helpful? Please rate the content.
Rating: 10.0/10 (1 vote cast)